summaryrefslogtreecommitdiff
path: root/openembedded/packages/glibc
diff options
context:
space:
mode:
Diffstat (limited to 'openembedded/packages/glibc')
-rw-r--r--openembedded/packages/glibc/files/5090_all_stubs-rule-fix.patch39
-rw-r--r--openembedded/packages/glibc/files/etc/ld.so.conf2
-rw-r--r--openembedded/packages/glibc/glibc_2.3.5+cvs20050627.bb1
3 files changed, 41 insertions, 1 deletions
diff --git a/openembedded/packages/glibc/files/5090_all_stubs-rule-fix.patch b/openembedded/packages/glibc/files/5090_all_stubs-rule-fix.patch
new file mode 100644
index 000000000..c445a5296
--- /dev/null
+++ b/openembedded/packages/glibc/files/5090_all_stubs-rule-fix.patch
@@ -0,0 +1,39 @@
+Index: Makerules
+===================================================================
+RCS file: /cvs/glibc/libc/Makerules,v
+retrieving revision 1.430
+diff -u -r1.430 Makerules
+--- libc/Makerules 5 Mar 2005 19:24:32 -0000 1.430
++++ libc/Makerules 22 Apr 2005 18:31:27 -0000
+@@ -1390,15 +1390,26 @@
+ $(addprefix $(objpfx),$(extra-objs))
+ $(objpfx)stubs: $(objs-for-stubs)
+ ifneq (,$(strip $(objs-for-stubs)))
+- $(OBJDUMP) -h $^ | \
+- $(AWK) '/\.gnu\.glibc-stub\./ { \
+- sub(/\.gnu\.glibc-stub\./, "", $$2); \
+- stubs[$$2] = 1; } \
+- END { for (s in stubs) print "#define __stub_" s }' > $@T
++ $(stub-obj-list)
++ cat $@L | xargs \
++ $(OBJDUMP) -h | \
++ $(AWK) '/\.gnu\.glibc-stub\./ { \
++ sub(/\.gnu\.glibc-stub\./, "", $$2); \
++ stubs[$$2] = 1; } \
++ END { for (s in stubs) print "#define __stub_" s }' \
++ > $@T
++ -rm -f $@L
+ mv -f $@T $@
+ else
+ > $@
+ endif
++
++define stub-obj-list
++-@rm -f $@L
++-@echo "Generating stub obj list..."
++$(foreach file,$^,
++@echo >> $@L '$(file)')
++endef
+
+ # This information is not used for making distributions any more.
+ # But it's used by MakeTAGS for making TAGS files and the .pot files.
diff --git a/openembedded/packages/glibc/files/etc/ld.so.conf b/openembedded/packages/glibc/files/etc/ld.so.conf
index 3f9b41aab..fb1aab516 100644
--- a/openembedded/packages/glibc/files/etc/ld.so.conf
+++ b/openembedded/packages/glibc/files/etc/ld.so.conf
@@ -1,3 +1,3 @@
/usr/local/lib
/opt/QtPalmtop/lib
-
+/usr/X11R6/lib
diff --git a/openembedded/packages/glibc/glibc_2.3.5+cvs20050627.bb b/openembedded/packages/glibc/glibc_2.3.5+cvs20050627.bb
index d1925902e..c8f1d5684 100644
--- a/openembedded/packages/glibc/glibc_2.3.5+cvs20050627.bb
+++ b/openembedded/packages/glibc/glibc_2.3.5+cvs20050627.bb
@@ -53,6 +53,7 @@ SRC_URI = "http://familiar.handhelds.org/source/v0.8.3/stash_libc_sources.redhat
file://fhs-linux-paths.patch;patch=1 \
file://dl-cache-libcmp.patch;patch=1 \
file://ldsocache-varrun.patch;patch=1 \
+ file://5090_all_stubs-rule-fix.patch;patch=1 \
file://etc/ld.so.conf \
file://generate-supported.mk"