summaryrefslogtreecommitdiff
path: root/openembedded/packages/oh/osso-addressbook_0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'openembedded/packages/oh/osso-addressbook_0.0.bb')
-rwxr-xr-xopenembedded/packages/oh/osso-addressbook_0.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/openembedded/packages/oh/osso-addressbook_0.0.bb b/openembedded/packages/oh/osso-addressbook_0.0.bb
new file mode 100755
index 000000000..ab49add06
--- /dev/null
+++ b/openembedded/packages/oh/osso-addressbook_0.0.bb
@@ -0,0 +1,28 @@
+SECTION = "x11"
+DEPENDS = "glib-2.0 gtk+ libglade eds-dbus libgalago"
+PR = "r0"
+
+SRC_URI = "file:///tmp/${PN}-${PV}.tar.gz \
+ file://stock_contact.png \
+ file://stock_person.png \
+ file://index.theme"
+
+inherit autotools pkgconfig
+
+do_install_append () {
+ install -d ${D}/${datadir}/icons/hicolor/48x48/stock/net
+ install -d ${D}/${datadir}/icons/hicolor/48x48/stock/generic
+
+ install -m 0644 ${WORKDIR}/stock_contact.png ${D}/${datadir}/icons/hicolor/48x48/stock/net
+ install -m 0644 ${WORKDIR}/stock_person.png ${D}/${datadir}/icons/hicolor/48x48/stock/generic
+ install -m 0644 ${WORKDIR}/index.theme ${D}/${datadir}/icons/hicolor
+}
+
+FILES_${PN} += "${datadir}/icons/hicolor/48x48/apps/oh-contacts.png \
+ ${datadir}/icons/hicolor/48x48/stock/*/*.png \
+ ${datadir}/icons/hicolor/index.theme"
+
+pkg_postinst_${PN} () {
+ gtk-update-icon-cache /usr/share/icons/hicolor
+}
+