summaryrefslogtreecommitdiff
path: root/openembedded/packages
diff options
context:
space:
mode:
Diffstat (limited to 'openembedded/packages')
-rw-r--r--openembedded/packages/rxvt-unicode/files/makefile.patch20
-rw-r--r--openembedded/packages/rxvt-unicode/files/signedchar.patch11
-rw-r--r--openembedded/packages/rxvt-unicode/files/xwc.patch28
-rw-r--r--openembedded/packages/rxvt-unicode/rxvt-unicode-5.6/xwc.patch24
-rw-r--r--openembedded/packages/rxvt-unicode/rxvt-unicode_5.6.bb55
-rw-r--r--openembedded/packages/rxvt/rxvt-2.7.9/include.patch16
-rw-r--r--openembedded/packages/rxvt/rxvt_2.7.9.bb41
7 files changed, 138 insertions, 57 deletions
diff --git a/openembedded/packages/rxvt-unicode/files/makefile.patch b/openembedded/packages/rxvt-unicode/files/makefile.patch
new file mode 100644
index 000000000..86f82eeb4
--- /dev/null
+++ b/openembedded/packages/rxvt-unicode/files/makefile.patch
@@ -0,0 +1,20 @@
+--- ../rxvt-unicode-cvs-r0/rxvt-unicode/Makefile.in 2004-08-12 22:32:40 +01:00
++++ rxvt-unicode/Makefile.in 2004-12-24 03:09:00 +00:00
+@@ -9,7 +9,7 @@
+ first_rule: all
+ dummy:
+
+-subdirs = src doc src/test
++subdirs = src src/test
+ allsubdirs = W11 $(subdirs)
+
+ DIST = INSTALL README.configure configure Makefile Makefile.in ChangeLog
+@@ -24,7 +24,7 @@
+
+ #-------------------------------------------------------------------------
+
+-all allbin alldoc tags:
++all allbin tags:
+ @if test x@host_os@ = xcygwin; then (cd W11; ${MAKE} $@) || exit 1; fi
+ @for I in ${subdirs}; do (cd $$I; ${MAKE} $@) || exit 1; done
+
diff --git a/openembedded/packages/rxvt-unicode/files/signedchar.patch b/openembedded/packages/rxvt-unicode/files/signedchar.patch
new file mode 100644
index 000000000..6faa17514
--- /dev/null
+++ b/openembedded/packages/rxvt-unicode/files/signedchar.patch
@@ -0,0 +1,11 @@
+--- ../rxvt-unicode-cvs-r0/rxvt-unicode/src/command.C 2004-12-21 06:43:00 +00:00
++++ rxvt-unicode/src/command.C 2004-12-24 02:31:36 +00:00
+@@ -1862,7 +1862,7 @@
+ #endif /* NO_SCROLLBAR_REPORT */
+
+ {
+- char upordown = 0;
++ signed char upordown = 0;
+
+ if (scrollBar.style == R_SB_NEXT)
+ {
diff --git a/openembedded/packages/rxvt-unicode/files/xwc.patch b/openembedded/packages/rxvt-unicode/files/xwc.patch
new file mode 100644
index 000000000..7cf59656c
--- /dev/null
+++ b/openembedded/packages/rxvt-unicode/files/xwc.patch
@@ -0,0 +1,28 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- rxvt-unicode-4.8/src/screen.C~xwc.c
++++ rxvt-unicode-4.8/src/screen.C
+@@ -3058,7 +3058,7 @@
+ else
+ rxvt_warn ("can't get primary selection, ignoring.\n");
+
+-#if 0
++#ifdef HAVE_XWC
+ XTextProperty ct;
+
+ if (XwcTextListToTextProperty (display->display, &selection.text, 1, XStringStyle, &ct) >= 0)
+@@ -3632,9 +3632,11 @@
+ }
+ else
+ #endif
++#ifdef HAVE_XWC
+ if (XwcTextListToTextProperty (display->display, &cl, 1, (XICCEncodingStyle) style, &ct) >= 0)
+ freect = 1;
+ else
++#endif
+ {
+ /* if we failed to convert then send it raw */
+ ct.value = (unsigned char *)cl;
diff --git a/openembedded/packages/rxvt-unicode/rxvt-unicode-5.6/xwc.patch b/openembedded/packages/rxvt-unicode/rxvt-unicode-5.6/xwc.patch
new file mode 100644
index 000000000..eb87b84b2
--- /dev/null
+++ b/openembedded/packages/rxvt-unicode/rxvt-unicode-5.6/xwc.patch
@@ -0,0 +1,24 @@
+diff -urNd ../rxvt-unicode-5.3-r2/rxvt-unicode-5.3/src/screen.C rxvt-unicode-5.3/src/screen.C
+--- ../rxvt-unicode-5.3-r2/rxvt-unicode-5.3/src/screen.C 2005-02-22 21:39:10 +00:00
++++ rxvt-unicode-5.3/src/screen.C 2005-04-05 22:12:45 +01:00
+@@ -3064,7 +3064,7 @@
+ else
+ rxvt_warn ("can't get primary selection, ignoring.\n");
+
+-#if 0
++#ifdef HAVE_XWC
+ XTextProperty ct;
+
+ if (XwcTextListToTextProperty (display->display, &selection.text, 1, XStringStyle, &ct) >= 0)
+@@ -3648,9 +3648,11 @@
+ }
+ else
+ #endif
++#ifdef HAVE_XWC
+ if (XwcTextListToTextProperty (disp, &cl, 1, (XICCEncodingStyle) style, &ct) >= 0)
+ freect = 1;
+ else
++#endif
+ {
+ /* if we failed to convert then send it raw */
+ ct.value = (unsigned char *)cl;
diff --git a/openembedded/packages/rxvt-unicode/rxvt-unicode_5.6.bb b/openembedded/packages/rxvt-unicode/rxvt-unicode_5.6.bb
new file mode 100644
index 000000000..92915bf87
--- /dev/null
+++ b/openembedded/packages/rxvt-unicode/rxvt-unicode_5.6.bb
@@ -0,0 +1,55 @@
+SECTION = "x11/utils"
+DEPENDS = "x11 xt libxft"
+DESCRIPTION = "rxvt-unicode is a clone of the well known \
+terminal emulator rxvt, modified to store text in Unicode \
+(either UCS-2 or UCS-4) and to use locale-correct input and \
+output. It also supports mixing multiple fonts at the \
+same time, including Xft fonts."
+LICENSE = "GPL"
+SRC_URI = "http://dist.schmorp.de/rxvt-unicode/Attic/rxvt-unicode-${PV}.tar.bz2 \
+ file://xwc.patch;patch=1 \
+ file://signedchar.patch;patch=1"
+PR = "r2"
+
+inherit autotools update-alternatives
+
+PROVIDES = "virtual/x-terminal-emulator"
+ALTERNATIVE_NAME = "x-terminal-emulator"
+ALTERNATIVE_PATH = "${bindir}/rxvt"
+
+CFLAGS_append = " -fpermissive"
+
+EXTRA_OECONF = "--enable-menubar --enable-xim \
+ --enable-utmp --enable-wtmp --enable-lastlog \
+ --disable-strings --with-term=rxvt --enable-keepscrolling \
+ --enable-xft --with-name=rxvt --enable-frills \
+ --enable-swapscreen --enable-transparency \
+ --with-codesets=eu \
+ --enable-cursor-blink --enable-pointer-blank \
+ --enable-text-blink --enable-rxvt-scroll \
+ --enable-combining --enable-shared \
+ --enable-xgetdefault \
+ --with-x=${STAGING_LIBDIR}/.."
+EXTRA_OEMAKE = "'XINC=-I${STAGING_INCDIR}' \
+ 'XLIB=-L${STAGING_LIBDIR} -lX11'"
+
+do_configure () {
+ mv autoconf/configure.in . || true
+ rm autoconf/libtool.m4
+ libtoolize --force
+ autotools_do_configure
+ echo '#define RXVT_UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
+ echo '#define RXVT_WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
+ echo '#define RXVT_LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
+ echo '#define HAVE_XLOCALE 1' >> config.h
+}
+
+do_compile () {
+ if test -e ${S}/${HOST_SYS}-libtool; then
+ LIBTOOL=${S}/${HOST_SYS}-libtool
+ else
+ LIBTOOL=${S}/libtool
+ fi
+ # docs need "yodl" and I have no idea what that is
+ oe_runmake -C src "LIBTOOL=$LIBTOOL"
+}
diff --git a/openembedded/packages/rxvt/rxvt-2.7.9/include.patch b/openembedded/packages/rxvt/rxvt-2.7.9/include.patch
deleted file mode 100644
index f7542843b..000000000
--- a/openembedded/packages/rxvt/rxvt-2.7.9/include.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -urN rxvt.orig/src/rxvtlib.h.in rxvt/src/rxvtlib.h.in
---- rxvt.orig/src/rxvtlib.h.in 2003-03-25 19:13:53.000000000 -0500
-+++ rxvt/src/rxvtlib.h.in 2004-04-03 20:35:13.000000000 -0500
-@@ -43,7 +43,11 @@
- #include <sys/wait.h>
- #include <sys/stat.h>
-
--#include <X11/Intrinsic.h> /* Xlib, Xutil, Xresource, Xfuncproto */
-+#include <X11/Xlib.h>
-+#include <X11/Xutil.h>
-+#include <X11/Xresource.h>
-+#include <X11/Xproto.h>
-+#include <X11/region.h>
-
- #ifdef ENABLE_XFT
- #include <X11/Xft/Xft.h>
diff --git a/openembedded/packages/rxvt/rxvt_2.7.9.bb b/openembedded/packages/rxvt/rxvt_2.7.9.bb
deleted file mode 100644
index c201d16f8..000000000
--- a/openembedded/packages/rxvt/rxvt_2.7.9.bb
+++ /dev/null
@@ -1,41 +0,0 @@
-DESCRIPTION = "Well known terminal emulator"
-SECTION = "x11/utils"
-PR = "r1"
-DEPENDS = "x11 libxft"
-LICENSE = "GPL"
-SRC_URI = "${HANDHELDS_CVS};module=apps/rxvt \
- file://include.patch;patch=1"
-
-inherit autotools update-alternatives
-
-ALTERNATIVE_NAME = "x-terminal-emulator"
-ALTERNATIVE_PATH = "${bindir}/rxvt-2.7.9"
-
-S = ${WORKDIR}/rxvt
-
-EXTRA_OECONF = "--disable-menubar --disable-xim \
- --enable-utmp --enable-wtmp --enable-lastlog \
- --disable-strings --with-term=rxvt --enable-keepscrolling \
- --with-xft --with-name=rxvt --enable-frills \
- --enable-swapscreen --enable-transparency \
- --with-codesets=eu,jp \
- --enable-cursor-blink --enable-pointer-blank \
- --enable-text-blink --enable-plain-scroll \
- --enable-combining --enable-shared \
- --with-x=${STAGING_LIBDIR}/.."
-
-EXTRA_OEMAKE = "'XINC=-I${STAGING_INCDIR}' \
- 'XLIB=-L${STAGING_LIBDIR} -lX11 -lXft'"
-
-do_configure () {
- mv autoconf/configure.in . || true
- rm autoconf/libtool.m4
- libtoolize --force
- autotools_do_configure
- echo '#define RXVT_UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
- echo '#define RXVT_WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
- echo '#define RXVT_LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
- echo '#define HAVE_XLOCALE 1' >> config.h
- echo '#define HAVE_UTMP_H 1' >> config.h
- echo '#define HAVE_TTYSLOT 1' >> config.h
-}