summaryrefslogtreecommitdiff
path: root/openembedded
diff options
context:
space:
mode:
Diffstat (limited to 'openembedded')
-rw-r--r--openembedded/packages/libmatchbox/libmatchbox.inc6
-rw-r--r--openembedded/packages/matchbox-wm/matchbox-wm_svn.bb6
-rw-r--r--openembedded/packages/meta/meta-oh.bb9
3 files changed, 13 insertions, 8 deletions
diff --git a/openembedded/packages/libmatchbox/libmatchbox.inc b/openembedded/packages/libmatchbox/libmatchbox.inc
index 44d2efde7..e8700cb7b 100644
--- a/openembedded/packages/libmatchbox/libmatchbox.inc
+++ b/openembedded/packages/libmatchbox/libmatchbox.inc
@@ -1,12 +1,12 @@
SECTION = "x11/libs"
DESCRIPTION = "Matchbox window manager core library"
LICENSE = "GPL"
-DEPENDS = "x11 xext expat libxft pango jpeg libpng zlib libxsettings-client"
-PR="r1"
+DEPENDS = "x11 xext expat libxft jpeg libpng zlib libxsettings-client"
+PR="r2"
inherit autotools pkgconfig
-EXTRA_OECONF = "--enable-jpeg --enable-expat --enable-pango --enable-xsettings"
+EXTRA_OECONF = "--enable-jpeg --enable-expat --enable-xsettings"
S = "${WORKDIR}/libmatchbox-${PV}"
diff --git a/openembedded/packages/matchbox-wm/matchbox-wm_svn.bb b/openembedded/packages/matchbox-wm/matchbox-wm_svn.bb
index 5ac11d212..0983c6d67 100644
--- a/openembedded/packages/matchbox-wm/matchbox-wm_svn.bb
+++ b/openembedded/packages/matchbox-wm/matchbox-wm_svn.bb
@@ -1,10 +1,10 @@
SECTION = "x11/wm"
DESCRIPTION = "Matchbox window manager"
LICENSE = "GPL"
-DEPENDS = "libmatchbox x11 xext xcomposite libxfixes xdamage libxrender startup-notification expat matchbox-common"
+DEPENDS = "libmatchbox x11 xext xcomposite libxfixes xdamage libxrender startup-notification expat matchbox-common gconf"
RDEPENDS = "matchbox-common"
PV = "0.9.5cvs${CVSDATE}"
-PR = "r2"
+PR = "r3"
DEFAULT_PREFERENCE = "-1"
SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=matchbox-window-manager;proto=http \
@@ -26,7 +26,7 @@ FILES_${PN} = "${bindir} \
${datadir}/themes/Default/matchbox \
${datadir}/themes/MBOpus/matchbox"
-EXTRA_OECONF = "--enable-composite --enable-startup-notification --disable-xrm --enable-expat"
+EXTRA_OECONF = "--enable-composite --enable-startup-notification --disable-xrm --enable-expat --enable-gconf"
do_install_prepend() {
install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig
diff --git a/openembedded/packages/meta/meta-oh.bb b/openembedded/packages/meta/meta-oh.bb
index 5839ae0c6..49f8dcf99 100644
--- a/openembedded/packages/meta/meta-oh.bb
+++ b/openembedded/packages/meta/meta-oh.bb
@@ -2,7 +2,7 @@ PACKAGES = "oh-base-depends oh-task-base"
# oh-task-base
DESCRIPTION = "Meta-package for OpenHand Palmtop Environment"
MAINTAINER = "Richard Purdie <richard@openedhand.com>"
-PR = "r2"
+PR = "r3"
ALLOW_EMPTY = "1"
@@ -36,7 +36,12 @@ oh-task-base = "\
# detect-stylus \
# xrdb \
-RDEPENDS_oh-task-base := "${oh-task-base}"
+RDEPENDS_oh-task-base := "${oh-task-base} \
+ gdk-pixbuf-loader-png \
+ gdk-pixbuf-loader-xpm \
+ gdk-pixbuf-loader-jpeg \
+ pango-module-basic-x \
+ pango-module-basic-fc"
DEPENDS += " ${oh-task-base}"