From 0809f98e995d3a2ce24ad25bade3dcd5154061fd Mon Sep 17 00:00:00 2001
From: Koen Kooi <koen@dominion.thruhere.net>
Date: Fri, 4 Nov 2011 15:26:53 +0100
Subject: lighttpd 1.4.29: rename index.html to avoid clashes with DL_DIR

As Martin Jansa pointed out before, bitbake will silently peek in DL_DIR before FILESPATH and use files from there if found.

The failure mode for lighttpd involves a 404 redirect placing index.html into DL_DIR, which will end up in the lighttpd packages. In my specific case iproute2 hit the linuxfoundation 404 redirect so lighttpd.ipk now serves the linuxfoundation frontpage :)

Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
---
 meta/recipes-extended/lighttpd/files/index.html          | 1 -
 meta/recipes-extended/lighttpd/files/index.html.lighttpd | 1 +
 meta/recipes-extended/lighttpd/lighttpd_1.4.29.bb        | 6 +++---
 3 files changed, 4 insertions(+), 4 deletions(-)
 delete mode 100644 meta/recipes-extended/lighttpd/files/index.html
 create mode 100644 meta/recipes-extended/lighttpd/files/index.html.lighttpd

diff --git a/meta/recipes-extended/lighttpd/files/index.html b/meta/recipes-extended/lighttpd/files/index.html
deleted file mode 100644
index cd25bf17b..000000000
--- a/meta/recipes-extended/lighttpd/files/index.html
+++ /dev/null
@@ -1 +0,0 @@
-<html><body><h1>It works!</h1></body></html>
\ No newline at end of file
diff --git a/meta/recipes-extended/lighttpd/files/index.html.lighttpd b/meta/recipes-extended/lighttpd/files/index.html.lighttpd
new file mode 100644
index 000000000..cd25bf17b
--- /dev/null
+++ b/meta/recipes-extended/lighttpd/files/index.html.lighttpd
@@ -0,0 +1 @@
+<html><body><h1>It works!</h1></body></html>
\ No newline at end of file
diff --git a/meta/recipes-extended/lighttpd/lighttpd_1.4.29.bb b/meta/recipes-extended/lighttpd/lighttpd_1.4.29.bb
index c1d5f81f6..9fdb5f692 100644
--- a/meta/recipes-extended/lighttpd/lighttpd_1.4.29.bb
+++ b/meta/recipes-extended/lighttpd/lighttpd_1.4.29.bb
@@ -16,10 +16,10 @@ RDEPENDS_${PN} += " \
                lighttpd-module-staticfile \
 "
 
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${PV}.tar.bz2 \
-        file://index.html \
+        file://index.html.lighttpd \
         file://lighttpd.conf \
         file://lighttpd \
 "
@@ -48,7 +48,7 @@ do_install_append() {
     install -d ${D}${sysconfdir}/init.d ${D}/www/logs ${D}/www/pages/dav ${D}/www/var
     install -m 0755 ${WORKDIR}/lighttpd ${D}${sysconfdir}/init.d
     install -m 0755 ${WORKDIR}/lighttpd.conf ${D}${sysconfdir}
-    install -m 0644 ${WORKDIR}/index.html ${D}/www/pages/
+    install -m 0644 ${WORKDIR}/index.html.lighttpd ${D}/www/pages/index.html
 }
 
 FILES_${PN} += "${sysconfdir} /www"
-- 
cgit v1.2.3