From 1900143c5bd02e780c87c8d1574f3da45350e8b8 Mon Sep 17 00:00:00 2001
From: Ross Burton <ross@openedhand.com>
Date: Fri, 3 Aug 2007 16:25:57 +0000
Subject: Upgrade hal-info and hal to 0.5.9.1

git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2355 311d38ba-8fff-0310-9ca6-ca027cbcb966
---
 meta/conf/distro/poky.conf               |  4 +-
 meta/packages/hal/files/sg-inhibit.patch | 24 +++++++++
 meta/packages/hal/hal_0.5.9.1.bb         | 82 +++++++++++++++++++++++++++++
 meta/packages/hal/hal_0.5.9.bb           | 88 --------------------------------
 4 files changed, 108 insertions(+), 90 deletions(-)
 create mode 100644 meta/packages/hal/files/sg-inhibit.patch
 create mode 100644 meta/packages/hal/hal_0.5.9.1.bb
 delete mode 100644 meta/packages/hal/hal_0.5.9.bb

diff --git a/meta/conf/distro/poky.conf b/meta/conf/distro/poky.conf
index 1344a4a9a..56441d431 100644
--- a/meta/conf/distro/poky.conf
+++ b/meta/conf/distro/poky.conf
@@ -111,7 +111,7 @@ SRCDATE_oh-puzzles = "20070714"
 SRCDATE_libowl = "20070715"
 SRCDATE_libxcalibrate = "20070607"
 SRCDATE_calibrateproto = "20070607"
-SRCDATE_hal-info = "20070513"
+SRCDATE_hal-info = "20070727"
 SRCDATE_gtk-theme-torturer = "20070529"
 SRCDATE_libsyncml = "20070529"
 SRCDATE_matchbox-applet-light = "20070529"
@@ -181,7 +181,7 @@ PREFERRED_VERSION_xprop ?= "0.0+cvs${SRCDATE}"
 PREFERRED_VERSION_xst ?= "0.15"
 PREFERRED_VERSION_oprofile ?= "0.9.2+cvs${SRCDATE}"
 PREFERRED_VERSION_elfutils ?= "0.89"
-PREFERRED_VERSION_hal ?= "0.5.9"
+PREFERRED_VERSION_hal ?= "0.5.9.1"
 
 require conf/distro/include/preferred-xorg-versions.inc
 
diff --git a/meta/packages/hal/files/sg-inhibit.patch b/meta/packages/hal/files/sg-inhibit.patch
new file mode 100644
index 000000000..f0cc41448
--- /dev/null
+++ b/meta/packages/hal/files/sg-inhibit.patch
@@ -0,0 +1,24 @@
+--- hal-0.5.9.1/hald/linux/probing/linux_dvd_rw_utils.c.old	2007-08-03 17:24:12.000000000 +0100
++++ hal-0.5.9.1/hald/linux/probing/linux_dvd_rw_utils.c	2007-08-03 17:25:06.000000000 +0100
+@@ -58,6 +58,10 @@
+ 
+ #include "linux_dvd_rw_utils.h"
+ 
++#if defined(SG_FLAG_UNUSED_LUN_INHIBIT)
++#  define SG_FLAG_LUN_INHIBIT SG_FLAG_UNUSED_LUN_INHIBIT
++#endif
++
+ typedef enum {
+ 	NONE = CGC_DATA_NONE,	// 3
+ 	READ = CGC_DATA_READ,	// 2
+@@ -153,8 +153,8 @@
+ 		errno = EIO;
+ 		ret = -1;
+ 		if (cmd->sg_io.masked_status & CHECK_CONDITION) {
+-			CREAM_ON_ERRNO (cmd->sg_io.sbp);
+-			ret = ERRCODE (cmd->sg_io.sbp);
++			CREAM_ON_ERRNO ((char*)cmd->sg_io.sbp);
++			ret = ERRCODE ((char*)cmd->sg_io.sbp);
+ 			if (ret == 0)
+ 				ret = -1;
+ 		}
diff --git a/meta/packages/hal/hal_0.5.9.1.bb b/meta/packages/hal/hal_0.5.9.1.bb
new file mode 100644
index 000000000..4e3c7ed92
--- /dev/null
+++ b/meta/packages/hal/hal_0.5.9.1.bb
@@ -0,0 +1,82 @@
+DESCRIPTION = "Hardware Abstraction Layer"
+HOMEPAGE = "http://freedesktop.org/Software/hal"
+SECTION = "unknown"
+LICENSE = "GPL LGPL AFL"
+
+DEPENDS = "virtual/kernel dbus-glib udev intltool-native expat libusb"
+RDEPENDS += "udev hal-info"
+RRECOMMENDS = "udev-utils"
+
+SRC_URI = "http://freedesktop.org/~david/dist/hal-${PV}.tar.gz \
+        file://sg-inhibit.patch;patch=1 \
+        file://99_hal"
+
+S = "${WORKDIR}/hal-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--with-hwdata=${datadir}/hwdata \
+                --with-expat=${STAGING_LIBDIR}/.. \
+                --with-dbus-sys=${sysconfdir}/dbus-1/system.d \
+                --with-hotplug=${sysconfdir}/hotplug.d \
+                --disable-docbook-docs \
+                --disable-policy-kit \
+                --disable-acpi --disable-acpi-acpid --disable-acpi-proc \
+                --disable-sonypic \
+                --disable-pmu --disable-pci \
+                --disable-pci-ids --disable-pnp-ids \
+                "
+
+do_install_append() {
+	install -d ${D}/etc/default/volatiles
+	install -m 0644 ${WORKDIR}/99_hal ${D}/etc/default/volatiles
+}
+
+do_stage() {
+        autotools_stage_all
+        install -d ${STAGING_LIBDIR}
+        install -m 755 libhal/.libs/libhal.so.1.0.0 ${STAGING_LIBDIR}/libhal.so
+        install -m 755 libhal-storage/.libs/libhal-storage.so.1.0.0 ${STAGING_LIBDIR}/libhal-storage.so
+}
+
+# At the time the postinst runs, dbus might not be setup so only restart if running
+pkg_postinst_hal () {
+	# can't do this offline
+	if [ "x$D" != "x" ]; then
+		exit 1
+	fi
+
+	/etc/init.d/populate-volatile.sh update
+
+	grep haldaemon /etc/group || addgroup haldaemon
+	grep haldaemon /etc/passwd || adduser --disabled-password --system --home /var/run/hald --no-create-home haldaemon --ingroup haldaemon -g HAL
+
+	DBUSPID=`pidof dbus-daemon`
+
+	if [ "x$DBUSPID" != "x" ]; then
+		/etc/init.d/dbus-1 force-reload
+	fi
+}
+
+pkg_postrm_hal () {
+	deluser haldaemon || true
+	delgroup haldaemon || true
+}
+
+FILES_${PN} = "${sysconfdir} \
+                ${bindir}/lshal \
+                ${bindir}/hal-find-by-capability \
+                ${bindir}/hal-find-by-property \
+                ${bindir}/hal-device  \
+                ${bindir}/hal-get-property \
+                ${bindir}/hal-set-property  \
+                ${bindir}/hal-lock  \
+                ${bindir}/hal-is-caller-locked-out  \
+                ${bindir}/hal-disable-polling  \
+                ${sbindir} \
+                ${libdir}/libhal.so.* \
+                ${libdir}/libhal-storage.so.* \
+                ${libdir}/hal \
+                ${libexecdir} \
+                ${datadir}/hal/fdi \
+                ${datadir}/hal/scripts"
diff --git a/meta/packages/hal/hal_0.5.9.bb b/meta/packages/hal/hal_0.5.9.bb
deleted file mode 100644
index 2e8ffd96e..000000000
--- a/meta/packages/hal/hal_0.5.9.bb
+++ /dev/null
@@ -1,88 +0,0 @@
-DESCRIPTION = "Hardware Abstraction Layer"
-HOMEPAGE = "http://freedesktop.org/Software/hal"
-SECTION = "unknown"
-LICENSE = "GPL LGPL AFL"
-
-DEPENDS = "virtual/kernel dbus-glib udev intltool expat libusb"
-RDEPENDS += "udev hal-info"
-#RDEPENDS_hal-device-manager = "python hal python-pygnome"
-RRECOMMENDS = "udev-utils"
-
-PR = "r1"
-
-SRC_URI = "http://freedesktop.org/~david/dist/hal-${PV}.tar.gz \
-        file://autoconf.diff;patch=1 \
-        file://99_hal"
-
-S = "${WORKDIR}/hal-${PV}"
-
-inherit autotools pkgconfig
-
-EXTRA_OECONF = "--with-hwdata=${datadir}/hwdata \
-                --with-expat=${STAGING_LIBDIR}/.. \
-                --with-dbus-sys=${sysconfdir}/dbus-1/system.d \
-                --with-hotplug=${sysconfdir}/hotplug.d \
-                --disable-docbook-docs \
-                --disable-policy-kit \
-                --disable-acpi --disable-pmu --disable-pci \
-                --disable-pci-ids --disable-pnp-ids \
-                "
-
-do_install_append() {
-	install -d ${D}/etc/default/volatiles
-	install -m 0644 ${WORKDIR}/99_hal ${D}/etc/default/volatiles
-}
-
-do_stage() {
-        autotools_stage_all
-        install -d ${STAGING_LIBDIR}
-        install -m 755 libhal/.libs/libhal.so.1.0.0 ${STAGING_LIBDIR}/libhal.so
-        install -m 755 libhal-storage/.libs/libhal-storage.so.1.0.0 ${STAGING_LIBDIR}/libhal-storage.so
-}
-
-# At the time the postinst runs, dbus might not be setup so only restart if running
-pkg_postinst_hal () {
-	# can't do this offline
-	if [ "x$D" != "x" ]; then
-		exit 1
-	fi
-
-	/etc/init.d/populate-volatile.sh update
-
-	grep haldaemon /etc/group || addgroup haldaemon
-	grep haldaemon /etc/passwd || adduser --disabled-password --system --home /var/run/hald --no-create-home haldaemon --ingroup haldaemon -g HAL
-
-	DBUSPID=`pidof dbus-daemon`
-
-	if [ "x$DBUSPID" != "x" ]; then
-		/etc/init.d/dbus-1 force-reload
-	fi
-}
-
-pkg_postrm_hal () {
-	deluser haldaemon || true
-	delgroup haldaemon || true
-}
-
-#PACKAGES += "hal-device-manager"
-
-#FILES_hal-device-manager = " \
-#               ${datadir}/hal/device-manager/ \
-#               ${bindir}/hal-device-manager"
-
-FILES_${PN} = "${sysconfdir} \
-                ${bindir}/lshal \
-                ${bindir}/hal-find-by-capability \
-                ${bindir}/hal-find-by-property \
-                ${bindir}/hal-device  \
-                ${bindir}/hal-get-property \
-                ${bindir}/hal-set-property  \
-                ${bindir}/hal-lock  \
-                ${bindir}/hal-is-caller-locked-out  \
-                ${sbindir} \
-                ${libdir}/libhal.so.* \
-                ${libdir}/libhal-storage.so.* \
-                ${libdir}/hal \
-                ${libexecdir} \
-                ${datadir}/hal/fdi \
-                ${datadir}/hal/scripts"
-- 
cgit v1.2.3