From 46f18ddf41dc4be642978d0052a2118177c71ba2 Mon Sep 17 00:00:00 2001
From: Richard Purdie <richard@openedhand.com>
Date: Fri, 22 Dec 2006 11:31:21 +0000
Subject: glibc: Fix locale generation

git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1077 311d38ba-8fff-0310-9ca6-ca027cbcb966
---
 meta/packages/glibc/glibc-package.bbclass | 26 +++++++++++++-------------
 meta/packages/glibc/glibc_2.4.bb          |  2 ++
 meta/packages/glibc/glibc_2.5.bb          |  2 ++
 3 files changed, 17 insertions(+), 13 deletions(-)

diff --git a/meta/packages/glibc/glibc-package.bbclass b/meta/packages/glibc/glibc-package.bbclass
index 84541c69f..b8f527f97 100644
--- a/meta/packages/glibc/glibc-package.bbclass
+++ b/meta/packages/glibc/glibc-package.bbclass
@@ -123,23 +123,23 @@ rm -rf ${TMP_LOCALE}
 }
 
 python __anonymous () {
-	enabled = bb.data.getVar("ENABLE_BINARY_LOCALE_GENERATION", d, 1)
+    enabled = bb.data.getVar("ENABLE_BINARY_LOCALE_GENERATION", d, 1)
 
-	if enabled and int(enabled):
-		import re
+    if enabled and int(enabled):
+        import re
 
-		target_arch = bb.data.getVar("TARGET_ARCH", d, 1)
-		binary_arches = bb.data.getVar("BINARY_LOCALE_ARCHES", d, 1) or ""
+        target_arch = bb.data.getVar("TARGET_ARCH", d, 1)
+        binary_arches = bb.data.getVar("BINARY_LOCALE_ARCHES", d, 1) or ""
 
-		for regexp in binary_arches.split(" "):
-			r = re.compile(regexp)
+        for regexp in binary_arches.split(" "):
+            r = re.compile(regexp)
 
-			if r.match(target_arch):
-				depends = bb.data.getVar("DEPENDS", d, 1)
-				depends = "%s qemu-native" % depends
-				bb.data.setVar("DEPENDS", depends, d)
-				bb.data.setVar("GLIBC_INTERNAL_USE_BINARY_LOCALE", "1", d)
-				break
+            if r.match(target_arch):
+                depends = bb.data.getVar("DEPENDS", d, 1)
+                depends = "%s qemu-native" % depends
+                bb.data.setVar("DEPENDS", depends, d)
+                bb.data.setVar("GLIBC_INTERNAL_USE_BINARY_LOCALE", "1", d)
+                break
 }
 
 do_prep_locale_tree() {
diff --git a/meta/packages/glibc/glibc_2.4.bb b/meta/packages/glibc/glibc_2.4.bb
index 857af9082..fe8abe6c5 100644
--- a/meta/packages/glibc/glibc_2.4.bb
+++ b/meta/packages/glibc/glibc_2.4.bb
@@ -18,6 +18,8 @@ GLIBC_EXTRA_OECONF ?= ""
 
 GLIBC_BROKEN_LOCALES = "sid_ET tr_TR mn_MN gez_ET bn_BD gez_ER te_IN"
 
+LIMIT_BUILT_LOCALES = "en_GB"
+
 #
 # For now, we will skip building of a gcc package if it is a uclibc one
 # and our build is not a uclibc one, and we skip a glibc one if our build
diff --git a/meta/packages/glibc/glibc_2.5.bb b/meta/packages/glibc/glibc_2.5.bb
index d3c6ab02e..24a91f5b0 100644
--- a/meta/packages/glibc/glibc_2.5.bb
+++ b/meta/packages/glibc/glibc_2.5.bb
@@ -14,6 +14,8 @@ GLIBC_EXTRA_OECONF ?= ""
 
 GLIBC_BROKEN_LOCALES = "sid_ET tr_TR mn_MN gez_ET gez_ER bn_BD te_IN"
 
+LIMIT_BUILT_LOCALES = "en_GB"
+
 #
 # For now, we will skip building of a gcc package if it is a uclibc one
 # and our build is not a uclibc one, and we skip a glibc one if our build
-- 
cgit v1.2.3