From 597f73ebe7890f67ad02f8ac54acc3280330b097 Mon Sep 17 00:00:00 2001
From: Chris Lord <chris@openedhand.com>
Date: Thu, 22 Dec 2005 16:50:56 +0000
Subject: Add packages for Contacts 0.1 and svn

git-svn-id: https://svn.o-hand.com/repos/poky@203 311d38ba-8fff-0310-9ca6-ca027cbcb966
---
 openembedded/packages/contacts/contacts_0.0.bb | 31 ----------------------
 openembedded/packages/contacts/contacts_0.1.bb | 32 +++++++++++++++++++++++
 openembedded/packages/contacts/contacts_svn.bb | 36 ++++++++++++++++++++++++++
 3 files changed, 68 insertions(+), 31 deletions(-)
 delete mode 100755 openembedded/packages/contacts/contacts_0.0.bb
 create mode 100755 openembedded/packages/contacts/contacts_0.1.bb
 create mode 100755 openembedded/packages/contacts/contacts_svn.bb

diff --git a/openembedded/packages/contacts/contacts_0.0.bb b/openembedded/packages/contacts/contacts_0.0.bb
deleted file mode 100755
index ef2d1b1b9..000000000
--- a/openembedded/packages/contacts/contacts_0.0.bb
+++ /dev/null
@@ -1,31 +0,0 @@
-LICENSE = "LGPL"
-SECTION = "x11"
-DEPENDS = "glib-2.0 gtk+ libglade eds-dbus"
-MAINTAINER = "Chris Lord <chris@openedhand.com>"
-DESCRIPTION = "Contacts is an address-book application."
-PR = "r5"
-
-SRC_URI = "file:///tmp/${PN}-${PV}.tar.gz \
-	   file://stock_contact.png \
-	   file://stock_person.png \
-	   file://index.theme"
-
-inherit autotools pkgconfig
-
-do_install_append () {
-	install -d ${D}/${datadir}/icons/hicolor/48x48/stock/net
-	install -d ${D}/${datadir}/icons/hicolor/48x48/stock/generic
-
-	install -m 0644 ${WORKDIR}/stock_contact.png ${D}/${datadir}/icons/hicolor/48x48/stock/net
-	install -m 0644 ${WORKDIR}/stock_person.png ${D}/${datadir}/icons/hicolor/48x48/stock/generic
-	install -m 0644 ${WORKDIR}/index.theme ${D}/${datadir}/icons/hicolor
-}
-
-FILES_${PN} += "${datadir}/icons/hicolor/48x48/apps/oh-contacts.png \
-		${datadir}/icons/hicolor/48x48/stock/*/*.png \
-		${datadir}/icons/hicolor/index.theme"
-
-pkg_postinst_${PN} () {
-	gtk-update-icon-cache /usr/share/icons/hicolor
-}
-
diff --git a/openembedded/packages/contacts/contacts_0.1.bb b/openembedded/packages/contacts/contacts_0.1.bb
new file mode 100755
index 000000000..aff86a1c6
--- /dev/null
+++ b/openembedded/packages/contacts/contacts_0.1.bb
@@ -0,0 +1,32 @@
+LICENSE = "LGPL"
+SECTION = "x11"
+DEPENDS = "glib-2.0 gtk+ libglade eds-dbus"
+MAINTAINER = "Chris Lord <chris@openedhand.com>"
+DESCRIPTION = "Contacts is an address-book application."
+
+SRC_URI = "svn://svn.o-hand.com/repos/${PN}/tags;module=release-0.1;proto=http \
+	   file://stock_contact.png \
+	   file://stock_person.png \
+	   file://index.theme"
+
+inherit autotools pkgconfig
+
+S = "${WORKDIR}/release-0.1"
+
+do_install_append () {
+	install -d ${D}/${datadir}/icons/hicolor/48x48/stock/net
+	install -d ${D}/${datadir}/icons/hicolor/48x48/stock/generic
+
+	install -m 0644 ${WORKDIR}/stock_contact.png ${D}/${datadir}/icons/hicolor/48x48/stock/net
+	install -m 0644 ${WORKDIR}/stock_person.png ${D}/${datadir}/icons/hicolor/48x48/stock/generic
+	install -m 0644 ${WORKDIR}/index.theme ${D}/${datadir}/icons/hicolor
+}
+
+FILES_${PN} += "${datadir}/icons/hicolor/48x48/apps/oh-contacts.png \
+		${datadir}/icons/hicolor/48x48/stock/*/*.png \
+		${datadir}/icons/hicolor/index.theme"
+
+pkg_postinst_${PN} () {
+	gtk-update-icon-cache /usr/share/icons/hicolor
+}
+
diff --git a/openembedded/packages/contacts/contacts_svn.bb b/openembedded/packages/contacts/contacts_svn.bb
new file mode 100755
index 000000000..121f256a4
--- /dev/null
+++ b/openembedded/packages/contacts/contacts_svn.bb
@@ -0,0 +1,36 @@
+LICENSE = "LGPL"
+SECTION = "x11"
+DEPENDS = "glib-2.0 gtk+ libglade eds-dbus gnome-vfs"
+RDEPENDS = "gnome-vfs-plugin-file"
+RRECOMMENDS = "gnome-vfs-plugin-http"
+MAINTAINER = "Chris Lord <chris@openedhand.com>"
+DESCRIPTION = "Contacts is an address-book application."
+
+SRC_URI = "svn://svn.o-hand.com/repos/${PN};module=trunk;proto=http \
+	   file://stock_contact.png \
+	   file://stock_person.png \
+	   file://index.theme"
+
+inherit autotools pkgconfig
+
+S = "${WORKDIR}/trunk"
+
+EXTRA_OECONF = "--enable-gnome-vfs"
+
+do_install_append () {
+	install -d ${D}/${datadir}/icons/hicolor/48x48/stock/net
+	install -d ${D}/${datadir}/icons/hicolor/48x48/stock/generic
+
+	install -m 0644 ${WORKDIR}/stock_contact.png ${D}/${datadir}/icons/hicolor/48x48/stock/net
+	install -m 0644 ${WORKDIR}/stock_person.png ${D}/${datadir}/icons/hicolor/48x48/stock/generic
+	install -m 0644 ${WORKDIR}/index.theme ${D}/${datadir}/icons/hicolor
+}
+
+FILES_${PN} += "${datadir}/icons/hicolor/48x48/apps/oh-contacts.png \
+		${datadir}/icons/hicolor/48x48/stock/*/*.png \
+		${datadir}/icons/hicolor/index.theme"
+
+pkg_postinst_${PN} () {
+	gtk-update-icon-cache /usr/share/icons/hicolor
+}
+
-- 
cgit v1.2.3