From 6ff6f31067e9720cddc7d8d3f3c112ddfede6b2e Mon Sep 17 00:00:00 2001
From: Chris Lord <chris@openedhand.com>
Date: Thu, 29 Sep 2005 12:44:24 +0000
Subject: Add staging for loudmouth

git-svn-id: https://svn.o-hand.com/repos/poky@64 311d38ba-8fff-0310-9ca6-ca027cbcb966
---
 openembedded/packages/loudmouth/loudmouth_1.0.1.bb | 7 +++++++
 1 file changed, 7 insertions(+)

diff --git a/openembedded/packages/loudmouth/loudmouth_1.0.1.bb b/openembedded/packages/loudmouth/loudmouth_1.0.1.bb
index a9264e0b7..ca8dd2777 100755
--- a/openembedded/packages/loudmouth/loudmouth_1.0.1.bb
+++ b/openembedded/packages/loudmouth/loudmouth_1.0.1.bb
@@ -2,8 +2,15 @@ LICENSE = "LGPL"
 DEPENDS = "glib-2.0 gnutls"
 MAINTAINER = "Chris Lord <chris@openedhand.com>"
 DESCRIPTION = "Loudmouth is a lightweight and easy-to-use C library for programming with the Jabber protocol."
+PR = "r1"
 
 SRC_URI = "http://ftp.imendio.com/pub/imendio/${PN}/src/${PN}-${PV}.tar.gz"
 
 inherit autotools pkgconfig
 
+do_stage() {
+	oe_libinstall -so -C loudmouth libloudmouth-1 ${STAGING_LIBDIR}
+
+        install -d ${STAGING_INCDIR}/${PN}/
+        install -m 0644 ${S}/${PN}/*.h ${STAGING_INCDIR}/${PN}/
+}
-- 
cgit v1.2.3