From 7b281a392417cf9633be8fb21adaf6bf7fb896bd Mon Sep 17 00:00:00 2001
From: Richard Purdie <rpurdie@linux.intel.com>
Date: Mon, 5 Jan 2009 22:00:22 +0000
Subject: native.bbclass: Add virtclass-native to OVERRIDES and use in fakeroot
 to function correctly

---
 meta/classes/native.bbclass              | 1 +
 meta/packages/fakeroot/fakeroot_1.9.4.bb | 1 +
 2 files changed, 2 insertions(+)

diff --git a/meta/classes/native.bbclass b/meta/classes/native.bbclass
index 91ea9b547..98b62a054 100644
--- a/meta/classes/native.bbclass
+++ b/meta/classes/native.bbclass
@@ -129,5 +129,6 @@ python __anonymous () {
             #else:
             #    bb.note("%s has rouge PROVIDES of %s which doesn't end in -sdk?" % (pn, prov))
     bb.data.setVar("PROVIDES", provides, d)
+    bb.data.setVar("OVERRIDES", bb.data.getVar("OVERRIDES", d, False) + ":virtclass-native", d)
 }
 
diff --git a/meta/packages/fakeroot/fakeroot_1.9.4.bb b/meta/packages/fakeroot/fakeroot_1.9.4.bb
index 04219519e..669fa5a38 100644
--- a/meta/packages/fakeroot/fakeroot_1.9.4.bb
+++ b/meta/packages/fakeroot/fakeroot_1.9.4.bb
@@ -4,6 +4,7 @@ SECTION = "base"
 LICENSE = "GPL"
 # fakeroot needs getopt which is provided by the util-linux package
 RDEPENDS = "util-linux"
+RDEPENDS_virtclass-native = "util-linux-native"
 PR = "r2"
 
 SRC_URI = "${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.tar.gz \
-- 
cgit v1.2.3