From 9439e99ae7dcb8a5317ab437612c0a630e9cf72b Mon Sep 17 00:00:00 2001
From: Richard Purdie <rpurdie@linux.intel.com>
Date: Thu, 16 Jul 2009 15:54:47 +0100
Subject: autotools.bbclass: Fix to work with configure files with leading
 whitespace

Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
---
 meta/classes/autotools.bbclass | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/meta/classes/autotools.bbclass b/meta/classes/autotools.bbclass
index 82ed36816..5ef3a8940 100644
--- a/meta/classes/autotools.bbclass
+++ b/meta/classes/autotools.bbclass
@@ -114,7 +114,7 @@ autotools_do_configure() {
 			else
 			  CONFIGURE_AC=configure.ac
 			fi
-			if grep "^AM_GLIB_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
+			if grep "^[[:space:]]*AM_GLIB_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
 			  if grep "sed.*POTFILES" $CONFIGURE_AC >/dev/null; then
 			    : do nothing -- we still have an old unmodified configure.ac
 			  else
@@ -122,12 +122,12 @@ autotools_do_configure() {
 			    echo "no" | glib-gettextize --force --copy
 			  fi
 			fi
-			if grep "^[AI][CT]_PROG_INTLTOOL" $CONFIGURE_AC >/dev/null; then
+			mkdir -p m4
+			if grep "^[[:space:]]*[AI][CT]_PROG_INTLTOOL" $CONFIGURE_AC >/dev/null; then
 			  oenote Executing intltoolize --copy --force --automake
 			  intltoolize --copy --force --automake
 			fi
 			oenote Executing autoreconf --verbose --install --force ${EXTRA_AUTORECONF} $acpaths
-			mkdir -p m4
 			autoreconf -Wcross --verbose --install --force ${EXTRA_AUTORECONF} $acpaths || oefatal "autoreconf execution failed."
 			cd $olddir
 		fi
-- 
cgit v1.2.3