From dc10e1688e9aa3b6f06b2a37b1d5bdb63443b955 Mon Sep 17 00:00:00 2001
From: Kevin Tian <kevin.tian@intel.com>
Date: Wed, 5 Jan 2011 11:04:12 +0800
Subject: bison-native: create a wrapper script for sstate installation

bison-native encodes M4 and PKGDATA staging path in its binary, which
breaks sstate installation in a new build environment. Use create_wrapper
similar as flex-native to solve this issue

Signed-off-by: Kevin Tian <kevin.tian@intel.com>
---
 meta/recipes-devtools/bison/bison_2.4.3.bb | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)

diff --git a/meta/recipes-devtools/bison/bison_2.4.3.bb b/meta/recipes-devtools/bison/bison_2.4.3.bb
index 03fd463fd..fa2f15400 100644
--- a/meta/recipes-devtools/bison/bison_2.4.3.bb
+++ b/meta/recipes-devtools/bison/bison_2.4.3.bb
@@ -10,7 +10,7 @@ SECTION = "devel"
 PRIORITY = "optional"
 DEPENDS = "gettext bison-native"
 
-PR = "r0"
+PR = "r1"
 
 BASE_SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.gz \
 	   file://m4.patch;patch=1"
@@ -27,4 +27,10 @@ SRC_URI_virtclass-native = "${BASE_SRC_URI}"
 inherit autotools
 acpaths = "-I ${S}/m4"
 
+do_install_append_virtclass-native() {
+	create_wrapper ${D}/${bindir}/bison \
+		M4=${STAGING_BINDIR_NATIVE}/m4 \
+		BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison
+}
+#bison-native encodes the staging M4 path
 BBCLASSEXTEND = "native"
-- 
cgit v1.2.3