From f8b928e9bab33fb60945fc9abfb8e4ffc404de6f Mon Sep 17 00:00:00 2001
From: Marcin Juszkiewicz <hrw@openedhand.com>
Date: Wed, 22 Aug 2007 16:30:00 +0000
Subject: qemu: added 20070613 version (as default), made CVS floating

This version works on 32 and 64 bit machines.


git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2540 311d38ba-8fff-0310-9ca6-ca027cbcb966
---
 meta/conf/distro/poky.conf                 |  2 --
 meta/packages/qemu/qemu-native_20070613.bb | 18 ++++++++++
 meta/packages/qemu/qemu_20070613.bb        | 55 ++++++++++++++++++++++++++++++
 meta/packages/qemu/qemu_cvs.bb             |  1 +
 4 files changed, 74 insertions(+), 2 deletions(-)
 create mode 100644 meta/packages/qemu/qemu-native_20070613.bb
 create mode 100644 meta/packages/qemu/qemu_20070613.bb

diff --git a/meta/conf/distro/poky.conf b/meta/conf/distro/poky.conf
index 683299936..cee86ffb1 100644
--- a/meta/conf/distro/poky.conf
+++ b/meta/conf/distro/poky.conf
@@ -92,8 +92,6 @@ SRCREV_pn-screenshot ?= "266"
 SRCDATE_xcalibrateext ?= "20051101"
 SRCREV_pn-libfakekey ?= "1270"
 SRCDATE_xcalibrate ?= "20060312"
-SRCDATE_qemu ?= "20070613"
-SRCDATE_qemu-native ?= "20070613"
 SRCDATE_oprofile ?= "20070807"
 SRCREV_pn-oprofileui ?= "127"
 SRCREV_pn-zaurusd ?= "273"
diff --git a/meta/packages/qemu/qemu-native_20070613.bb b/meta/packages/qemu/qemu-native_20070613.bb
new file mode 100644
index 000000000..03a433b23
--- /dev/null
+++ b/meta/packages/qemu/qemu-native_20070613.bb
@@ -0,0 +1,18 @@
+require qemu_${PV}.bb
+inherit native
+DEPENDS = "zlib-native"
+prefix = "${STAGING_DIR}/${BUILD_SYS}"
+
+python __anonymous() {
+    from bb import which, data
+	
+    path = data.getVar('PATH', d)
+    oeconf = data.getVar('EXTRA_OECONF', d) or ''
+    if len(which(path, 'gcc-3.4')) != 0:
+        data.setVar('EXTRA_OECONF', oeconf + " --cc=gcc-3.4", d)
+    elif len(which(path, 'gcc34')) != 0:
+        data.setVar('EXTRA_OECONF', oeconf + " --cc=gcc34", d)
+    elif len(which(path, 'gcc-3.3')) != 0:
+        data.setVar('EXTRA_OECONF', oeconf + " --cc=gcc-3.3", d)
+    #data.setVarFlag('PKG_CONFIG_PATH', 'unexport', '1', d)
+}
diff --git a/meta/packages/qemu/qemu_20070613.bb b/meta/packages/qemu/qemu_20070613.bb
new file mode 100644
index 000000000..590641b84
--- /dev/null
+++ b/meta/packages/qemu/qemu_20070613.bb
@@ -0,0 +1,55 @@
+LICENSE = "GPL"
+DEPENDS = "zlib"
+SRCDATE = "20070613"
+PV = "0.9.0+cvs${SRCDATE}"
+PR = "r4"
+
+FILESDIR = "${WORKDIR}"
+
+SRC_URI = "\
+    cvs://anonymous@cvs.savannah.nongnu.org/sources/qemu;method=pserver;rsh=ssh;module=qemu \
+    file://02_snapshot_use_tmpdir.patch;patch=1;pnum=0 \
+    file://03_machines_list_no_error.patch;patch=1;pnum=0 \
+    file://04_do_not_print_rtc_freq_if_ok.patch;patch=1;pnum=1 \
+    file://05_non-fatal_if_linux_hd_missing.patch;patch=1;pnum=1 \
+    file://06_exit_segfault.patch;patch=1;pnum=0 \
+    file://10_signal_jobs.patch;patch=1;pnum=0 \
+    file://11_signal_sigaction.patch;patch=1;pnum=0 \
+    file://12_signal_powerpc_support.patch;patch=1;pnum=1 \
+    file://22_net_tuntap_stall.patch;patch=1;pnum=0 \
+    file://31_syscalls.patch;patch=1;pnum=0 \
+    file://32_syscall_sysctl.patch;patch=1;pnum=0 \
+    file://33_syscall_ppc_clone.patch;patch=1;pnum=0 \
+    file://39_syscall_fadvise64.patch;patch=1;pnum=0 \
+    file://41_arm_fpa_sigfpe.patch;patch=1;pnum=0 \
+    file://52_ne2000_return.patch;patch=1;pnum=1 \
+    file://61_safe_64bit_int.patch;patch=1;pnum=0 \
+    file://63_sparc_build.patch;patch=1;pnum=0 \
+    file://64_ppc_asm_constraints.patch;patch=1;pnum=1 \
+    file://65_kfreebsd.patch;patch=1;pnum=0 \
+    file://66_tls_ld.patch;patch=1;pnum=0 \
+    file://91-oh-sdl-cursor.patch;patch=1;pnum=0 \
+    file://93-oh-pl110-rgb.patch;patch=1;pnum=0 \
+    file://qemu-0.9.0-nptl.patch;patch=1 \
+    file://qemu-0.9.0-nptl-update.patch;patch=1 \
+    file://qemu-amd64-32b-mapping-0.9.0.patch;patch=1 \
+    file://workaround_bad_futex_headers.patch;patch=1 \
+    file://fix_segfault.patch;patch=1"
+
+#    svn://svn.o-hand.com/repos/misc/trunk/qemu-packaging/qemu;module=debian;proto=http;srcdate=20070119 \
+#    file://debian/patches/21_net_soopts.patch;patch=1;pnum=0 \
+#    file://debian/patches/35_syscall_sockaddr.patch;patch=1;pnum=0 \
+#    file://debian/patches/43_arm_cpustate.patch;patch=1;pnum=0 \
+#    file://debian/patches/62_linux_boot_nasm.patch;patch=1;pnum=0 \
+#    file://debian/patches/67_ppc_ftbfs.patch;patch=1;pnum=0 \
+#    file://debian/patches/80_ui_curses.patch;patch=1;pnum=0 \
+#    file://debian/patches/96-x.patch;patch=1"
+
+S = "${WORKDIR}/qemu"
+
+#EXTRA_OECONF = "--disable-sdl"
+#EXTRA_OECONF = "--disable-gfx-check --target-list=arm-linux-user"
+EXTRA_OECONF = "--disable-gfx-check"
+
+inherit autotools
+
diff --git a/meta/packages/qemu/qemu_cvs.bb b/meta/packages/qemu/qemu_cvs.bb
index ddad39c6c..c64875bda 100644
--- a/meta/packages/qemu/qemu_cvs.bb
+++ b/meta/packages/qemu/qemu_cvs.bb
@@ -3,6 +3,7 @@ DEPENDS = "zlib"
 PV = "0.9.0+cvs${SRCDATE}"
 PR = "r4"
 
+DEFAULT_PREFERENCE = "-1"
 FILESDIR = "${WORKDIR}"
 
 SRC_URI = "\
-- 
cgit v1.2.3