From fa36fa237099d60bfc9f451f59b5857652895094 Mon Sep 17 00:00:00 2001
From: Ross Burton <ross@openedhand.com>
Date: Sat, 16 Feb 2008 16:51:13 +0000
Subject: gtk+: merge two related patches into a single file

git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3822 311d38ba-8fff-0310-9ca6-ca027cbcb966
---
 .../gtk+/gtk+-2.12.7/filechooser-props.patch       | 57 ++++++++++++++++++++++
 .../gtk+/gtk+-2.12.7/filechooser-utils.patch       | 32 ------------
 meta/packages/gtk+/gtk+-2.12.7/filechooser.patch   | 25 ----------
 meta/packages/gtk+/gtk+_2.12.7.bb                  |  3 +-
 4 files changed, 58 insertions(+), 59 deletions(-)
 create mode 100644 meta/packages/gtk+/gtk+-2.12.7/filechooser-props.patch
 delete mode 100644 meta/packages/gtk+/gtk+-2.12.7/filechooser-utils.patch
 delete mode 100644 meta/packages/gtk+/gtk+-2.12.7/filechooser.patch

diff --git a/meta/packages/gtk+/gtk+-2.12.7/filechooser-props.patch b/meta/packages/gtk+/gtk+-2.12.7/filechooser-props.patch
new file mode 100644
index 000000000..7d55f3cbb
--- /dev/null
+++ b/meta/packages/gtk+/gtk+-2.12.7/filechooser-props.patch
@@ -0,0 +1,57 @@
+Index: gtk+-2.12.3/gtk/gtkfilechooser.c
+===================================================================
+--- gtk+-2.12.3.orig/gtk/gtkfilechooser.c	2007-12-04 16:52:08.000000000 +0000
++++ gtk+-2.12.3/gtk/gtkfilechooser.c	2008-01-02 13:15:38.000000000 +0000
+@@ -272,6 +272,20 @@
+ 								"if necessary."),
+ 							     FALSE,
+ 							     GTK_PARAM_READWRITE));
++
++  g_object_interface_install_property (g_iface,
++				       g_param_spec_string ("root-folder",
++							    P_("File System Root"),
++							    P_("Root folder for the file system below which the user should not be able to switch"),
++							    NULL,
++							    G_PARAM_WRITABLE));
++
++  g_object_interface_install_property (g_iface,
++				       g_param_spec_boolean ("show-create-folder",
++							     P_("Show Create Folder button"),
++							     P_("Whether the Create Folder button should be visible on the bar"),
++							     TRUE,
++							     G_PARAM_READWRITE));
+ }
+ 
+ /**
+Index: gtk+-2.12.3/gtk/gtkfilechooserutils.h
+===================================================================
+--- gtk+-2.12.3.orig/gtk/gtkfilechooserutils.h	2007-12-04 16:52:08.000000000 +0000
++++ gtk+-2.12.3/gtk/gtkfilechooserutils.h	2008-01-02 13:15:17.000000000 +0000
+@@ -41,7 +41,9 @@
+   GTK_FILE_CHOOSER_PROP_SELECT_MULTIPLE,
+   GTK_FILE_CHOOSER_PROP_SHOW_HIDDEN,
+   GTK_FILE_CHOOSER_PROP_DO_OVERWRITE_CONFIRMATION,
+-  GTK_FILE_CHOOSER_PROP_LAST                   = GTK_FILE_CHOOSER_PROP_DO_OVERWRITE_CONFIRMATION
++  GTK_FILE_CHOOSER_PROP_ROOT_FOLDER,
++  GTK_FILE_CHOOSER_PROP_SHOW_CREATE_FOLDER,
++  GTK_FILE_CHOOSER_PROP_LAST = GTK_FILE_CHOOSER_PROP_SHOW_CREATE_FOLDER
+ } GtkFileChooserProp;
+ 
+ void _gtk_file_chooser_install_properties (GObjectClass *klass);
+Index: gtk+-2.12.3/gtk/gtkfilechooserutils.c
+===================================================================
+--- gtk+-2.12.3.orig/gtk/gtkfilechooserutils.c	2007-12-04 16:52:08.000000000 +0000
++++ gtk+-2.12.3/gtk/gtkfilechooserutils.c	2008-01-02 13:15:17.000000000 +0000
+@@ -117,6 +117,12 @@
+   g_object_class_override_property (klass,
+ 				    GTK_FILE_CHOOSER_PROP_DO_OVERWRITE_CONFIRMATION,
+ 				    "do-overwrite-confirmation");
++  g_object_class_override_property (klass,
++				    GTK_FILE_CHOOSER_PROP_ROOT_FOLDER,
++				    "root-folder");
++  g_object_class_override_property (klass,
++				    GTK_FILE_CHOOSER_PROP_SHOW_CREATE_FOLDER,
++				    "show-create-folder");
+ }
+ 
+ /**
diff --git a/meta/packages/gtk+/gtk+-2.12.7/filechooser-utils.patch b/meta/packages/gtk+/gtk+-2.12.7/filechooser-utils.patch
deleted file mode 100644
index 45cfd4fd6..000000000
--- a/meta/packages/gtk+/gtk+-2.12.7/filechooser-utils.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-Index: gtk+-2.12.3/gtk/gtkfilechooserutils.h
-===================================================================
---- gtk+-2.12.3.orig/gtk/gtkfilechooserutils.h	2007-12-04 16:52:08.000000000 +0000
-+++ gtk+-2.12.3/gtk/gtkfilechooserutils.h	2008-01-02 13:15:17.000000000 +0000
-@@ -41,7 +41,9 @@
-   GTK_FILE_CHOOSER_PROP_SELECT_MULTIPLE,
-   GTK_FILE_CHOOSER_PROP_SHOW_HIDDEN,
-   GTK_FILE_CHOOSER_PROP_DO_OVERWRITE_CONFIRMATION,
--  GTK_FILE_CHOOSER_PROP_LAST                   = GTK_FILE_CHOOSER_PROP_DO_OVERWRITE_CONFIRMATION
-+  GTK_FILE_CHOOSER_PROP_ROOT_FOLDER,
-+  GTK_FILE_CHOOSER_PROP_SHOW_CREATE_FOLDER,
-+  GTK_FILE_CHOOSER_PROP_LAST = GTK_FILE_CHOOSER_PROP_SHOW_CREATE_FOLDER
- } GtkFileChooserProp;
- 
- void _gtk_file_chooser_install_properties (GObjectClass *klass);
-Index: gtk+-2.12.3/gtk/gtkfilechooserutils.c
-===================================================================
---- gtk+-2.12.3.orig/gtk/gtkfilechooserutils.c	2007-12-04 16:52:08.000000000 +0000
-+++ gtk+-2.12.3/gtk/gtkfilechooserutils.c	2008-01-02 13:15:17.000000000 +0000
-@@ -117,6 +117,12 @@
-   g_object_class_override_property (klass,
- 				    GTK_FILE_CHOOSER_PROP_DO_OVERWRITE_CONFIRMATION,
- 				    "do-overwrite-confirmation");
-+  g_object_class_override_property (klass,
-+				    GTK_FILE_CHOOSER_PROP_ROOT_FOLDER,
-+				    "root-folder");
-+  g_object_class_override_property (klass,
-+				    GTK_FILE_CHOOSER_PROP_SHOW_CREATE_FOLDER,
-+				    "show-create-folder");
- }
- 
- /**
diff --git a/meta/packages/gtk+/gtk+-2.12.7/filechooser.patch b/meta/packages/gtk+/gtk+-2.12.7/filechooser.patch
deleted file mode 100644
index c422f60d4..000000000
--- a/meta/packages/gtk+/gtk+-2.12.7/filechooser.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Index: gtk+-2.12.3/gtk/gtkfilechooser.c
-===================================================================
---- gtk+-2.12.3.orig/gtk/gtkfilechooser.c	2007-12-04 16:52:08.000000000 +0000
-+++ gtk+-2.12.3/gtk/gtkfilechooser.c	2008-01-02 13:15:38.000000000 +0000
-@@ -272,6 +272,20 @@
- 								"if necessary."),
- 							     FALSE,
- 							     GTK_PARAM_READWRITE));
-+
-+  g_object_interface_install_property (g_iface,
-+				       g_param_spec_string ("root-folder",
-+							    P_("File System Root"),
-+							    P_("Root folder for the file system below which the user should not be able to switch"),
-+							    NULL,
-+							    G_PARAM_WRITABLE));
-+
-+  g_object_interface_install_property (g_iface,
-+				       g_param_spec_boolean ("show-create-folder",
-+							     P_("Show Create Folder button"),
-+							     P_("Whether the Create Folder button should be visible on the bar"),
-+							     TRUE,
-+							     G_PARAM_READWRITE));
- }
- 
- /**
diff --git a/meta/packages/gtk+/gtk+_2.12.7.bb b/meta/packages/gtk+/gtk+_2.12.7.bb
index 79784dd02..a29bd313f 100644
--- a/meta/packages/gtk+/gtk+_2.12.7.bb
+++ b/meta/packages/gtk+/gtk+_2.12.7.bb
@@ -14,8 +14,7 @@ SRC_URI = "http://download.gnome.org/sources/gtk+/2.12/gtk+-${PV}.tar.bz2 \
            file://toggle-font.diff;patch=1;pnum=0 \
            file://scrolled-placement.patch;patch=1;pnum=0 \
            file://filesystem-volumes.patch;patch=1 \
-           file://filechooser-utils.patch;patch=1 \
-           file://filechooser.patch;patch=1 \
+           file://filechooser-props.patch;patch=1 \
            file://filechooser-default.patch;patch=1 \
 # temporary
 #           file://gtklabel-resize-patch;patch=1 \
-- 
cgit v1.2.3