From 6c338660e8a5efec3baa30a23eeb9662b09a863d Mon Sep 17 00:00:00 2001
From: Cliff Brake <cbrake@bec-systems.com>
Date: Tue, 15 Jun 2010 17:29:54 -0700
Subject: remove return in finally statement

causes exceptions to not be handled after the finally statement

(Bitbake rev: 1a04610dea376340b9ea4c109f64995b4fd6ad02)

Signed-off-by: Cliff Brake <cbrake@bec-systems.com>
Signed-off-by: Chris Larson <clarson@kergoth.com>
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
---
 bitbake/bin/bitbake | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

(limited to 'bitbake')

diff --git a/bitbake/bin/bitbake b/bitbake/bin/bitbake
index 65739106b..c0eb713f5 100755
--- a/bitbake/bin/bitbake
+++ b/bitbake/bin/bitbake
@@ -198,9 +198,9 @@ Default BBFILES are the .bb files in the current directory.""")
         except Exception, e:
             print "FATAL: Unable to start to '%s' UI: %s" % (ui, e)
             raise
-    finally:
-        serverConnection.terminate()
-        return return_value
+
+    serverConnection.terminate()
+    return return_value
 
 if __name__ == "__main__":
     ret = main()
-- 
cgit v1.2.3