From b2f192faabe412adce79534e22efe9fb69ee40e2 Mon Sep 17 00:00:00 2001
From: Richard Purdie <richard@openedhand.com>
Date: Fri, 21 Jul 2006 10:10:31 +0000
Subject: Rename /openembedded/ -> /meta/

git-svn-id: https://svn.o-hand.com/repos/poky/trunk@530 311d38ba-8fff-0310-9ca6-ca027cbcb966
---
 meta/packages/quilt/files/install.patch  | 19 +++++++++++++++++++
 meta/packages/quilt/files/non-gnu.patch  | 13 +++++++++++++
 meta/packages/quilt/files/nostrip.patch  | 16 ++++++++++++++++
 meta/packages/quilt/quilt-native_0.42.bb | 14 ++++++++++++++
 meta/packages/quilt/quilt-package.inc    | 10 ++++++++++
 meta/packages/quilt/quilt.inc            | 13 +++++++++++++
 meta/packages/quilt/quilt_0.42.bb        |  7 +++++++
 7 files changed, 92 insertions(+)
 create mode 100644 meta/packages/quilt/files/install.patch
 create mode 100644 meta/packages/quilt/files/non-gnu.patch
 create mode 100644 meta/packages/quilt/files/nostrip.patch
 create mode 100644 meta/packages/quilt/quilt-native_0.42.bb
 create mode 100644 meta/packages/quilt/quilt-package.inc
 create mode 100644 meta/packages/quilt/quilt.inc
 create mode 100644 meta/packages/quilt/quilt_0.42.bb

(limited to 'meta/packages/quilt')

diff --git a/meta/packages/quilt/files/install.patch b/meta/packages/quilt/files/install.patch
new file mode 100644
index 000000000..4122370d6
--- /dev/null
+++ b/meta/packages/quilt/files/install.patch
@@ -0,0 +1,19 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- quilt-0.32/Makefile.in~install
++++ quilt-0.32/Makefile.in
+@@ -9,9 +9,9 @@
+ libdir :=	@libdir@
+ datadir :=	@datadir@
+ docdir :=	@docdir@
+-mandir :=	$(datadir)/man
++mandir :=	@mandir@
+ localedir :=	$(datadir)/locale
+-etcdir :=	$(subst /usr/etc,/etc,$(prefix)/etc)
++etcdir :=	@sysconfdir@
+ 
+ QUILT_DIR =	$(datadir)/$(PACKAGE)
+ SCRIPTS_DIR =	$(QUILT_DIR)/scripts
diff --git a/meta/packages/quilt/files/non-gnu.patch b/meta/packages/quilt/files/non-gnu.patch
new file mode 100644
index 000000000..8b07bc292
--- /dev/null
+++ b/meta/packages/quilt/files/non-gnu.patch
@@ -0,0 +1,13 @@
+Index: quilt/Makefile.in
+===================================================================
+--- quilt.orig/Makefile.in
++++ quilt/Makefile.in	
+@@ -216,7 +216,7 @@
+ 	     -e 's:@LOCALEDIR''@:$(localedir):g' \
+ 	     -e 's:@DOCSUBDIR''@:$(docdir)/$(PACKAGE)-$(VERSION):g' \
+ 	     $< > $@
+-	@chmod --reference=$< $@
++	@chmod `stat -f "%p" $<`  $@
+ 
+ Makefile : Makefile.in
+ 	@echo "Please run ./configure by hand"
diff --git a/meta/packages/quilt/files/nostrip.patch b/meta/packages/quilt/files/nostrip.patch
new file mode 100644
index 000000000..4dedad96d
--- /dev/null
+++ b/meta/packages/quilt/files/nostrip.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- quilt-0.32/Makefile.in~nostrip
++++ quilt-0.32/Makefile.in
+@@ -240,7 +240,7 @@
+ 	@INSTALL@ -m 644 scripts/patchfns $(BUILD_ROOT)$(SCRIPTS_DIR)
+ 
+ 	@INSTALL@ -d $(BUILD_ROOT)$(LIB_DIR)
+-	@INSTALL@ -m 755 -s $(LIB:%=lib/%) $(BUILD_ROOT)$(LIB_DIR)/
++	@INSTALL@ -m 755 $(LIB:%=lib/%) $(BUILD_ROOT)$(LIB_DIR)/
+ 
+ 	@INSTALL@ -d $(BUILD_ROOT)$(docdir)/$(PACKAGE)-$(VERSION)/
+ 	@INSTALL@ -m 644 doc/README \
diff --git a/meta/packages/quilt/quilt-native_0.42.bb b/meta/packages/quilt/quilt-native_0.42.bb
new file mode 100644
index 000000000..d9bdc0e00
--- /dev/null
+++ b/meta/packages/quilt/quilt-native_0.42.bb
@@ -0,0 +1,14 @@
+include quilt.inc
+RDEPENDS_${PN} = "diffstat-native patch-native bzip2-native"
+
+INHIBIT_AUTOTOOLS_DEPS = "1"
+
+inherit autotools native
+
+PATCHCLEANCMD = ""
+PATCHCMD = "num='%s'; name='%s'; file='%s'; patch -p "$num" -i "$file""
+EXTRA_OECONF = "--disable-nls"
+
+do_configure () {
+	oe_runconf
+}
diff --git a/meta/packages/quilt/quilt-package.inc b/meta/packages/quilt/quilt-package.inc
new file mode 100644
index 000000000..bcdbcf026
--- /dev/null
+++ b/meta/packages/quilt/quilt-package.inc
@@ -0,0 +1,10 @@
+PACKAGES += "guards guards-doc"
+FILES_${PN} = "${sysconfdir} ${datadir}/quilt \
+	       ${bindir}/quilt ${libdir}/quilt"
+FILES_guards = "${bindir}/guards"
+FILES_${PN}-doc = "${mandir}/man1/quilt.1 ${docdir}/${P}"
+FILES_guards-doc = "${mandir}/man1/guards.1"
+
+do_install () {
+	oe_runmake 'BUILD_ROOT=${D}' install
+}
diff --git a/meta/packages/quilt/quilt.inc b/meta/packages/quilt/quilt.inc
new file mode 100644
index 000000000..cd5e85c3d
--- /dev/null
+++ b/meta/packages/quilt/quilt.inc
@@ -0,0 +1,13 @@
+DESCRIPTION = "Tool to work with series of patches."
+HOMEPAGE = "http://savannah.nongnu.org/projects/quilt/"
+SECTION = "devel"
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+LICENSE = "GPL"
+
+SRC_URI = "http://download.savannah.gnu.org/releases/quilt/quilt-${PV}.tar.gz \
+	   file://install.patch;patch=1 \
+	   file://nostrip.patch;patch=1"
+
+SRC_URI_append_build-darwin = "	   file://non-gnu.patch;patch=1 "
+
+S = "${WORKDIR}/quilt-${PV}"
diff --git a/meta/packages/quilt/quilt_0.42.bb b/meta/packages/quilt/quilt_0.42.bb
new file mode 100644
index 000000000..51bfa7a46
--- /dev/null
+++ b/meta/packages/quilt/quilt_0.42.bb
@@ -0,0 +1,7 @@
+RDEPENDS_${PN} += "patch diffstat bzip2"
+
+include quilt.inc
+
+inherit autotools gettext
+
+include quilt-package.inc
-- 
cgit v1.2.3