From 2e04ea87541479fee6dcbdd5a587f98a86428de6 Mon Sep 17 00:00:00 2001
From: Nitin A Kamble <nitin.a.kamble@intel.com>
Date: Thu, 24 Jun 2010 05:16:24 -0700
Subject: prelink: upgrade from 20061027 to 20100106

This need change to elfutils. elfutils changes are added in separate commit.

Removed the patch arm_eabi.patch, as it is included in the new sources

Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
---
 .../prelink/prelink-20061027/arm_eabi.patch        | 300 ---------------------
 .../packages/prelink/prelink-20061027/prelink.conf |  18 --
 .../prelink/prelink-20061027/prelink.cron.daily    |  40 ---
 .../prelink/prelink-20061027/prelink.default       |  22 --
 meta/packages/prelink/prelink/prelink.conf         |  18 ++
 meta/packages/prelink/prelink/prelink.cron.daily   |  40 +++
 meta/packages/prelink/prelink/prelink.default      |  22 ++
 meta/packages/prelink/prelink_20061027.bb          |  46 ----
 meta/packages/prelink/prelink_20100106.bb          |  45 ++++
 9 files changed, 125 insertions(+), 426 deletions(-)
 delete mode 100644 meta/packages/prelink/prelink-20061027/arm_eabi.patch
 delete mode 100644 meta/packages/prelink/prelink-20061027/prelink.conf
 delete mode 100644 meta/packages/prelink/prelink-20061027/prelink.cron.daily
 delete mode 100644 meta/packages/prelink/prelink-20061027/prelink.default
 create mode 100644 meta/packages/prelink/prelink/prelink.conf
 create mode 100644 meta/packages/prelink/prelink/prelink.cron.daily
 create mode 100644 meta/packages/prelink/prelink/prelink.default
 delete mode 100644 meta/packages/prelink/prelink_20061027.bb
 create mode 100644 meta/packages/prelink/prelink_20100106.bb

(limited to 'meta/packages')

diff --git a/meta/packages/prelink/prelink-20061027/arm_eabi.patch b/meta/packages/prelink/prelink-20061027/arm_eabi.patch
deleted file mode 100644
index 768d82e74..000000000
--- a/meta/packages/prelink/prelink-20061027/arm_eabi.patch
+++ /dev/null
@@ -1,300 +0,0 @@
----
- src/arch-arm.c |  177 +++++++++++++++++++++++++++++++++++++++++++++++++++++++--
- 1 file changed, 172 insertions(+), 5 deletions(-)
-
-Index: prelink-0.0.20061027/src/arch-arm.c
-===================================================================
---- prelink-0.0.20061027.orig/src/arch-arm.c	2006-08-13 16:18:17.000000000 +0100
-+++ prelink-0.0.20061027/src/arch-arm.c	2008-06-12 10:46:12.000000000 +0100
-@@ -145,6 +145,27 @@
-       error (0, 0, "%s: R_ARM_PC24 relocs with non-zero addend should not be present in prelinked REL sections",
- 	     dso->filename);
-       return 1;
-+    /* DTPMOD32 is impossible to predict unless prelink sets the rules. 
-+       DTPOFF32/TPOFF32 are converted REL->RELA.  */
-+    case R_ARM_TLS_DTPOFF32:
-+      error (0, 0, "%s: R_ARM_TLS_DTPOFF32 relocs should not be present in prelinked REL section",
-+	       dso->filename);
-+      return 1;
-+    case R_ARM_TLS_DTPMOD32:
-+      if (dso->ehdr.e_type == ET_EXEC)
-+	{
-+	  error (0, 0, "%s: R_ARM_TLS_DTPMOD32 reloc in executable?",
-+		 dso->filename);
-+	  return 1;
-+	}
-+      break;
-+    case R_ARM_TLS_TPOFF32:
-+      if (dso->ehdr.e_type == ET_EXEC) {
-+	error (0, 0, "%s: R_ARM_TLS_TPOFF32 relocs should not be present in prelinked ET_EXEC REL sections",
-+	       dso->filename);
-+	return 1;
-+      }
-+      break;
-     case R_ARM_COPY:
-       if (dso->ehdr.e_type == ET_EXEC)
- 	/* COPY relocs are handled specially in generic code.  */
-@@ -195,6 +216,24 @@
-       write_le32 (dso, rela->r_offset,
- 		  (read_ule32 (dso, rela->r_offset) & 0xff000000) | val);
-       break;
-+    case R_ARM_TLS_DTPOFF32:
-+      write_le32 (dso, rela->r_offset, value + rela->r_addend);
-+      break;
-+    /* DTPMOD32 and TPOFF32 are impossible to predict unless prelink
-+       sets the rules.  */
-+    case R_ARM_TLS_DTPMOD32:
-+      if (dso->ehdr.e_type == ET_EXEC)
-+	{
-+	  error (0, 0, "%s: R_ARM_TLS_DTPMOD32 reloc in executable?",
-+		 dso->filename);
-+	  return 1;
-+	}
-+      break;
-+    case R_ARM_TLS_TPOFF32:
-+      if (dso->ehdr.e_type == ET_EXEC && info->resolvetls)
-+	write_le32 (dso, rela->r_offset,
-+		    value + rela->r_addend + info->resolvetls->offset);
-+      break;
-     case R_ARM_COPY:
-       if (dso->ehdr.e_type == ET_EXEC)
- 	/* COPY relocs are handled specially in generic code.  */
-@@ -315,6 +354,7 @@
- {
-   GElf_Addr value;
-   struct prelink_conflict *conflict;
-+  struct prelink_tls *tls;
-   GElf_Rela *ret;
- 
-   if (GELF_R_TYPE (rel->r_info) == R_ARM_RELATIVE
-@@ -324,8 +364,32 @@
-   conflict = prelink_conflict (info, GELF_R_SYM (rel->r_info),
- 			       GELF_R_TYPE (rel->r_info));
-   if (conflict == NULL)
--    return 0;
--  value = conflict_lookup_value (conflict);
-+    {
-+      if (info->curtls == NULL)
-+	return 0;
-+      switch (GELF_R_TYPE (rel->r_info))
-+	{
-+	/* Even local DTPMOD and {D,}TPOFF relocs need conflicts.  */
-+	case R_ARM_TLS_DTPMOD32:
-+	case R_ARM_TLS_DTPOFF32:
-+	case R_ARM_TLS_TPOFF32:
-+	  break;
-+	default:
-+	  return 0;
-+	}
-+      value = 0;
-+    }
-+  else
-+    {
-+      /* DTPOFF32 wants to see only real conflicts, not lookups
-+	 with reloc_class RTYPE_CLASS_TLS.  */
-+      if (GELF_R_TYPE (rel->r_info) == R_ARM_TLS_DTPOFF32
-+	  && conflict->lookup.tls == conflict->conflict.tls
-+	  && conflict->lookupval == conflict->conflictval)
-+	return 0;
-+
-+      value = conflict_lookup_value (conflict);
-+    }
-   ret = prelink_conflict_add_rela (info);
-   if (ret == NULL)
-     return 1;
-@@ -342,6 +406,33 @@
-       error (0, 0, "%s: R_ARM_%s relocs should not be present in prelinked REL sections",
- 	     dso->filename, GELF_R_TYPE (rel->r_info) == R_ARM_ABS32 ? "ABS32" : "PC24");
-       return 1;
-+    case R_ARM_TLS_DTPMOD32:
-+    case R_ARM_TLS_DTPOFF32:
-+    case R_ARM_TLS_TPOFF32:
-+      if (conflict != NULL
-+	  && (conflict->reloc_class != RTYPE_CLASS_TLS
-+	      || conflict->lookup.tls == NULL))
-+	{
-+	  error (0, 0, "%s: R_ARM_TLS not resolving to STT_TLS symbol",
-+		 dso->filename);
-+	  return 1;
-+	}
-+      tls = conflict ? conflict->lookup.tls : info->curtls;
-+      ret->r_info = GELF_R_INFO (0, R_ARM_ABS32);
-+      switch (GELF_R_TYPE (rel->r_info))
-+	{
-+	case R_ARM_TLS_DTPMOD32:
-+	  ret->r_addend = tls->modid;
-+	  break;
-+	case R_ARM_TLS_DTPOFF32:
-+	  ret->r_addend = value + read_ule32 (dso, rel->r_offset);
-+	  break;
-+	case R_ARM_TLS_TPOFF32:
-+	  ret->r_addend = value + read_ule32 (dso, rel->r_offset)
-+			    + tls->offset;
-+	  break;
-+	}
-+      break;
-     case R_ARM_COPY:
-       error (0, 0, "R_ARM_COPY should not be present in shared libraries");
-       return 1;
-@@ -359,6 +450,7 @@
- {
-   GElf_Addr value;
-   struct prelink_conflict *conflict;
-+  struct prelink_tls *tls;
-   GElf_Rela *ret;
-   Elf32_Sword val;
- 
-@@ -369,8 +461,32 @@
-   conflict = prelink_conflict (info, GELF_R_SYM (rela->r_info),
- 			       GELF_R_TYPE (rela->r_info));
-   if (conflict == NULL)
--    return 0;
--  value = conflict_lookup_value (conflict);
-+    {
-+      if (info->curtls == NULL)
-+	return 0;
-+      switch (GELF_R_TYPE (rela->r_info))
-+	{
-+	/* Even local DTPMOD and {D,}TPOFF relocs need conflicts.  */
-+	case R_ARM_TLS_DTPMOD32:
-+	case R_ARM_TLS_DTPOFF32:
-+	case R_ARM_TLS_TPOFF32:
-+	  break;
-+	default:
-+	  return 0;
-+	}
-+      value = 0;
-+    }
-+  else
-+    {
-+      /* DTPOFF32 wants to see only real conflicts, not lookups
-+	 with reloc_class RTYPE_CLASS_TLS.  */
-+      if (GELF_R_TYPE (rela->r_info) == R_ARM_TLS_DTPOFF32
-+	  && conflict->lookup.tls == conflict->conflict.tls
-+	  && conflict->lookupval == conflict->conflictval)
-+	return 0;
-+
-+      value = conflict_lookup_value (conflict);
-+    }
-   ret = prelink_conflict_add_rela (info);
-   if (ret == NULL)
-     return 1;
-@@ -398,6 +514,32 @@
-     case R_ARM_COPY:
-       error (0, 0, "R_ARM_COPY should not be present in shared libraries");
-       return 1;
-+    case R_ARM_TLS_DTPMOD32:
-+    case R_ARM_TLS_DTPOFF32:
-+    case R_ARM_TLS_TPOFF32:
-+      if (conflict != NULL
-+	  && (conflict->reloc_class != RTYPE_CLASS_TLS
-+	      || conflict->lookup.tls == NULL))
-+	{
-+	  error (0, 0, "%s: R_ARM_TLS not resolving to STT_TLS symbol",
-+		 dso->filename);
-+	  return 1;
-+	}
-+      tls = conflict ? conflict->lookup.tls : info->curtls;
-+      ret->r_info = GELF_R_INFO (0, R_ARM_ABS32);
-+      switch (GELF_R_TYPE (rela->r_info))
-+	{
-+	case R_ARM_TLS_DTPMOD32:
-+	  ret->r_addend = tls->modid;
-+	  break;
-+	case R_ARM_TLS_DTPOFF32:
-+	  ret->r_addend = value + rela->r_addend;
-+	  break;
-+	case R_ARM_TLS_TPOFF32:
-+	  ret->r_addend = value + rela->r_addend + tls->offset;
-+	  break;
-+	}
-+      break;
-     default:
-       error (0, 0, "%s: Unknown arm relocation type %d", dso->filename,
- 	     (int) GELF_R_TYPE (rela->r_info));
-@@ -418,6 +560,8 @@
-       abort ();
-     case R_ARM_RELATIVE:
-     case R_ARM_ABS32:
-+    case R_ARM_TLS_TPOFF32:
-+    case R_ARM_TLS_DTPOFF32:
-       rela->r_addend = (Elf32_Sword) read_ule32 (dso, rel->r_offset);
-       break;
-     case R_ARM_PC24:
-@@ -426,6 +570,7 @@
-       break;
-     case R_ARM_COPY:
-     case R_ARM_GLOB_DAT:
-+    case R_ARM_TLS_DTPMOD32:
-       rela->r_addend = 0;
-       break;
-     }
-@@ -445,6 +590,8 @@
-       abort ();
-     case R_ARM_RELATIVE:
-     case R_ARM_ABS32:
-+    case R_ARM_TLS_TPOFF32:
-+    case R_ARM_TLS_DTPOFF32:
-       write_le32 (dso, rela->r_offset, rela->r_addend);
-       break;
-     case R_ARM_PC24:
-@@ -453,6 +600,7 @@
- 		  | ((rela->r_addend >> 2) & 0xffffff));
-       break;
-     case R_ARM_GLOB_DAT:
-+    case R_ARM_TLS_DTPMOD32:
-       write_le32 (dso, rela->r_offset, 0);
-       break;
-     }
-@@ -488,6 +636,18 @@
- 		/* FALLTHROUGH */
- 	      case R_ARM_PC24:
- 		return 1;
-+	      case R_ARM_TLS_DTPOFF32:
-+		/* We can prelink these fields, and the addend is relative
-+		   to the symbol value.  A RELA entry is needed.  */
-+		return 1;
-+	      case R_ARM_TLS_TPOFF32:
-+		/* In shared libraries TPOFF32 is changed always into
-+		   conflicts, for executables we need to preserve
-+		   original addend.  */
-+		if (dso->ehdr.e_type == ET_EXEC) {
-+		  return 1;
-+		}
-+		break;
- 	      }
- 	}
-     }
-@@ -612,6 +772,12 @@
- 	return 0;
-       error (0, 0, "%s: R_ARM_COPY reloc in shared library?", dso->filename);
-       return 1;
-+    case R_ARM_TLS_DTPMOD32:
-+      write_le32 (dso, rel->r_offset, 0);
-+      break;
-+    case R_ARM_TLS_DTPOFF32:
-+    case R_ARM_TLS_TPOFF32:
-+      break;
-     default:
-       error (0, 0, "%s: Unknown arm relocation type %d", dso->filename,
- 	     (int) GELF_R_TYPE (rel->r_info));
-@@ -634,6 +800,10 @@
-     {
-     case R_ARM_COPY: return RTYPE_CLASS_COPY;
-     case R_ARM_JUMP_SLOT: return RTYPE_CLASS_PLT;
-+    case R_ARM_TLS_DTPMOD32:
-+    case R_ARM_TLS_DTPOFF32:
-+    case R_ARM_TLS_TPOFF32:
-+      return RTYPE_CLASS_TLS;
-     default: return RTYPE_CLASS_VALID;
-     }
- }
-@@ -646,7 +816,7 @@
-   .R_JMP_SLOT = R_ARM_JUMP_SLOT,
-   .R_COPY = R_ARM_COPY,
-   .R_RELATIVE = R_ARM_RELATIVE,
--  .dynamic_linker = "/lib/ld-linux.so.2",
-+  .dynamic_linker = "/lib/ld-linux.so.3",
-   .adjust_dyn = arm_adjust_dyn,
-   .adjust_rel = arm_adjust_rel,
-   .adjust_rela = arm_adjust_rela,
diff --git a/meta/packages/prelink/prelink-20061027/prelink.conf b/meta/packages/prelink/prelink-20061027/prelink.conf
deleted file mode 100644
index c5a4f4adc..000000000
--- a/meta/packages/prelink/prelink-20061027/prelink.conf
+++ /dev/null
@@ -1,18 +0,0 @@
-# This config file contains a list of directories both with binaries
-# and libraries prelink should consider by default.
-# If a directory name is prefixed with `-l ', the directory hierarchy
-# will be walked as long as filesystem boundaries are not crossed.
-# If a directory name is prefixed with `-h ', symbolic links in a
-# directory hierarchy are followed.
--l /usr/local/sbin
--l /sbin
--l /usr/sbin
--l /usr/local/bin
--l /bin
--l /usr/bin
--l /usr/X11R6/bin
--l /usr/games
--l /usr/local/lib
--l /lib
--l /usr/lib
--l /usr/X11R6/lib
diff --git a/meta/packages/prelink/prelink-20061027/prelink.cron.daily b/meta/packages/prelink/prelink-20061027/prelink.cron.daily
deleted file mode 100644
index 0b3c07322..000000000
--- a/meta/packages/prelink/prelink-20061027/prelink.cron.daily
+++ /dev/null
@@ -1,40 +0,0 @@
-#!/bin/sh
-
-. /etc/default/prelink
-
-renice +19 -p $$ >/dev/null 2>&1
-
-if [ "$PRELINKING" != yes ]; then
-  if [ -f /etc/prelink.cache ]; then
-    echo /usr/sbin/prelink -uav > /var/log/prelink.log
-    /usr/sbin/prelink -uav >> /var/log/prelink.log 2>&1
-    rm -f /etc/prelink.cache
-    # Restart init if needed
-    [ -n "$(find `ldd /sbin/init | awk '{ print $3 }'` /sbin/init -ctime -1 2>/dev/null )" ] && /sbin/telinit u
-  fi
-  exit 0
-fi
-
-if [ ! -f /etc/prelink.cache -o -f /var/lib/misc/prelink.force ] \
-   || grep -q '^prelink-ELF0.[0-2]' /etc/prelink.cache; then
-  # If cache does not exist or is from older prelink versions or
-  # if we were asked to explicitely, force full prelinking
-  rm -f /etc/prelink.cache /var/lib/misc/prelink.force
-  PRELINK_OPTS="$PRELINK_OPTS -f"
-  date > /var/lib/misc/prelink.full
-elif [ -n "$PRELINK_FULL_TIME_INTERVAL" \
-       -a "`find /var/lib/misc/prelink.full -mtime -${PRELINK_FULL_TIME_INTERVAL} 2>/dev/null`" \
-	  = /var/lib/misc/prelink.full ]; then
-  # If prelink without -q has been run in the last
-  # PRELINK_FULL_TIME_INTERVAL days, just use quick mode
-  PRELINK_OPTS="$PRELINK_OPTS -q"
-else
-  date > /var/lib/misc/prelink.full
-fi
-
-echo /usr/sbin/prelink -av $PRELINK_OPTS > /var/log/prelink.log
-/usr/sbin/prelink -av $PRELINK_OPTS >> /var/log/prelink.log 2>&1
-# Restart init if needed
-[ -n "$(find `ldd /sbin/init | awk '{ print $3 }'` /sbin/init -ctime -1 2>/dev/null )" ] && /sbin/telinit u
-
-exit 0
diff --git a/meta/packages/prelink/prelink-20061027/prelink.default b/meta/packages/prelink/prelink-20061027/prelink.default
deleted file mode 100644
index 901258ed2..000000000
--- a/meta/packages/prelink/prelink-20061027/prelink.default
+++ /dev/null
@@ -1,22 +0,0 @@
-# Set this to no to disable prelinking altogether
-# or to yes to enable it.
-# (if you change this from yes to no prelink -ua
-# will be run next night to undo prelinking)
-PRELINKING=unknown
-
-# Options to pass to prelink
-# -m	Try to conserve virtual memory by allowing overlapping
-#	assigned virtual memory slots for libraries which
-#	never appear together in one binary
-# -R	Randomize virtual memory slot assignments for libraries.
-#	This makes it slightly harder for various buffer overflow
-#	attacks, since library addresses will be different on each
-#	host using -R.
-PRELINK_OPTS=-mR
-
-# How often should full prelink be run (in days)
-# Normally, prelink will be run in quick mode, every
-# $PRELINK_FULL_TIME_INTERVAL days it will be run
-# in normal mode.  Comment this line out if prelink 
-# should be run in normal mode always.
-PRELINK_FULL_TIME_INTERVAL=14
diff --git a/meta/packages/prelink/prelink/prelink.conf b/meta/packages/prelink/prelink/prelink.conf
new file mode 100644
index 000000000..c5a4f4adc
--- /dev/null
+++ b/meta/packages/prelink/prelink/prelink.conf
@@ -0,0 +1,18 @@
+# This config file contains a list of directories both with binaries
+# and libraries prelink should consider by default.
+# If a directory name is prefixed with `-l ', the directory hierarchy
+# will be walked as long as filesystem boundaries are not crossed.
+# If a directory name is prefixed with `-h ', symbolic links in a
+# directory hierarchy are followed.
+-l /usr/local/sbin
+-l /sbin
+-l /usr/sbin
+-l /usr/local/bin
+-l /bin
+-l /usr/bin
+-l /usr/X11R6/bin
+-l /usr/games
+-l /usr/local/lib
+-l /lib
+-l /usr/lib
+-l /usr/X11R6/lib
diff --git a/meta/packages/prelink/prelink/prelink.cron.daily b/meta/packages/prelink/prelink/prelink.cron.daily
new file mode 100644
index 000000000..0b3c07322
--- /dev/null
+++ b/meta/packages/prelink/prelink/prelink.cron.daily
@@ -0,0 +1,40 @@
+#!/bin/sh
+
+. /etc/default/prelink
+
+renice +19 -p $$ >/dev/null 2>&1
+
+if [ "$PRELINKING" != yes ]; then
+  if [ -f /etc/prelink.cache ]; then
+    echo /usr/sbin/prelink -uav > /var/log/prelink.log
+    /usr/sbin/prelink -uav >> /var/log/prelink.log 2>&1
+    rm -f /etc/prelink.cache
+    # Restart init if needed
+    [ -n "$(find `ldd /sbin/init | awk '{ print $3 }'` /sbin/init -ctime -1 2>/dev/null )" ] && /sbin/telinit u
+  fi
+  exit 0
+fi
+
+if [ ! -f /etc/prelink.cache -o -f /var/lib/misc/prelink.force ] \
+   || grep -q '^prelink-ELF0.[0-2]' /etc/prelink.cache; then
+  # If cache does not exist or is from older prelink versions or
+  # if we were asked to explicitely, force full prelinking
+  rm -f /etc/prelink.cache /var/lib/misc/prelink.force
+  PRELINK_OPTS="$PRELINK_OPTS -f"
+  date > /var/lib/misc/prelink.full
+elif [ -n "$PRELINK_FULL_TIME_INTERVAL" \
+       -a "`find /var/lib/misc/prelink.full -mtime -${PRELINK_FULL_TIME_INTERVAL} 2>/dev/null`" \
+	  = /var/lib/misc/prelink.full ]; then
+  # If prelink without -q has been run in the last
+  # PRELINK_FULL_TIME_INTERVAL days, just use quick mode
+  PRELINK_OPTS="$PRELINK_OPTS -q"
+else
+  date > /var/lib/misc/prelink.full
+fi
+
+echo /usr/sbin/prelink -av $PRELINK_OPTS > /var/log/prelink.log
+/usr/sbin/prelink -av $PRELINK_OPTS >> /var/log/prelink.log 2>&1
+# Restart init if needed
+[ -n "$(find `ldd /sbin/init | awk '{ print $3 }'` /sbin/init -ctime -1 2>/dev/null )" ] && /sbin/telinit u
+
+exit 0
diff --git a/meta/packages/prelink/prelink/prelink.default b/meta/packages/prelink/prelink/prelink.default
new file mode 100644
index 000000000..901258ed2
--- /dev/null
+++ b/meta/packages/prelink/prelink/prelink.default
@@ -0,0 +1,22 @@
+# Set this to no to disable prelinking altogether
+# or to yes to enable it.
+# (if you change this from yes to no prelink -ua
+# will be run next night to undo prelinking)
+PRELINKING=unknown
+
+# Options to pass to prelink
+# -m	Try to conserve virtual memory by allowing overlapping
+#	assigned virtual memory slots for libraries which
+#	never appear together in one binary
+# -R	Randomize virtual memory slot assignments for libraries.
+#	This makes it slightly harder for various buffer overflow
+#	attacks, since library addresses will be different on each
+#	host using -R.
+PRELINK_OPTS=-mR
+
+# How often should full prelink be run (in days)
+# Normally, prelink will be run in quick mode, every
+# $PRELINK_FULL_TIME_INTERVAL days it will be run
+# in normal mode.  Comment this line out if prelink 
+# should be run in normal mode always.
+PRELINK_FULL_TIME_INTERVAL=14
diff --git a/meta/packages/prelink/prelink_20061027.bb b/meta/packages/prelink/prelink_20061027.bb
deleted file mode 100644
index 21c538d5c..000000000
--- a/meta/packages/prelink/prelink_20061027.bb
+++ /dev/null
@@ -1,46 +0,0 @@
-SECTION = "devel"
-DEPENDS = "elfutils"
-DESCRIPTION = " The prelink package contains a utility which modifies ELF shared libraries \
-and executables, so that far fewer relocations need to be resolved at \
-runtime and thus programs come up faster."
-LICENSE = "GPL"
-PR = "r9"
-
-SRC_URI = "${DEBIAN_MIRROR}/main/p/prelink/prelink_0.0.${PV}.orig.tar.gz \
-           file://prelink.conf \
-           file://prelink.cron.daily \
-           file://prelink.default"
-
-TARGET_OS_ORIG := "${TARGET_OS}"
-OVERRIDES_append = ":${TARGET_OS_ORIG}"
-SRC_URI_append_linux-gnueabi = " file://arm_eabi.patch;patch=1"
-
-S = "${WORKDIR}/prelink-0.0.${PV}"
-
-EXTRA_OECONF = "--disable-64bit"
-
-inherit autotools 
-
-do_install_append () {
-	install -d ${D}${sysconfdir}/cron.daily ${D}${sysconfdir}/default
-	install -m 0644 ${WORKDIR}/prelink.conf ${D}${sysconfdir}/prelink.conf
-	install -m 0644 ${WORKDIR}/prelink.cron.daily ${D}${sysconfdir}/cron.daily/prelink
-	install -m 0644 ${WORKDIR}/prelink.default ${D}${sysconfdir}/default/prelink
-}
-
-pkg_postinst_prelink() {
-#!/bin/sh
-
-if [ "x$D" != "x" ]; then
-  exit 1
-fi
-
-prelink -a
-}
-
-pkg_postrm_prelink() {
-#!/bin/sh
-
-prelink -au
-}
-
diff --git a/meta/packages/prelink/prelink_20100106.bb b/meta/packages/prelink/prelink_20100106.bb
new file mode 100644
index 000000000..a84aaa267
--- /dev/null
+++ b/meta/packages/prelink/prelink_20100106.bb
@@ -0,0 +1,45 @@
+SECTION = "devel"
+DEPENDS = "elfutils"
+DESCRIPTION = " The prelink package contains a utility which modifies ELF shared libraries \
+and executables, so that far fewer relocations need to be resolved at \
+runtime and thus programs come up faster."
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://people.redhat.com/jakub/prelink/prelink-${PV}.tar.bz2 \
+           file://prelink.conf \
+           file://prelink.cron.daily \
+           file://prelink.default"
+
+TARGET_OS_ORIG := "${TARGET_OS}"
+OVERRIDES_append = ":${TARGET_OS_ORIG}"
+
+S = "${WORKDIR}/prelink"
+
+EXTRA_OECONF = "--disable-64bit"
+
+inherit autotools 
+
+do_install_append () {
+	install -d ${D}${sysconfdir}/cron.daily ${D}${sysconfdir}/default
+	install -m 0644 ${WORKDIR}/prelink.conf ${D}${sysconfdir}/prelink.conf
+	install -m 0644 ${WORKDIR}/prelink.cron.daily ${D}${sysconfdir}/cron.daily/prelink
+	install -m 0644 ${WORKDIR}/prelink.default ${D}${sysconfdir}/default/prelink
+}
+
+pkg_postinst_prelink() {
+#!/bin/sh
+
+if [ "x$D" != "x" ]; then
+  exit 1
+fi
+
+prelink -a
+}
+
+pkg_postrm_prelink() {
+#!/bin/sh
+
+prelink -au
+}
+
-- 
cgit v1.2.3