From 29d6678fd546377459ef75cf54abeef5b969b5cf Mon Sep 17 00:00:00 2001
From: Richard Purdie <rpurdie@linux.intel.com>
Date: Fri, 27 Aug 2010 15:14:24 +0100
Subject: Major layout change to the packages directory

Having one monolithic packages directory makes it hard to find things
and is generally overwhelming. This commit splits it into several
logical sections roughly based on function, recipes.txt gives more
information about the classifications used.

The opportunity is also used to switch from "packages" to "recipes"
as used in OpenEmbedded as the term "packages" can be confusing to
people and has many different meanings.

Not all recipes have been classified yet, this is just a first pass
at separating things out. Some packages are moved to meta-extras as
they're no longer actively used or maintained.

Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
---
 meta/recipes-core/initrdscripts/files/init-boot.sh |   8 +
 .../initrdscripts/files/init-install.sh            | 170 +++++++++++++++++++++
 meta/recipes-core/initrdscripts/files/init-live.sh |  92 +++++++++++
 .../initrdscripts/initramfs-boot_1.0.bb            |  13 ++
 .../initrdscripts/initramfs-live-boot_1.0.bb       |  13 ++
 .../initrdscripts/initramfs-live-install_1.0.bb    |  18 +++
 6 files changed, 314 insertions(+)
 create mode 100644 meta/recipes-core/initrdscripts/files/init-boot.sh
 create mode 100644 meta/recipes-core/initrdscripts/files/init-install.sh
 create mode 100644 meta/recipes-core/initrdscripts/files/init-live.sh
 create mode 100644 meta/recipes-core/initrdscripts/initramfs-boot_1.0.bb
 create mode 100644 meta/recipes-core/initrdscripts/initramfs-live-boot_1.0.bb
 create mode 100644 meta/recipes-core/initrdscripts/initramfs-live-install_1.0.bb

(limited to 'meta/recipes-core/initrdscripts')

diff --git a/meta/recipes-core/initrdscripts/files/init-boot.sh b/meta/recipes-core/initrdscripts/files/init-boot.sh
new file mode 100644
index 000000000..9d804fc3a
--- /dev/null
+++ b/meta/recipes-core/initrdscripts/files/init-boot.sh
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+mkdir /proc
+mkdir /sys
+mount -t proc proc /proc
+mount -t sysfs sysfs /sys
+
+exec sh
diff --git a/meta/recipes-core/initrdscripts/files/init-install.sh b/meta/recipes-core/initrdscripts/files/init-install.sh
new file mode 100644
index 000000000..ecd0a1b44
--- /dev/null
+++ b/meta/recipes-core/initrdscripts/files/init-install.sh
@@ -0,0 +1,170 @@
+#!/bin/sh -e
+#
+# Copyright (C) 2008 Intel
+#
+# install.sh [device_name] [rootfs_name] [video_mode] [vga_mode]
+#
+
+# We need 20 Mb for the boot partition
+boot_size=20
+
+# 5% for the swap
+swap_ratio=5
+
+found="no"
+
+echo "Searching for a hard drive..."
+for device in 'hda' 'hdb' 'sda' 'sdb'
+  do
+  if [ -e /sys/block/${device}/removable ]; then
+      if [ "$(cat /sys/block/${device}/removable)" = "0" ]; then
+	  found="yes"
+
+	  while true; do
+	      echo "Found drive at /dev/${device}. Do you want to install moblin there ? [y/n]"
+	      read answer
+	      if [ "$answer" = "y" ] ; then
+		  break
+	      fi
+	  
+	      if [ "$answer" = "n" ] ; then
+		  found=no
+		  break
+	      fi
+
+	      echo "Please answer by y or n"
+	  done
+      fi
+  fi
+
+  if [ "$found" = "yes" ]; then
+      break;
+  fi
+
+done
+
+if [ "$found" = "no" ]; then
+      exit 1      
+fi
+
+echo "Installing image on /dev/${device}"
+
+#
+# The udev automounter can cause pain here, kill it
+#
+rm -f /etc/udev/scripts/mount*
+
+#
+# Unmount anything the automounter had mounted
+#
+umount /dev/${device} 2> /dev/null || /bin/true
+umount /dev/${device}1 2> /dev/null || /bin/true
+umount /dev/${device}2 2> /dev/null || /bin/true
+umount /dev/${device}3 2> /dev/null || /bin/true
+umount /dev/${device}4 2> /dev/null || /bin/true
+umount /dev/${device}5 2> /dev/null || /bin/true
+umount /dev/${device}6 2> /dev/null || /bin/true
+
+if [ ! -b /dev/sda ] ; then
+    mknod /dev/sda b 8 0
+fi
+
+if [ ! -b /dev/sdb ] ; then
+    mknod /dev/sdb b 8 16
+fi
+
+if [ ! -b /dev/loop0 ] ; then
+    mknod /dev/loop0 b 7 0
+fi
+
+mkdir -p /tmp
+cat /proc/mounts > /etc/mtab
+
+disk_size=$(parted /dev/${device} unit mb print | grep Disk | cut -d" " -f 3 | sed -e "s/MB//")
+
+swap_size=$((disk_size*5/100))
+rootfs_size=$((disk_size-boot_size-swap_size))
+
+rootfs_start=$((boot_size + 1))
+rootfs_end=$((rootfs_start+rootfs_size))
+swap_start=$((rootfs_end+1))
+
+bootfs=/dev/${device}1
+rootfs=/dev/${device}2
+swap=/dev/${device}3
+
+echo "*****************"
+echo "Boot partition size:   $boot_size MB (/dev/${device}1)"
+echo "Rootfs partition size: $rootfs_size MB (/dev/${device}2)"
+echo "Swap partition size:   $swap_size MB (/dev/${device}3)"
+echo "*****************"
+echo "Deleting partition table on /dev/${device} ..."
+dd if=/dev/zero of=/dev/${device} bs=512 count=2
+
+echo "Creating new partition table on /dev/${device} ..."
+parted /dev/${device} mklabel msdos
+
+echo "Creating boot partition on /dev/${device}1"
+parted /dev/${device} mkpartfs primary ext2 0 $boot_size
+
+echo "Creating rootfs partition on /dev/${device}2"
+parted /dev/${device} mkpartfs primary ext2 $rootfs_start $rootfs_end 
+
+echo "Creating swap partition on /dev/${device}3"
+parted /dev/${device} mkpartfs primary linux-swap $swap_start $disk_size
+
+parted /dev/${device} print
+
+echo "Formatting /dev/${device}1 to ext2..."
+mkfs.ext3 $bootfs
+
+echo "Formatting /dev/${device}2 to ext3..."
+mkfs.ext3 $rootfs
+
+echo "Formatting swap partition...(/dev/${device}3)"
+mkswap $swap
+
+mkdir /ssd
+mkdir /rootmnt
+
+mount $rootfs /ssd
+mount -o rw,loop,noatime,nodiratime /media/$1/$2 /rootmnt
+
+echo "Copying rootfs files..."
+cp -a /rootmnt/* /ssd
+
+if [ -d /ssd/etc/ ] ; then
+    echo "$swap                swap             swap       defaults              0  0" >> /ssd/etc/fstab
+
+    # We dont want udev to mount our root device while we're booting...
+    if [ -d /ssd/etc/udev/ ] ; then
+	echo "/dev/${device}" >> /ssd/etc/udev/mount.blacklist
+    fi
+fi
+
+umount /ssd
+umount /rootmnt
+
+echo "Preparing boot partition..."
+mount $bootfs /ssd
+grub-install --root-directory=/ssd /dev/${device}
+
+echo "(hd0) /dev/${device}" > /ssd/boot/grub/device.map
+
+echo "default 0" > /ssd/boot/grub/menu.lst
+echo "timeout 30" >> /ssd/boot/grub/menu.lst
+echo "title Poky-Netbook" >> /ssd/boot/grub/menu.lst
+echo "root  (hd0,0)" >> /ssd/boot/grub/menu.lst
+echo "kernel /boot/vmlinuz root=$rootfs rw $3 $4 quiet" >> /ssd/boot/grub/menu.lst
+
+cp /media/$1/vmlinuz /ssd/boot/
+
+umount /ssd
+sync
+
+echo "Remove your installation media, and press ENTER"
+
+read enter
+
+echo "Rebooting..."
+reboot -f
diff --git a/meta/recipes-core/initrdscripts/files/init-live.sh b/meta/recipes-core/initrdscripts/files/init-live.sh
new file mode 100644
index 000000000..c96b1f47c
--- /dev/null
+++ b/meta/recipes-core/initrdscripts/files/init-live.sh
@@ -0,0 +1,92 @@
+#!/bin/sh
+
+ROOT_MOUNT="/rootfs/"
+ROOT_IMAGE=rootfs.img
+MOUNT="/bin/mount"
+UMOUNT="/bin/umount"
+
+early_setup() {
+    mkdir /proc
+    mkdir /sys
+    mount -t proc proc /proc
+    mount -t sysfs sysfs /sys
+    udevd --daemon
+}
+
+read_args() {
+    [ -z "$CMDLINE" ] && CMDLINE=`cat /proc/cmdline`
+    for arg in $CMDLINE; do
+        optarg=`expr "x$arg" : 'x[^=]*=\(.*\)'`
+        case $arg in
+            root=*)
+                ROOT_DEVICE=$optarg ;;
+            rootfstype=*)
+                ROOT_FSTYPE=$optarg ;;
+            rootdelay=*)
+                rootdelay=$optarg ;;
+	    LABEL=*)
+		label=$optarg ;;
+	    video=*)
+		video_mode=$arg ;;
+	    vga=*)
+		vga_mode=$arg ;;
+        esac
+    done
+}
+
+boot_live_root() {
+    killall udevd
+    cd $ROOT_MOUNT
+    exec switch_root -c /dev/console $ROOT_MOUNT /sbin/init
+}
+
+fatal() {
+    echo $1 >$CONSOLE
+    echo >$CONSOLE
+    exec sh
+}
+
+early_setup
+
+[ -z "$CONSOLE" ] && CONSOLE="/dev/console"
+
+read_args
+
+echo "Waiting for removable media..."
+while true
+do
+  for i in `ls /media 2>/dev/null`; do
+      if [ -f /media/$i/$ROOT_IMAGE ] ; then
+	  found="yes"
+	  break
+      fi
+  done
+  if [ "$found" = "yes" ]; then
+      break;
+  fi
+  sleep 1
+done
+
+case $label in
+    boot)
+	mkdir $ROOT_MOUNT
+	mknod /dev/loop0 b 7 0
+
+	if ! $MOUNT -o rw,loop,noatime,nodiratime /media/$i/$ROOT_IMAGE $ROOT_MOUNT ; then
+	    fatal "Couldnt mount rootfs image"
+	else
+	    boot_live_root
+	fi
+	;;
+    install)
+	if [ -f /media/$i/$ROOT_IMAGE ] ; then
+	    ./install.sh $i $ROOT_IMAGE $video_mode $vga_mode
+	else
+	    fatal "Couldnt find install script"
+	fi
+
+	# If we're getting here, we failed...
+	fatal "Installation image failed"
+	;;
+esac
+
diff --git a/meta/recipes-core/initrdscripts/initramfs-boot_1.0.bb b/meta/recipes-core/initrdscripts/initramfs-boot_1.0.bb
new file mode 100644
index 000000000..04ce51faf
--- /dev/null
+++ b/meta/recipes-core/initrdscripts/initramfs-boot_1.0.bb
@@ -0,0 +1,13 @@
+DESCRIPTON = "A live image init script"
+LICENSE = "MIT"
+
+SRC_URI = "file://init-boot.sh"
+
+PR = "r0"
+
+do_install() {
+        install -m 0755 ${WORKDIR}/init-boot.sh ${D}/init
+}
+
+PACKAGE_ARCH = "all"
+FILES_${PN} += " /init "
diff --git a/meta/recipes-core/initrdscripts/initramfs-live-boot_1.0.bb b/meta/recipes-core/initrdscripts/initramfs-live-boot_1.0.bb
new file mode 100644
index 000000000..ba36a5804
--- /dev/null
+++ b/meta/recipes-core/initrdscripts/initramfs-live-boot_1.0.bb
@@ -0,0 +1,13 @@
+DESCRIPTON = "A live image init script"
+LICENSE = "MIT"
+
+SRC_URI = "file://init-live.sh"
+
+PR = "r2"
+
+do_install() {
+        install -m 0755 ${WORKDIR}/init-live.sh ${D}/init
+}
+
+PACKAGE_ARCH = "all"
+FILES_${PN} += " /init "
diff --git a/meta/recipes-core/initrdscripts/initramfs-live-install_1.0.bb b/meta/recipes-core/initrdscripts/initramfs-live-install_1.0.bb
new file mode 100644
index 000000000..b15621b66
--- /dev/null
+++ b/meta/recipes-core/initrdscripts/initramfs-live-install_1.0.bb
@@ -0,0 +1,18 @@
+DESCRIPTON = "A live image init script"
+LICENSE = "MIT"
+
+SRC_URI = "file://init-install.sh"
+
+PR = "r3"
+
+RDEPENDS="grub parted e2fsprogs-mke2fs"
+
+do_install() {
+        install -m 0755 ${WORKDIR}/init-install.sh ${D}/install.sh
+}
+
+PACKAGE_ARCH = "all"
+FILES_${PN} = " /install.sh "
+
+# Alternatives to grub need adding for other arch support
+COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
-- 
cgit v1.2.3