From dc9cae2f12921b92f34f50bc0bd30ce814c9fbc7 Mon Sep 17 00:00:00 2001
From: Saul Wold <sgw@linux.intel.com>
Date: Fri, 11 Feb 2011 07:51:57 -0800
Subject: puzzles: Update to r9084

Signed-off-by: Saul Wold <sgw@linux.intel.com>
---
 meta/recipes-sato/puzzles/puzzles_r9076.bb | 61 ------------------------------
 meta/recipes-sato/puzzles/puzzles_r9084.bb | 61 ++++++++++++++++++++++++++++++
 2 files changed, 61 insertions(+), 61 deletions(-)
 delete mode 100644 meta/recipes-sato/puzzles/puzzles_r9076.bb
 create mode 100644 meta/recipes-sato/puzzles/puzzles_r9084.bb

(limited to 'meta/recipes-sato')

diff --git a/meta/recipes-sato/puzzles/puzzles_r9076.bb b/meta/recipes-sato/puzzles/puzzles_r9076.bb
deleted file mode 100644
index fbd0e37d5..000000000
--- a/meta/recipes-sato/puzzles/puzzles_r9076.bb
+++ /dev/null
@@ -1,61 +0,0 @@
-DESCRIPTION="Simon Tatham's Portable Puzzle Collection"
-HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/puzzles/"
-
-DEPENDS = "gtk+ libxt"
-PR = "r0"
-MOD_PV = "${@bb.data.getVar('PV',d,1)[1:]}"
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENCE;md5=9928b60f3b78be315b7ab699c1b03ff5"
-
-SRC_URI = "http://www.chiark.greenend.org.uk/~sgtatham/puzzles/puzzles-${PV}.tar.gz"
-
-# Checksums seem to be changing regularly right now, need to verify with upstream
-#SRC_URI[md5sum] = "e8b4c7e2341264789f3cd6733857bf1c"
-#SRC_URI[sha256sum] = "69f37e497e63b2f7ab44e7bbd50aee078269c16dbc2d78ec1b00257678f2cbd2"
-#SRC_URI = "svn://ixion.tartarus.org/main;module=puzzles;rev=${MOD_PV}"
-
-S = "${WORKDIR}/${PN}-${PV}"
-
-do_configure () {
-	./mkfiles.pl
-}
-
-do_compile_prepend = " \
-        export XLDFLAGS='${LDFLAGS} `${STAGING_BINDIR_NATIVE}/pkg-config gtk+-2.0 --libs`'; \
-	export CFLAGS='${CFLAGS} -I./ `${STAGING_BINDIR_NATIVE}/pkg-config gtk+-2.0 --cflags`'; "
-
-FILES_${PN} = "${prefix}/games/* ${datadir}/applications/*"
-FILES_${PN}-dbg += "${prefix}/games/.debug"
-
-do_install () {
-    rm -rf ${D}/*
-    export prefix=${D}
-    export DESTDIR=${D}
-    install -d ${D}/${prefix}/
-    install -d ${D}/${prefix}/games/
-    oe_runmake install
-    
-    install -d ${D}/${datadir}/
-    install -d ${D}/${datadir}/applications/
-
-    cd ${D}/${prefix}/games 
-    for prog in *; do
-	if [ -x $prog ]; then
-            # Convert prog to Title Case
-            title=$(echo $prog | sed 's/\(^\| \)./\U&/g')
-	    echo "making ${D}/${datadir}/applications/$prog.desktop"
-	    cat <<STOP > ${D}/${datadir}/applications/$prog.desktop
-[Desktop Entry]
-Name=$title
-Exec=${prefix}/games/$prog
-Icon=applications-games
-Terminal=false
-Type=Application
-Categories=Game;
-StartupNotify=true
-X-MB-SingleInstance=true
-STOP
-        fi
-    done
-}
diff --git a/meta/recipes-sato/puzzles/puzzles_r9084.bb b/meta/recipes-sato/puzzles/puzzles_r9084.bb
new file mode 100644
index 000000000..fbd0e37d5
--- /dev/null
+++ b/meta/recipes-sato/puzzles/puzzles_r9084.bb
@@ -0,0 +1,61 @@
+DESCRIPTION="Simon Tatham's Portable Puzzle Collection"
+HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/puzzles/"
+
+DEPENDS = "gtk+ libxt"
+PR = "r0"
+MOD_PV = "${@bb.data.getVar('PV',d,1)[1:]}"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENCE;md5=9928b60f3b78be315b7ab699c1b03ff5"
+
+SRC_URI = "http://www.chiark.greenend.org.uk/~sgtatham/puzzles/puzzles-${PV}.tar.gz"
+
+# Checksums seem to be changing regularly right now, need to verify with upstream
+#SRC_URI[md5sum] = "e8b4c7e2341264789f3cd6733857bf1c"
+#SRC_URI[sha256sum] = "69f37e497e63b2f7ab44e7bbd50aee078269c16dbc2d78ec1b00257678f2cbd2"
+#SRC_URI = "svn://ixion.tartarus.org/main;module=puzzles;rev=${MOD_PV}"
+
+S = "${WORKDIR}/${PN}-${PV}"
+
+do_configure () {
+	./mkfiles.pl
+}
+
+do_compile_prepend = " \
+        export XLDFLAGS='${LDFLAGS} `${STAGING_BINDIR_NATIVE}/pkg-config gtk+-2.0 --libs`'; \
+	export CFLAGS='${CFLAGS} -I./ `${STAGING_BINDIR_NATIVE}/pkg-config gtk+-2.0 --cflags`'; "
+
+FILES_${PN} = "${prefix}/games/* ${datadir}/applications/*"
+FILES_${PN}-dbg += "${prefix}/games/.debug"
+
+do_install () {
+    rm -rf ${D}/*
+    export prefix=${D}
+    export DESTDIR=${D}
+    install -d ${D}/${prefix}/
+    install -d ${D}/${prefix}/games/
+    oe_runmake install
+    
+    install -d ${D}/${datadir}/
+    install -d ${D}/${datadir}/applications/
+
+    cd ${D}/${prefix}/games 
+    for prog in *; do
+	if [ -x $prog ]; then
+            # Convert prog to Title Case
+            title=$(echo $prog | sed 's/\(^\| \)./\U&/g')
+	    echo "making ${D}/${datadir}/applications/$prog.desktop"
+	    cat <<STOP > ${D}/${datadir}/applications/$prog.desktop
+[Desktop Entry]
+Name=$title
+Exec=${prefix}/games/$prog
+Icon=applications-games
+Terminal=false
+Type=Application
+Categories=Game;
+StartupNotify=true
+X-MB-SingleInstance=true
+STOP
+        fi
+    done
+}
-- 
cgit v1.2.3