From 9eb2de9163791e1cf02a1fbf94da1ed55d8378c5 Mon Sep 17 00:00:00 2001
From: Richard Purdie <rpurdie@linux.intel.com>
Date: Thu, 14 Oct 2010 11:42:37 +0100
Subject: Revert "meta-toolchain: Update the way ld.so.cache is handled"

This change didn't work as expected as ld.so.cache doesn't preseve any search
path ordering, therefore revert the change.

This reverts commit b2c3ce6d17520d43b10777dd306449876cb40819.
---
 meta/recipes-tbd/meta/meta-toolchain.bb | 11 ++---------
 1 file changed, 2 insertions(+), 9 deletions(-)

(limited to 'meta/recipes-tbd')

diff --git a/meta/recipes-tbd/meta/meta-toolchain.bb b/meta/recipes-tbd/meta/meta-toolchain.bb
index 633f5f199..2fab8f94b 100644
--- a/meta/recipes-tbd/meta/meta-toolchain.bb
+++ b/meta/recipes-tbd/meta/meta-toolchain.bb
@@ -72,15 +72,8 @@ do_populate_sdk() {
 	#rm -f ${SDK_OUTPUT}/${SDKPATHNATIVE}/lib/*.la
 	rm -f ${SDK_OUTPUT}/${SDKPATHNATIVE}${libdir_nativesdk}/*.la
 
-	# Create an appropriate setup so the dynamic loader can find libs in 
-	# both the host system and the toolchain directories
-	echo ${SDKPATHNATIVE}${libdir} > ${SDK_OUTPUT}/${SDKPATHNATIVE}/etc/ld.so.conf
-	echo ${SDKPATHNATIVE}${base_libdir} >> ${SDK_OUTPUT}/${SDKPATHNATIVE}/etc/ld.so.conf
-	echo "include /etc/ld.so.conf" >> ${SDK_OUTPUT}/${SDKPATHNATIVE}/etc/ld.so.conf
-	echo "#!/bin/sh" > ${SDK_OUTPUT}/${SDKPATH}/postinstall
-	echo "ldconfig -f ${SDKPATHNATIVE}/etc/ld.so.conf -C /${SDKPATHNATIVE}/etc/ld.so.cache" >> ${SDK_OUTPUT}/${SDKPATH}/postinstall
-	chmod a+x ${SDK_OUTPUT}/${SDKPATH}/postinstall
-
+	# Link the ld.so.cache file into the hosts filesystem
+	ln -s /etc/ld.so.cache ${SDK_OUTPUT}/${SDKPATHNATIVE}/etc/ld.so.cache
 
 	# Setup site file for external use
 	siteconfig=${SDK_OUTPUT}/${SDKPATH}/site-config-${MULTIMACH_TARGET_SYS}
-- 
cgit v1.2.3