From 11cbd871e0969931d5c81ec53684446f4293faf1 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Thu, 12 Apr 2012 21:35:14 -0700
Subject: gcc-4.7: Do not use --with-header option for cross-gcc

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-devtools/gcc/gcc-configure-cross.inc | 2 +-
 meta/recipes-devtools/gcc/gcc-cross_4.7.bb        | 6 ++++++
 2 files changed, 7 insertions(+), 1 deletion(-)

(limited to 'meta')

diff --git a/meta/recipes-devtools/gcc/gcc-configure-cross.inc b/meta/recipes-devtools/gcc/gcc-configure-cross.inc
index 65e340a0d..3cb3452e6 100644
--- a/meta/recipes-devtools/gcc/gcc-configure-cross.inc
+++ b/meta/recipes-devtools/gcc/gcc-configure-cross.inc
@@ -3,12 +3,12 @@ require gcc-configure-common.inc
 USE_NLS = '${@base_conditional( "TARGET_OS", "linux-uclibc", "no", "", d )}'
 
 EXTRA_OECONF += " --enable-poison-system-directories \
-		  --with-headers=${STAGING_DIR_TARGET}${SYSTEMHEADERS} \
 		"
 
 INHIBIT_DEFAULT_DEPS = "1"
 
 EXTRA_OECONF_PATHS = " \
+		      --with-headers=${STAGING_DIR_TARGET}${SYSTEMHEADERS} \
 		      --with-gxx-include-dir=${STAGING_DIR_TARGET}${target_includedir}/c++ \
                       --with-sysroot=${STAGING_DIR_TARGET} \
                       --with-build-sysroot=${STAGING_DIR_TARGET}"
diff --git a/meta/recipes-devtools/gcc/gcc-cross_4.7.bb b/meta/recipes-devtools/gcc/gcc-cross_4.7.bb
index 75679d1b0..d60523513 100644
--- a/meta/recipes-devtools/gcc/gcc-cross_4.7.bb
+++ b/meta/recipes-devtools/gcc/gcc-cross_4.7.bb
@@ -5,4 +5,10 @@ EXTRA_OECONF += "--disable-libunwind-exceptions \
                  --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native} \
                  --with-system-zlib "
 
+EXTRA_OECONF_PATHS = " \
+                      --with-gxx-include-dir=${STAGING_DIR_TARGET}${target_includedir}/c++ \
+                      --with-sysroot=${STAGING_DIR_TARGET} \
+                      --with-build-sysroot=${STAGING_DIR_TARGET}"
+
+
 ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${target_includedir}"
-- 
cgit v1.2.3