From 21f2dae46b481dbf34f6874ae814dcd23fc86d54 Mon Sep 17 00:00:00 2001
From: Richard Purdie <richard.purdie@linuxfoundation.org>
Date: Mon, 31 Jan 2011 16:37:32 +0000
Subject: libgcc: Explicitly wait for the libc packaging to occur before libgcc
 packages

libgcc can link against the libc and libc can be dynamically renamed
so we ensure we package after libc. There was code in the gcc core
for this in the ipk case but it wasn't moved as part of the libgcc
split, this change fixes that oversight.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
 meta/recipes-devtools/gcc/gcc-configure-cross.inc | 2 --
 meta/recipes-devtools/gcc/libgcc_4.5.1.bb         | 4 ++++
 2 files changed, 4 insertions(+), 2 deletions(-)

(limited to 'meta')

diff --git a/meta/recipes-devtools/gcc/gcc-configure-cross.inc b/meta/recipes-devtools/gcc/gcc-configure-cross.inc
index 04a868535..346d1640d 100644
--- a/meta/recipes-devtools/gcc/gcc-configure-cross.inc
+++ b/meta/recipes-devtools/gcc/gcc-configure-cross.inc
@@ -20,5 +20,3 @@ do_compile_prepend () {
 
 LIBGCCS_VAR = "-lgcc_s"
 LIBGCCS_VAR_avr32 = ""
-
-do_package_write_ipk[depends] += "virtual/libc:do_package"
diff --git a/meta/recipes-devtools/gcc/libgcc_4.5.1.bb b/meta/recipes-devtools/gcc/libgcc_4.5.1.bb
index a99fdeffd..b6cf2685e 100644
--- a/meta/recipes-devtools/gcc/libgcc_4.5.1.bb
+++ b/meta/recipes-devtools/gcc/libgcc_4.5.1.bb
@@ -38,5 +38,9 @@ do_install () {
 	fi
 }
 
+do_package_write_ipk[depends] += "virtual/libc:do_package"
+do_package_write_deb[depends] += "virtual/libc:do_package"
+do_package_write_rpm[depends] += "virtual/libc:do_package"
+
 BBCLASSEXTEND = "nativesdk"
 
-- 
cgit v1.2.3