From 272266f06ffbf67a73893ac5c46ee5e14688b16f Mon Sep 17 00:00:00 2001
From: Richard Purdie <richard@openedhand.com>
Date: Wed, 11 Oct 2006 14:39:05 +0000
Subject: oprofile: Remove some bashisms and general breakage

git-svn-id: https://svn.o-hand.com/repos/poky/trunk@792 311d38ba-8fff-0310-9ca6-ca027cbcb966
---
 .../oprofile/oprofile/opcontrol_bashisms.patch     | 24 ++++++++++++++++++++++
 meta/packages/oprofile/oprofile_cvs.bb             |  2 ++
 2 files changed, 26 insertions(+)
 create mode 100644 meta/packages/oprofile/oprofile/opcontrol_bashisms.patch

(limited to 'meta')

diff --git a/meta/packages/oprofile/oprofile/opcontrol_bashisms.patch b/meta/packages/oprofile/oprofile/opcontrol_bashisms.patch
new file mode 100644
index 000000000..58e2cb809
--- /dev/null
+++ b/meta/packages/oprofile/oprofile/opcontrol_bashisms.patch
@@ -0,0 +1,24 @@
+ utils/opcontrol |    3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+Index: oprofile/utils/opcontrol
+===================================================================
+--- oprofile.orig/utils/opcontrol	2006-02-10 14:18:13.000000000 +0000
++++ oprofile/utils/opcontrol	2006-10-11 15:52:16.000000000 +0100
+@@ -476,7 +476,7 @@ validate_separate_args()
+ 	SEPARATE_KERNEL=0
+ 	SEPARATE_THREAD=0
+ 	SEPARATE_CPU=0
+-	while (($i < $#)); do
++	while [ "$i" -lt "$#" ]; do
+ 		shift
+ 		case "$1" in
+ 			lib|library)
+@@ -1513,7 +1513,6 @@ check_version()
+ BINDIR="/usr/bin"
+ OPCONTROL=`$BINDIR/which $0`
+ OPDIR=`$BINDIR/dirname $OPCONTROL`
+-n
+ PATH=/usr/local/bin:/usr/local/sbin:/bin:/sbin:/usr/bin:/usr/sbin
+ 
+ check_version_help $@
diff --git a/meta/packages/oprofile/oprofile_cvs.bb b/meta/packages/oprofile/oprofile_cvs.bb
index 1a255d357..087cc3396 100644
--- a/meta/packages/oprofile/oprofile_cvs.bb
+++ b/meta/packages/oprofile/oprofile_cvs.bb
@@ -1,4 +1,5 @@
 PV = "0.9.1+cvs${SRCDATE}"
+PR = "r1"
 SECTION = "devel"
 DESCRIPTION = "OProfile is a system-wide profiler for Linux systems, capable \
 of profiling all running code at low overhead."
@@ -7,6 +8,7 @@ DEPENDS = "popt binutils"
 
 SRC_URI = "cvs://anonymous@oprofile.cvs.sourceforge.net/cvsroot/oprofile;module=oprofile \
 	   file://no_arm_mapping_syms.patch;patch=1 \
+           file://opcontrol_bashisms.patch;patch=1 \
 	   file://acinclude.m4"
 S = "${WORKDIR}/oprofile"
 
-- 
cgit v1.2.3