From 2e9e8af197671ae06de1bdc9201765b160869d60 Mon Sep 17 00:00:00 2001
From: Liping Ke <liping.ke@intel.com>
Date: Thu, 10 Mar 2011 17:27:55 +0800
Subject: Disable wget server side cache

We found some proxy server has wrong cache for long http file name.
It will cause fetching wrong ipk files from adt repo. To avoid this,
we use wget options --no-cache to disable all server side cache.
It will make the fetch speed slower, yet correct always.

Signed-off-by: Liping Ke <liping.ke@intel.com>
Signed-off-by: Lianhao Lu <lianhao.lu@intel.com>
---
 meta/recipes-devtools/installer/adt-installer_1.0.bb   |  3 ++-
 meta/recipes-devtools/installer/files/wget_cache.patch | 10 ++++++++++
 2 files changed, 12 insertions(+), 1 deletion(-)
 create mode 100644 meta/recipes-devtools/installer/files/wget_cache.patch

(limited to 'meta')

diff --git a/meta/recipes-devtools/installer/adt-installer_1.0.bb b/meta/recipes-devtools/installer/adt-installer_1.0.bb
index 50290f9ff..ff7afe662 100644
--- a/meta/recipes-devtools/installer/adt-installer_1.0.bb
+++ b/meta/recipes-devtools/installer/adt-installer_1.0.bb
@@ -36,11 +36,13 @@ PR = "r0"
 ADT_DEPLOY = "${TMPDIR}/deploy/sdk/"
 ADT_DIR = "${WORKDIR}/adt-installer/"
 YOCTOADT_VERSION = "${SDK_VERSION}"
+S = "${WORKDIR}/trunk"
 
 inherit deploy
 
 PV = "0.1.8+svnr${SRCPV}"
 SRC_URI = "svn://opkg.googlecode.com/svn;module=trunk;proto=http \
+           file://wget_cache.patch \
            file://adt_installer \
            file://scripts/adt_installer_internal \
            file://scripts/util \
@@ -70,7 +72,6 @@ fakeroot do_deploy () {
 	cp ${WORKDIR}/adt_installer.tar.bz2 ${ADT_DEPLOY}
 }
 
-do_patch[noexec] = "1"
 do_install[noexec] = "1"
 do_configure[noexec] = "1"
 do_compile[noexec] = "1"
diff --git a/meta/recipes-devtools/installer/files/wget_cache.patch b/meta/recipes-devtools/installer/files/wget_cache.patch
new file mode 100644
index 000000000..6fd38e5fc
--- /dev/null
+++ b/meta/recipes-devtools/installer/files/wget_cache.patch
@@ -0,0 +1,10 @@
+--- trunk/libopkg/opkg_download.c	2011-03-10 16:41:29.000000000 +0800
++++ trunk/libopkg/opkg_download.c	2011-03-10 16:42:33.000000000 +0800
+@@ -162,6 +162,7 @@
+ 
+       argv[i++] = "wget";
+       argv[i++] = "-q";
++      argv[i++] = "--no-cache";
+       if (conf->http_proxy || conf->ftp_proxy) {
+ 	argv[i++] = "-Y";
+ 	argv[i++] = "on";
-- 
cgit v1.2.3