From 2f7ac32b57e047cdaf01e0b6f77509117dbbd14c Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Thu, 22 Mar 2012 15:53:05 -0700
Subject: gcc-crosssdk-intermediate: Use --with-native-system-header-dir for
 4.7

--with-native-system-header-dir is relative to sysroot which
is what we want --with-headers is deprecated anyway

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-devtools/gcc/gcc-crosssdk-intermediate.inc    | 2 --
 meta/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.6.bb | 1 +
 meta/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.7.bb | 1 +
 3 files changed, 2 insertions(+), 2 deletions(-)

(limited to 'meta')

diff --git a/meta/recipes-devtools/gcc/gcc-crosssdk-intermediate.inc b/meta/recipes-devtools/gcc/gcc-crosssdk-intermediate.inc
index 8f20d2015..ed5d5e838 100644
--- a/meta/recipes-devtools/gcc/gcc-crosssdk-intermediate.inc
+++ b/meta/recipes-devtools/gcc/gcc-crosssdk-intermediate.inc
@@ -7,5 +7,3 @@ SYSTEMLIBS1 = "${SDKPATHNATIVE}${libdir_nativesdk}/"
 DEPENDS = "virtual/${TARGET_PREFIX}binutils-crosssdk gettext-native"
 DEPENDS += "virtual/${TARGET_PREFIX}libc-initial-nativesdk"
 PROVIDES = "virtual/${TARGET_PREFIX}gcc-intermediate-crosssdk"
-
-EXTRA_OECONF += " --with-headers=${STAGING_DIR_TCBOOTSTRAP}${SYSTEMHEADERS} "
diff --git a/meta/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.6.bb b/meta/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.6.bb
index c7233af07..3820cb670 100644
--- a/meta/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.6.bb
+++ b/meta/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.6.bb
@@ -1,2 +1,3 @@
 require recipes-devtools/gcc/gcc-cross-intermediate_${PV}.bb
 require gcc-crosssdk-intermediate.inc
+EXTRA_OECONF += " --with-headers=${STAGING_DIR_TCBOOTSTRAP}${SYSTEMHEADERS} "
diff --git a/meta/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.7.bb b/meta/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.7.bb
index 1aa588ac9..32788988e 100644
--- a/meta/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.7.bb
+++ b/meta/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.7.bb
@@ -1,2 +1,3 @@
 require gcc-cross-intermediate_${PV}.bb
 require gcc-crosssdk-intermediate.inc
+EXTRA_OECONF += " --with-native-system-header-dir=${SYSTEMHEADERS} "
-- 
cgit v1.2.3