From 339d039a9b2f0e97f25781ccf6937f1050d83989 Mon Sep 17 00:00:00 2001
From: Tom Rini <tom_rini@mentor.com>
Date: Mon, 18 Jul 2011 09:19:07 -0700
Subject: python-native: Mangle scripts to use /usr/bin/env python, bump PR

This is dd33ced4b8123600efa1f67f704aec13b0842ad1 in oe.dev and needed
for building in deep paths.

Signed-off-by: Tom Rini <tom_rini@mentor.com>
---
 meta/recipes-devtools/python/python-native_2.6.6.bb | 5 +++++
 1 file changed, 5 insertions(+)

(limited to 'meta')

diff --git a/meta/recipes-devtools/python/python-native_2.6.6.bb b/meta/recipes-devtools/python/python-native_2.6.6.bb
index fa943f463..59ed61a67 100644
--- a/meta/recipes-devtools/python/python-native_2.6.6.bb
+++ b/meta/recipes-devtools/python/python-native_2.6.6.bb
@@ -36,4 +36,9 @@ do_install() {
 	oe_runmake 'DESTDIR=${D}' install
 	install -d ${D}${bindir}/
 	install -m 0755 Parser/pgen ${D}${bindir}/
+
+	# Make sure we use /usr/bin/env python
+	for PYTHSCRIPT in `grep -rIl ${bindir}/python ${D}${bindir}`; do
+		sed -i -e '1s|^#!.*|#!/usr/bin/env python|' $PYTHSCRIPT
+	done
 }
-- 
cgit v1.2.3