From 5b44fa1f2929b850cd9b36df6db10a14d2b99a39 Mon Sep 17 00:00:00 2001
From: Richard Purdie <rpurdie@linux.intel.com>
Date: Wed, 18 Nov 2009 22:04:55 +0000
Subject: perl: Updates to ensure Config-heavy-target.pl is found

Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
---
 meta/packages/perl/perl-5.8.8/perl-configpm-switch.patch | 13 +++++++++++--
 meta/packages/perl/perl_5.8.8.bb                         |  2 ++
 2 files changed, 13 insertions(+), 2 deletions(-)

(limited to 'meta')

diff --git a/meta/packages/perl/perl-5.8.8/perl-configpm-switch.patch b/meta/packages/perl/perl-5.8.8/perl-configpm-switch.patch
index 1aacd3518..ac519a027 100644
--- a/meta/packages/perl/perl-5.8.8/perl-configpm-switch.patch
+++ b/meta/packages/perl/perl-5.8.8/perl-configpm-switch.patch
@@ -18,7 +18,7 @@ values would be valid for the host only.
  
      return $self->fetch_string($key);
  }
-@@ -530,7 +530,12 @@
+@@ -530,7 +530,21 @@
  sub DESTROY { }
  
  sub AUTOLOAD {
@@ -28,7 +28,16 @@ values would be valid for the host only.
 +    {
 +        $cfgfile = 'Config_heavy-target.pl';
 +    }
-+    require $cfgfile;
++    if (defined $ENV{PERL_ARCHLIB})
++    {
++        push @INC, $ENV{PERL_ARCHLIB};
++        require $cfgfile;
++        pop @INC;
++    }
++    else
++    {
++        require $cfgfile;
++    }
      goto \&launcher unless $Config::AUTOLOAD =~ /launcher$/;
      die "&Config::AUTOLOAD failed on $Config::AUTOLOAD";
  }
diff --git a/meta/packages/perl/perl_5.8.8.bb b/meta/packages/perl/perl_5.8.8.bb
index fa1a8d34c..bf68cfcc8 100644
--- a/meta/packages/perl/perl_5.8.8.bb
+++ b/meta/packages/perl/perl_5.8.8.bb
@@ -129,6 +129,8 @@ do_install() {
 
         install -d ${D}${datadir}/perl/${PV}/ExtUtils
 	install lib/ExtUtils/typemap ${D}${datadir}/perl/${PV}/ExtUtils/
+	
+	ln -s Config_heavy.pl ${D}${libdir}/perl/${PV}/Config_heavy-target.pl
 }
 
 PACKAGE_PREPROCESS_FUNCS += "perl_package_preprocess"
-- 
cgit v1.2.3