From 7b8db36e088e3e9cd585e8d8dde1c1c2860c3c2e Mon Sep 17 00:00:00 2001
From: Mark Hatle <mark.hatle@windriver.com>
Date: Wed, 21 Sep 2011 20:47:03 -0500
Subject: perl: Fix a few perl binaries to use target interpreter paths

A small number of target installed programs, "${bindir}/pod*",
were incorrectly using the perl-native paths to access perl.  This
caused a dependency failure during RPM rootfs install, and also
prevented those specific components from functioning.

Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
 meta/recipes-devtools/perl/perl_5.12.3.bb | 10 +++++++++-
 1 file changed, 9 insertions(+), 1 deletion(-)

(limited to 'meta')

diff --git a/meta/recipes-devtools/perl/perl_5.12.3.bb b/meta/recipes-devtools/perl/perl_5.12.3.bb
index d28656486..e4769a423 100644
--- a/meta/recipes-devtools/perl/perl_5.12.3.bb
+++ b/meta/recipes-devtools/perl/perl_5.12.3.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
 # We need gnugrep (for -I)
 DEPENDS = "virtual/db grep-native"
 DEPENDS += "gdbm zlib"
-PR = "r4"
+PR = "r5"
 
 # 5.10.1 has Module::Build built-in
 PROVIDES += "libmodule-build-perl"
@@ -216,9 +216,17 @@ perl_package_preprocess () {
                -e "s,${STAGING_LIBDIR},${libdir},g" \
                -e "s,${STAGING_BINDIR},${bindir},g" \
                -e "s,${STAGING_INCDIR},${includedir},g" \
+               -e "s,${STAGING_BINDIR_NATIVE}/perl-native/,${bindir}/,g" \
                -e "s,${STAGING_BINDIR_NATIVE}/,,g" \
             ${PKGD}${bindir}/h2xs \
             ${PKGD}${bindir}/h2ph \
+            ${PKGD}${bindir}/pod2html \
+            ${PKGD}${bindir}/pod2latex \
+            ${PKGD}${bindir}/pod2man \
+            ${PKGD}${bindir}/pod2text \
+            ${PKGD}${bindir}/pod2usage \
+            ${PKGD}${bindir}/podchecker \
+            ${PKGD}${bindir}/podselect \
             ${PKGD}${libdir}/perl/${PV}/pod/*.pod \
             ${PKGD}${libdir}/perl/${PV}/cacheout.pl \
             ${PKGD}${libdir}/perl/${PV}/FileCache.pm \
-- 
cgit v1.2.3