From 9106e2922ba5972e3b87436372a12c2e04e9eb65 Mon Sep 17 00:00:00 2001
From: Saul Wold <sgw@linux.intel.com>
Date: Sat, 3 Sep 2011 20:51:02 -0700
Subject: groff: Fix sstate relocation issue

[YOCTO #1439]

This fixes a problem where the native groff has a path hard coded into
it, therefor add a wrapper to set the command line with the correct
paths for fonts and tmac directories.

Signed-off-by: Saul Wold <sgw@linux.intel.com>
---
 meta/recipes-extended/groff/groff_1.20.1.bb | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)

(limited to 'meta')

diff --git a/meta/recipes-extended/groff/groff_1.20.1.bb b/meta/recipes-extended/groff/groff_1.20.1.bb
index 708591100..6cb72bf11 100644
--- a/meta/recipes-extended/groff/groff_1.20.1.bb
+++ b/meta/recipes-extended/groff/groff_1.20.1.bb
@@ -4,7 +4,7 @@ formatting commands and produces formatted output."
 SECTION = "base"
 HOMEPAGE = "ftp://ftp.gnu.org/gnu/groff/"
 LICENSE = "GPLv2"
-PR = "r0"
+PR = "r1"
 
 LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
 
@@ -34,4 +34,11 @@ do_configure_prepend() {
 	fi
 }
 
+do_install_append_virtclass-native() {
+	create_cmdline_wrapper ${D}/${bindir}/groff \
+		-F${STAGING_DIR_NATIVE}${datadir_native}/groff/${PV}/font \
+		-M${STAGING_DIR_NATIVE}${datadir_native}/groff/${PV}/tmac
+}
+
+
 BBCLASSEXTEND = "native"
-- 
cgit v1.2.3