From a1bb79372e75269b8d135c0018955c533ba06027 Mon Sep 17 00:00:00 2001
From: Mark Hatle <mark.hatle@windriver.com>
Date: Tue, 15 Mar 2011 22:01:50 -0500
Subject: libzypp: Fix release query

Libzypp is looking for the "redhat-release" file and using that version
number to help adjust the system version.  This ensures that there is
something on the system that returns a correct value.

This patch is likely not necessary.

Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
---
 .../libzypp/libzypp/config-release.patch            | 21 +++++++++++++++++++++
 meta/recipes-extended/libzypp/libzypp_git.bb        |  3 ++-
 2 files changed, 23 insertions(+), 1 deletion(-)
 create mode 100644 meta/recipes-extended/libzypp/libzypp/config-release.patch

(limited to 'meta')

diff --git a/meta/recipes-extended/libzypp/libzypp/config-release.patch b/meta/recipes-extended/libzypp/libzypp/config-release.patch
new file mode 100644
index 000000000..912823775
--- /dev/null
+++ b/meta/recipes-extended/libzypp/libzypp/config-release.patch
@@ -0,0 +1,21 @@
+Configure distro version package
+
+We need to configure a package that the system can use to determine the
+system distribution version.
+
+Hack: for now set to task-poky-rpm.
+
+Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
+
+diff -ur git.orig/zypp/ZConfig.cc git/zypp/ZConfig.cc
+--- git.orig/zypp/ZConfig.cc	2011-03-14 16:30:07.492786134 -0500
++++ git/zypp/ZConfig.cc	2011-03-15 11:39:15.396801927 -0500
+@@ -821,7 +821,7 @@
+   ///////////////////////////////////////////////////////////////////
+ 
+   std::string ZConfig::distroverpkg() const
+-  { return "redhat-release"; }
++  { return "task-poky-rpm"; }
+ 
+   ///////////////////////////////////////////////////////////////////
+ 
diff --git a/meta/recipes-extended/libzypp/libzypp_git.bb b/meta/recipes-extended/libzypp/libzypp_git.bb
index 825339d12..621ce45da 100644
--- a/meta/recipes-extended/libzypp/libzypp_git.bb
+++ b/meta/recipes-extended/libzypp/libzypp_git.bb
@@ -13,7 +13,7 @@ RDEPENDS_${PN} = "sat-solver"
 
 S = "${WORKDIR}/git"
 PV = "0.0-git${SRCPV}"
-PR = "r7"
+PR = "r8"
 
 SRC_URI = "git://gitorious.org/opensuse/libzypp.git;protocol=git \
            file://no-doc.patch \
@@ -22,6 +22,7 @@ SRC_URI = "git://gitorious.org/opensuse/libzypp.git;protocol=git \
            file://builtin-arch.patch;apply=no \
            file://no-builtin-arch.patch;apply=no \
            file://archconf.patch;apply=no \
+	   file://config-release.patch \
           "
 
 SRC_URI_append_mips = " file://mips-workaround-gcc-tribool-error.patch"
-- 
cgit v1.2.3