From cb7d25e1836527544afaa53394908634e2529a0b Mon Sep 17 00:00:00 2001
From: Richard Purdie <richard@openedhand.com>
Date: Fri, 15 Feb 2008 17:29:40 +0000
Subject: meta-toolchain: Add version data to the sdk tarballs

git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3820 311d38ba-8fff-0310-9ca6-ca027cbcb966
---
 meta/packages/meta/meta-toolchain.bb | 8 ++++++++
 1 file changed, 8 insertions(+)

(limited to 'meta')

diff --git a/meta/packages/meta/meta-toolchain.bb b/meta/packages/meta/meta-toolchain.bb
index fb213b88b..525d09091 100644
--- a/meta/packages/meta/meta-toolchain.bb
+++ b/meta/packages/meta/meta-toolchain.bb
@@ -123,6 +123,14 @@ do_populate_sdk() {
 	echo 'export PKG_CONFIG_PATH=${prefix}/${TARGET_SYS}/lib/pkgconfig' >> $script
 	echo 'export CONFIG_SITE=${prefix}/site-config' >> $script
 
+	# Add version information
+	versionfile=${SDK_OUTPUT}/${prefix}/version
+	touch $versionfile
+	echo 'Distro: ${DISTRO}' >> $versionfile
+	echo 'Distro Version: ${DISTRO_VERSION}' >> $versionfile
+	echo 'Metadata Revision: ${METADATA_REVISION}' >> $versionfile
+	echo 'Timestamp: ${DATETIME}' >> $versionfile
+
 	# Package it up
 	mkdir -p ${SDK_DEPLOY}
 	cd ${SDK_OUTPUT}
-- 
cgit v1.2.3