From ce1e2f2df5b245382aa90fb37aae879faf87a570 Mon Sep 17 00:00:00 2001
From: Richard Purdie <richard@openedhand.com>
Date: Wed, 19 Mar 2008 22:00:26 +0000
Subject: libgcrypt: Upgrade to 1.2.4 and add pkgconfig support

git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4081 311d38ba-8fff-0310-9ca6-ca027cbcb966
---
 .../libgcrypt/files/add-pkgconfig-support.patch    | 62 ++++++++++++++++++++++
 meta/packages/libgcrypt/libgcrypt.inc              | 22 ++++++++
 meta/packages/libgcrypt/libgcrypt_1.2.3.bb         | 22 --------
 meta/packages/libgcrypt/libgcrypt_1.2.4.bb         |  3 ++
 4 files changed, 87 insertions(+), 22 deletions(-)
 create mode 100644 meta/packages/libgcrypt/files/add-pkgconfig-support.patch
 create mode 100644 meta/packages/libgcrypt/libgcrypt.inc
 delete mode 100644 meta/packages/libgcrypt/libgcrypt_1.2.3.bb
 create mode 100644 meta/packages/libgcrypt/libgcrypt_1.2.4.bb

(limited to 'meta')

diff --git a/meta/packages/libgcrypt/files/add-pkgconfig-support.patch b/meta/packages/libgcrypt/files/add-pkgconfig-support.patch
new file mode 100644
index 000000000..9b00e8262
--- /dev/null
+++ b/meta/packages/libgcrypt/files/add-pkgconfig-support.patch
@@ -0,0 +1,62 @@
+diff -Nur libgcrypt-1.2.4/configure.ac libgcrypt11-1.2.4/configure.ac
+--- libgcrypt-1.2.4/configure.ac 2007-02-01 19:41:06.000000000 +0100
++++ libgcrypt11-1.2.4/configure.ac 2007-02-11 13:05:36.000000000 +0100
+@@ -808,6 +808,7 @@
+ src/Makefile
+ src/gcrypt.h
+ src/libgcrypt-config
++src/libgcrypt.pc
+ tests/Makefile
+ w32-dll/Makefile
+ ])
+diff -Nur libgcrypt-1.2.4/src/libgcrypt.pc.in libgcrypt11-1.2.4/src/libgcrypt.pc.in
+--- libgcrypt-1.2.4/src/libgcrypt.pc.in 1970-01-01 01:00:00.000000000 +0100
++++ libgcrypt11-1.2.4/src/libgcrypt.pc.in 2007-02-11 13:03:30.000000000 +0100
+@@ -0,0 +1,32 @@
++# Process this file with autoconf to produce a pkg-config metadata file.
++# Copyright (C) 2002, 2003, 2004, 2005, 2006 Free Software Foundation
++# Author: Simon Josefsson
++#
++# This file is free software; as a special exception the author gives
++# unlimited permission to copy and/or distribute it, with or without
++# modifications, as long as this notice is preserved.
++#
++# This file is distributed in the hope that it will be useful, but
++# WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
++# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
++
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++# API info
++api_version=@LIBGCRYPT_CONFIG_API_VERSION@
++
++# Misc information.
++symmetric_ciphers=@LIBGCRYPT_CIPHERS@
++asymmetric_ciphers=@LIBGCRYPT_PUBKEY_CIPHERS@
++digests=@LIBGCRYPT_DIGESTS@
++
++Name: libgcrypt
++Description: GNU crypto library
++URL: http://www.gnupg.org
++Version: @VERSION@
++Libs: -L${libdir} @LIBGCRYPT_CONFIG_LIBS@
++Libs.private: @GPG_ERROR_LIBS@
++Cflags: -I${includedir} @LIBGCRYPT_CONFIG_CFLAGS@ @GPG_ERROR_CFLAGS@
+diff -Nur libgcrypt-1.2.4/src/Makefile.am libgcrypt11-1.2.4/src/Makefile.am
+--- libgcrypt-1.2.4/src/Makefile.am 2006-11-30 16:38:18.000000000 +0100
++++ libgcrypt11-1.2.4/src/Makefile.am 2007-02-11 13:10:03.000000000 +0100
+@@ -27,6 +27,11 @@
+ 
+ lib_LTLIBRARIES = libgcrypt.la
+ 
++# Pkg-config script.
++pkgconfigdir = $(libdir)/pkgconfig
++pkgconfig_DATA = libgcrypt.pc
++DISTCLEANFILES = $(pkgconfig_DATA)
++
+ if HAVE_LD_VERSION_SCRIPT
+   libgcrypt_version_script_cmd = -Wl,--version-script=$(srcdir)/libgcrypt.vers
+ else 
diff --git a/meta/packages/libgcrypt/libgcrypt.inc b/meta/packages/libgcrypt/libgcrypt.inc
new file mode 100644
index 000000000..74205da67
--- /dev/null
+++ b/meta/packages/libgcrypt/libgcrypt.inc
@@ -0,0 +1,22 @@
+DESCRIPTION = "A general purpose cryptographic library based on the code from GnuPG"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL LGPL FDL"
+DEPENDS = "libgpg-error"
+PR = "r1"
+
+# move libgcrypt-config into -dev package
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${bindir}"
+
+SRC_URI = "ftp://ftp.gnupg.org/gcrypt/libgcrypt/libgcrypt-${PV}.tar.gz"
+
+inherit autotools binconfig
+
+EXTRA_OECONF = "--without-pth --disable-asm --with-capabilities"
+
+ARM_INSTRUCTION_SET = "arm"
+
+do_stage() {
+	autotools_stage_all
+}
diff --git a/meta/packages/libgcrypt/libgcrypt_1.2.3.bb b/meta/packages/libgcrypt/libgcrypt_1.2.3.bb
deleted file mode 100644
index 74205da67..000000000
--- a/meta/packages/libgcrypt/libgcrypt_1.2.3.bb
+++ /dev/null
@@ -1,22 +0,0 @@
-DESCRIPTION = "A general purpose cryptographic library based on the code from GnuPG"
-SECTION = "libs"
-PRIORITY = "optional"
-LICENSE = "GPL LGPL FDL"
-DEPENDS = "libgpg-error"
-PR = "r1"
-
-# move libgcrypt-config into -dev package
-FILES_${PN} = "${libdir}/lib*.so.*"
-FILES_${PN}-dev += "${bindir}"
-
-SRC_URI = "ftp://ftp.gnupg.org/gcrypt/libgcrypt/libgcrypt-${PV}.tar.gz"
-
-inherit autotools binconfig
-
-EXTRA_OECONF = "--without-pth --disable-asm --with-capabilities"
-
-ARM_INSTRUCTION_SET = "arm"
-
-do_stage() {
-	autotools_stage_all
-}
diff --git a/meta/packages/libgcrypt/libgcrypt_1.2.4.bb b/meta/packages/libgcrypt/libgcrypt_1.2.4.bb
new file mode 100644
index 000000000..2fe98d62e
--- /dev/null
+++ b/meta/packages/libgcrypt/libgcrypt_1.2.4.bb
@@ -0,0 +1,3 @@
+require libgcrypt.inc
+
+PR = "r2"
-- 
cgit v1.2.3