From cecd1bdf6f2680960909d1f0535d1606d04938c1 Mon Sep 17 00:00:00 2001
From: Yu Ke <ke.yu@intel.com>
Date: Sat, 9 Oct 2010 09:47:52 +0800
Subject: qemugl: remove obsolate /usr/X11R6/lib lib directory

qemugl makefile has "-L/usr/X11R6/lib" to specifiy the X lib dir.
it is actually obsolate in poky now, because poky use Xserver from
X.org (X11R7.x), and its libs are in standard /usr/lib.

Meanwhile,the -L/usr/X11R6/lib will cause warning: library search path
"/usr/X11R6/lib" is unsafe for cross-compilation. so better to remove it.

Fix [BUGID #386]

Signed-off-by: Yu Ke <ke.yu@intel.com>
---
 .../mesa/qemugl/remove-x11r6-lib-dir.patch            | 19 +++++++++++++++++++
 meta/recipes-graphics/mesa/qemugl_git.bb              |  5 +++--
 2 files changed, 22 insertions(+), 2 deletions(-)
 create mode 100644 meta/recipes-graphics/mesa/qemugl/remove-x11r6-lib-dir.patch

(limited to 'meta')

diff --git a/meta/recipes-graphics/mesa/qemugl/remove-x11r6-lib-dir.patch b/meta/recipes-graphics/mesa/qemugl/remove-x11r6-lib-dir.patch
new file mode 100644
index 000000000..d14ce891c
--- /dev/null
+++ b/meta/recipes-graphics/mesa/qemugl/remove-x11r6-lib-dir.patch
@@ -0,0 +1,19 @@
+Remove X11R6 lib directory
+
+"-L/usr/X11R6/lib" is obsolate in poky. Poky currently use Xserver from X.org (X11R7.x), which puts lib in standard /usr/lib, so no need to specify the extra -L/usr/X11R6/lib. Meanwhile, the -L/usr/X11R6/lib will cause warning: library search path "/usr/X11R6/lib" is unsafe for cross-compilation. so better to remove it.
+
+Signed-off-by: Yu Ke <ke.yu@intel.com>
+
+diff --git a/Makefile b/Makefile
+index 9e5a8ea..f3a082a 100644
+--- a/Makefile
++++ b/Makefile
+@@ -3,7 +3,7 @@ GL_CFLAGS := -Wall -g -O2 -fno-strict-aliasing
+ all: libGL.so.1.2
+ 
+ libGL.so.1.2: client_stub.c opengl_client.c glgetv_cst.h opengl_func.h opengl_utils.h opengl_client_xfonts.c mesa_gl.h mesa_glext.h mesa_glx.h mesa_glxext.h
+-	$(CC) -fPIC $(GL_CFLAGS) opengl_client.c -shared -o libGL.so.1.2 -lX11 -lXfixes -lm -L$(D)/usr/X11R6/lib -lpthread -I.
++	$(CC) -fPIC $(GL_CFLAGS) opengl_client.c -shared -o libGL.so.1.2 -lX11 -lXfixes -lm -lpthread -I.
+ 
+ opengl_func.h: gl_func.h
+ 
diff --git a/meta/recipes-graphics/mesa/qemugl_git.bb b/meta/recipes-graphics/mesa/qemugl_git.bb
index 184c78272..8f8929117 100644
--- a/meta/recipes-graphics/mesa/qemugl_git.bb
+++ b/meta/recipes-graphics/mesa/qemugl_git.bb
@@ -8,11 +8,12 @@ DEPENDS = "virtual/libx11 xproto glproto libxfixes"
 COMPATIBLE_HOST = '(x86_64.*|i.86.*)-(linux|freebsd.*)'
 
 SRC_URI = "git://git.o-hand.com/qemugl.git;protocol=git \
-           file://versionfix.patch"
+           file://versionfix.patch \
+           file://remove-x11r6-lib-dir.patch"
 S = "${WORKDIR}/git"
 
 PV = "0.0+git${SRCPV}"
-PR = "r6"
+PR = "r7"
 
 DEFAULT_PREFERENCE = "-1"
 
-- 
cgit v1.2.3