From a1c255607188f539ed4bb5e3d98ba965c819201c Mon Sep 17 00:00:00 2001
From: Richard Purdie <richard@openedhand.com>
Date: Mon, 22 May 2006 22:15:25 +0000
Subject: avahi: upgrade 0.6.3 -> 0.6.10 (and fix the postinst to run on
 device)

git-svn-id: https://svn.o-hand.com/repos/poky/trunk@406 311d38ba-8fff-0310-9ca6-ca027cbcb966
---
 openembedded/packages/avahi/avahi_0.6.10.bb | 58 +++++++++++++++++++++++++++++
 openembedded/packages/avahi/avahi_0.6.3.bb  | 52 --------------------------
 2 files changed, 58 insertions(+), 52 deletions(-)
 create mode 100644 openembedded/packages/avahi/avahi_0.6.10.bb
 delete mode 100644 openembedded/packages/avahi/avahi_0.6.3.bb

(limited to 'openembedded')

diff --git a/openembedded/packages/avahi/avahi_0.6.10.bb b/openembedded/packages/avahi/avahi_0.6.10.bb
new file mode 100644
index 000000000..2b12d91c8
--- /dev/null
+++ b/openembedded/packages/avahi/avahi_0.6.10.bb
@@ -0,0 +1,58 @@
+DESCRIPTION = "Avahi implements the DNS-SD over Multicast DNS"
+SECTION = "network"
+PRIORITY = "optional"
+AUTHOR = "Lennart Poettering <lennart@poettering.net>"
+HOMEPAGE = "http://avahi.org"
+MAINTAINER = "Philipp Zabel <philipp.zabel@gmail.com>"
+LICENSE= "GPL"
+
+DEPENDS = "expat libdaemon dbus"
+RRECOMMENDS = "libnss-mdns"
+
+SRC_URI = "http://avahi.org/download/avahi-${PV}.tar.gz"
+
+PACKAGES = "avahi-daemon libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib avahi-dev avahi-doc avahi-utils"
+
+FILES_libavahi-common = "${libdir}/libavahi-common.so.*"
+FILES_libavahi-core= "${libdir}/libavahi-core.so.*"
+FILES_avahi-daemon = "${sbindir}/avahi-daemon \
+		      ${sysconfdir}/avahi/avahi-daemon.conf \
+		      ${sysconfdir}/avahi/hosts \
+		      ${sysconfdir}/avahi/services \
+		      ${sysconfdir}/dbus-1 \
+		      ${sysconfdir}/init.d/avahi-daemon \
+		      ${datadir}/avahi/introspection/*.introspect \
+		      ${datadir}/avahi/avahi-service.dtd \
+		      ${datadir}/avahi/service-types"
+FILES_libavahi-client = "${libdir}/libavahi-client.so.*"
+FILES_avahi-dnsconfd = "${sbindir}/avahi-dnsconfd \
+			${sysconfdir}/avahi/avahi-dnsconfd.action \
+			${sysconfdir}/init.d/avahi-dnsconfd"
+FILES_libavahi-glib = "${libdir}/libavahi-glib.so.*"
+FILES_avahi-utils = "${bindir}/avahi-*"
+
+CONFFILES_avahi-daemon = "${sysconfdir}/avahi/avahi-daemon.conf"
+
+EXTRA_OECONF = "--with-distro=debian --disable-gdbm --disable-gtk --disable-mono --disable-monodoc --disable-qt3 --disable-qt4 --disable-python"
+inherit autotools pkgconfig update-rc.d
+
+INITSCRIPT_PACKAGES = "avahi-daemon avahi-dnsconfd"
+INITSCRIPT_NAME_avahi-daemon = "avahi-daemon"
+INITSCRIPT_PARAMS_avahi-daemon = "defaults 21 19"
+INITSCRIPT_NAME_avahi-dnsconfd = "avahi-dnsconfd"
+INITSCRIPT_PARAMS_avahi-dnsconfd = "defaults 22 19"
+
+pkg_postinst_avahi-daemon () {
+	if [ "x$D" != "x" ]; then
+		exit 1
+	fi
+
+	grep avahi /etc/group || addgroup avahi
+	grep avahi /etc/passwd || adduser --disabled-password --system --home /var/run/avahi-daemon --no-create-home avahi --ingroup avahi -g Avahi
+	/etc/init.d/dbus-1 force-reload
+}
+
+pkg_postrm_avahi-daemon () {
+	deluser avahi || true
+	delgroup avahi || true
+}
diff --git a/openembedded/packages/avahi/avahi_0.6.3.bb b/openembedded/packages/avahi/avahi_0.6.3.bb
deleted file mode 100644
index 3253b1197..000000000
--- a/openembedded/packages/avahi/avahi_0.6.3.bb
+++ /dev/null
@@ -1,52 +0,0 @@
-DESCRIPTION = "Avahi implements the DNS-SD over Multicast DNS"
-HOMEPAGE = "http://avahi.org"
-LICENSE= "GPL"
-DEPENDS = "expat libdaemon dbus"
-RRECOMMENDS = "libnss-mdns"
-SECTION = "net"
-PRIORITY = "optional"
-PR = "r0"
-
-SRC_URI = "http://avahi.org/download/avahi-${PV}.tar.gz"
-
-PACKAGES = "avahi-daemon libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib avahi-dev avahi-doc avahi-utils"
-
-FILES_libavahi-common = "${libdir}/libavahi-common.so.*"
-FILES_libavahi-core= "${libdir}/libavahi-core.so.*"
-FILES_avahi-daemon = "${sbindir}/avahi-daemon \
-		      ${sysconfdir}/avahi/avahi-daemon.conf \
-		      ${sysconfdir}/avahi/services \
-		      ${sysconfdir}/dbus-1 \
-		      ${sysconfdir}/init.d/avahi-daemon \
-		      ${datadir}/avahi/introspection/*.introspect \
-		      ${datadir}/avahi/avahi-service.dtd \
-		      ${datadir}/avahi/service-types"
-FILES_libavahi-client = "${libdir}/libavahi-client.so.*"
-FILES_avahi-dnsconfd = "${sbindir}/avahi-dnsconfd \
-			${sysconfdir}/avahi/avahi-dnsconfd.action \
-			${sysconfdir}/init.d/avahi-dnsconfd"
-FILES_libavahi-glib = "${libdir}/libavahi-glib.so.*"
-FILES_avahi-utils = "${bindir}/avahi-*"
-
-CONFFILES_avahi-daemon = "${sysconfdir}/avahi/avahi-daemon.conf"
-
-EXTRA_OECONF = "--with-distro=debian --disable-gdbm --disable-gtk --disable-mono --disable-monodoc --disable-qt3 --disable-qt4 --disable-python"
-inherit autotools
-inherit update-rc.d
-
-INITSCRIPT_PACKAGES = "avahi-daemon avahi-dnsconfd"
-INITSCRIPT_NAME_avahi-daemon = "avahi-daemon"
-INITSCRIPT_PARAMS_avahi-daemon = "defaults 21 19"
-INITSCRIPT_NAME_avahi-dnsconfd = "avahi-dnsconfd"
-INITSCRIPT_PARAMS_avahi-dnsconfd = "defaults 22 19"
-
-pkg_postinst_avahi-daemon () {
-	grep avahi /etc/group || addgroup avahi
-	grep avahi /etc/passwd || adduser --disabled-password --system --home /var/run/avahi-daemon --no-create-home avahi --ingroup avahi -g Avahi
-	/etc/init.d/dbus-1 force-reload
-}
-
-pkg_postrm_avahi-daemon () {
-	deluser avahi || true
-	delgroup avahi || true
-}
-- 
cgit v1.2.3