SRC_DISTRIBUTECOMMAND[func] = "1"
python do_distribute_sources () {
	l = bb.data.createCopy(d)
	bb.data.update_data(l)
	licenses = (bb.data.getVar('LICENSE', d, 1) or "unknown").split()

	sources_dir = bb.data.getVar('SRC_DISTRIBUTEDIR', d, 1)
	import re
	for license in licenses:
		for entry in license.split("|"):
			for s in (bb.data.getVar('A', d, 1) or "").split():
				s = re.sub(';.*$', '', s)
				cmd = bb.data.getVar('SRC_DISTRIBUTECOMMAND', d, 1)
				if not cmd:
					raise bb.build.FuncFailed("Unable to distribute sources, SRC_DISTRIBUTECOMMAND not defined")
				bb.data.setVar('SRC', s, d)
				bb.data.setVar('SRC_DISTRIBUTEDIR', "%s/%s" % (sources_dir, entry), d)
				bb.build.exec_func('SRC_DISTRIBUTECOMMAND', d)
}

addtask distribute_sources before do_build after do_fetch

addtask distsrcall after do_distribute_sources
do_distall[recrdeptask] = "do_distribute_sources"
base_do_distsrcall() {
	:
}

</script>
<div id='cgit'><table id='header'>
<tr>
<td class='logo' rowspan='2'><a href='/git/'><img src='/git/cgit.png' alt='cgit logo'/></a></td>
<td class='main'><a href='/git/'>index</a> : <a href='/git/junk/openocd_libswd.git/'>openocd_libswd.git</a></td><td class='form'><form method='get'>
<input type='hidden' name='id' value='aaf1daa056103f711a7498914b9b5b76cb64c1b3'/><select name='h' onchange='this.form.submit();'>
<option value='master' selected='selected'>master</option>
</select> <input type='submit' value='switch'/></form></td></tr>
<tr><td class='sub'>Unnamed repository; edit this file 'description' to name the repository.</td><td class='sub right'>Trygve Laugstøl</td></tr></table>
<table class='tabs'><tr><td>
<a href='/git/junk/openocd_libswd.git/'>summary</a><a href='/git/junk/openocd_libswd.git/refs/?id=aaf1daa056103f711a7498914b9b5b76cb64c1b3'>refs</a><a href='/git/junk/openocd_libswd.git/log/tcl/target/at91sam3uXX.cfg'>log</a><a class='active' href='/git/junk/openocd_libswd.git/tree/tcl/target/at91sam3uXX.cfg?id=aaf1daa056103f711a7498914b9b5b76cb64c1b3'>tree</a><a href='/git/junk/openocd_libswd.git/commit/tcl/target/at91sam3uXX.cfg?id=aaf1daa056103f711a7498914b9b5b76cb64c1b3'>commit</a><a href='/git/junk/openocd_libswd.git/diff/tcl/target/at91sam3uXX.cfg?id=aaf1daa056103f711a7498914b9b5b76cb64c1b3'>diff</a></td><td class='form'><form class='right' method='get' action='/git/junk/openocd_libswd.git/log/tcl/target/at91sam3uXX.cfg'>
<input type='hidden' name='id' value='aaf1daa056103f711a7498914b9b5b76cb64c1b3'/><select name='qt'>
<option value='grep'>log msg</option>
<option value='author'>author</option>
<option value='committer'>committer</option>
<option value='range'>range</option>
</select>
<input class='txt' type='search' size='10' name='q' value=''/>
<input type='submit' value='search'/>
</form>
</td></tr></table>
<div class='path'>path: <a href='/git/junk/openocd_libswd.git/tree/?id=aaf1daa056103f711a7498914b9b5b76cb64c1b3'>root</a>/<a href='/git/junk/openocd_libswd.git/tree/tcl?id=aaf1daa056103f711a7498914b9b5b76cb64c1b3'>tcl</a>/<a href='/git/junk/openocd_libswd.git/tree/tcl/target?id=aaf1daa056103f711a7498914b9b5b76cb64c1b3'>target</a>/<a href='/git/junk/openocd_libswd.git/tree/tcl/target/at91sam3uXX.cfg?id=aaf1daa056103f711a7498914b9b5b76cb64c1b3'>at91sam3uXX.cfg</a></div><div class='content'>blob: d54d3a4daa0232cd04cec0ea409c25a5bf632a44 (<a href='/git/junk/openocd_libswd.git/plain/tcl/target/at91sam3uXX.cfg?id=aaf1daa056103f711a7498914b9b5b76cb64c1b3'>plain</a>)
<table summary='blob content' class='blob'>
<tr><td class='linenumbers'><pre><a id='n1' href='#n1'>1</a>
<a id='n2' href='#n2'>2</a>
<a id='n3' href='#n3'>3</a>
<a id='n4' href='#n4'>4</a>
<a id='n5' href='#n5'>5</a>
<a id='n6' href='#n6'>6</a>
<a id='n7' href='#n7'>7</a>
<a id='n8' href='#n8'>8</a>
<a id='n9' href='#n9'>9</a>
<a id='n10' href='#n10'>10</a>
<a id='n11' href='#n11'>11</a>
<a id='n12' href='#n12'>12</a>
<a id='n13' href='#n13'>13</a>
<a id='n14' href='#n14'>14</a>
<a id='n15' href='#n15'>15</a>
<a id='n16' href='#n16'>16</a>
<a id='n17' href='#n17'>17</a>
<a id='n18' href='#n18'>18</a>
<a id='n19' href='#n19'>19</a>
<a id='n20' href='#n20'>20</a>
<a id='n21' href='#n21'>21</a>
<a id='n22' href='#n22'>22</a>
<a id='n23' href='#n23'>23</a>
<a id='n24' href='#n24'>24</a>
<a id='n25' href='#n25'>25</a>
<a id='n26' href='#n26'>26</a>
<a id='n27' href='#n27'>27</a>
<a id='n28' href='#n28'>28</a>
<a id='n29' href='#n29'>29</a>
<a id='n30' href='#n30'>30</a>
<a id='n31' href='#n31'>31</a>
<a id='n32' href='#n32'>32</a>
<a id='n33' href='#n33'>33</a>
<a id='n34' href='#n34'>34</a>
<a id='n35' href='#n35'>35</a>
<a id='n36' href='#n36'>36</a>
<a id='n37' href='#n37'>37</a>
<a id='n38' href='#n38'>38</a>
<a id='n39' href='#n39'>39</a>
<a id='n40' href='#n40'>40</a>
<a id='n41' href='#n41'>41</a>
<a id='n42' href='#n42'>42</a>
</pre></td>
<td class='lines'><pre><code>