aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8a43b50..e23e674 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,7 +11,9 @@ add_definitions(-DBOOST_ALL_DYN_LINK)
find_package(Boost REQUIRED COMPONENTS system log thread)
-set(SOURCE_FILES main.cpp Bluetooth.cpp LinuxBluetooth.cpp)
+set(SOURCE_FILES "${SOURCE_FILES}" main.cpp Bluetooth.cpp LinuxBluetooth.cpp)
+set(SOURCE_FILES "${SOURCE_FILES}" ByteBuffer.cpp)
+
add_executable(ble_toys ${SOURCE_FILES})
target_link_libraries(ble_toys bluetooth)