aboutsummaryrefslogtreecommitdiff
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt19
1 files changed, 11 insertions, 8 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index 58048ff..2cb3286 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -1,11 +1,14 @@
-cmake_minimum_required(VERSION 3.5)
-project(kicad_utils_examples)
+# If we're not included by the msgflo project, find the sources the normal way. This is what you should do in your
+# application
+if (CMAKE_CURRENT_SOURCE_DIR STREQUAL CMAKE_SOURCE_DIR)
+ cmake_minimum_required(VERSION 3.5)
+ project(kicad_utils_examples)
-find_package(KicadUtils QUIET)
-
-if (NOT KicadUtils_FOUND)
- message(FATAL_ERROR "The KicadUtils CMake package was not found. Did you pass the correct value for KicadUtils_DIR?\nIt should probably be something like KicadUtils_DIR=$HOME/opt/kicad-utils/lib/cmake/KicadUtils")
+ find_package(KicadUtils)
+ if (NOT KicadUtils_FOUND)
+ message(FATAL_ERROR "The KicadUtils CMake package was not found. Did you pass the correct value for KicadUtils_DIR?\nIt should probably be something like KicadUtils_DIR=$HOME/opt/kicad-utils/lib/cmake/KicadUtils")
+ endif ()
endif ()
-add_subdirectory(arduino-led)
-add_subdirectory(intel-quark-d2000)
+#add_subdirectory(arduino-led)
+#add_subdirectory(intel-quark-d2000)