aboutsummaryrefslogtreecommitdiff
path: root/examples/intel-quark-d2000/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/intel-quark-d2000/CMakeLists.txt')
-rw-r--r--examples/intel-quark-d2000/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/examples/intel-quark-d2000/CMakeLists.txt b/examples/intel-quark-d2000/CMakeLists.txt
index 1822996..3920d4b 100644
--- a/examples/intel-quark-d2000/CMakeLists.txt
+++ b/examples/intel-quark-d2000/CMakeLists.txt
@@ -1,8 +1,11 @@
+find_package(KicadUtils)
+
kicad_generate_header(
OUTPUT schematic.h
NET schematic/intel-quark-d2000.net
REF U1
- IN_SOURCE)
+ TEMPLATE intel-quark-d2000.py
+ TEMPLATE_LIB_LIST .)
if (FALSE)
# If you have Intel Quark support for CMake something like this would work:
@@ -10,5 +13,5 @@ if (FALSE)
#add_executable(arduino-led arduino-led.ino schematic.h)
#target_include_directories(arduino-led PUBLIC ${CMAKE_CURRENT_BINARY_DIR}/kicad-include)
else ()
- add_custom_target(intel-quark-d2000 ALL DEPENDS schematic.h)
+ add_custom_target(intel-quark-d2000 ALL DEPENDS schematic.h schematic-py.h)
endif ()