summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTrygve Laugstøl <trygvis@inamo.no>2017-05-11 11:36:52 +0200
committerTrygve Laugstøl <trygvis@inamo.no>2017-05-11 11:36:52 +0200
commit8665bdbf682bdff02576a6f4393f09bc56572043 (patch)
tree54b1f51c0b3e5f5dd577720a9cd54e28be19d97f /CMakeLists.txt
parenteabbd037f5f605a9ecf06185cd62594eb4564bce (diff)
downloadradio-controller-8665bdbf682bdff02576a6f4393f09bc56572043.tar.gz
radio-controller-8665bdbf682bdff02576a6f4393f09bc56572043.tar.bz2
radio-controller-8665bdbf682bdff02576a6f4393f09bc56572043.tar.xz
radio-controller-8665bdbf682bdff02576a6f4393f09bc56572043.zip
wip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4097d5a..2826974 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,8 +7,9 @@ project(radio-controller C CXX ASM)
set(CMAKE_CXX_STANDARD 14)
-add_executable(firmware src/radio-controller.cpp)
+add_executable(firmware src/radio-controller.cpp include/radio-controller.h)
target_compile_definitions(firmware PUBLIC MCUCMAKE_USING_STM32CUBEMX=1)
+target_include_directories(firmware PUBLIC include)
target_link_libraries(firmware PUBLIC gcc)
mcu_add_executable(TARGET firmware)
@@ -34,7 +35,7 @@ target_include_directories(firmware PUBLIC
)
target_sources(firmware PUBLIC
thirdparty/mcucpp/src/arm/semihosting.cpp
- thirdparty/mcucpp/src/arm/semihosting-putc.cpp
+ thirdparty/mcucpp/src/arm/semihosting-puts.cpp
thirdparty/mcucpp/src/arm/semihosting-putchar.cpp
thirdparty/mcucpp/src/generic/tinyprintf-printf.cpp
thirdparty/mcucpp/src/generic/tinyprintf-snprintf.cpp