aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py37
1 files changed, 25 insertions, 12 deletions
diff --git a/setup.py b/setup.py
index 1580612..0470b81 100644
--- a/setup.py
+++ b/setup.py
@@ -1,16 +1,29 @@
from distutils.core import setup
-from glob import glob
-from os.path import basename
-from os.path import dirname
-from os.path import join
-from os.path import splitext
+
from setuptools import find_packages
setup(name='ee',
- version='1.0',
- packages=find_packages('src'),
- package_dir={'': 'src'},
- entry_points = {
- 'console_scripts': ['ee=ee.__main__:main'],
- },
- )
+ version='1.0',
+ packages=find_packages('src'),
+ package_dir={'': 'src'},
+ entry_points={
+ 'console_scripts': ['ee=ee.__main__:main'],
+ },
+ install_requires=[
+ 'ansicolors',
+ 'cachecontrol',
+ 'lockfile',
+ 'lxml',
+ 'matplotlib',
+ 'mpmath',
+ 'mypy',
+ 'numpy',
+ 'pandas',
+ 'parsec',
+ 'Pillow',
+ 'pytest',
+ 'pyyaml',
+ 'requests',
+ 'sympy',
+ ],
+ )