summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorZachary T Welch <zw@superlucidity.net>2009-11-17 06:54:56 -0800
committerZachary T Welch <zw@superlucidity.net>2009-11-17 11:42:48 -0800
commit0091e59d2a18c293fd952a9d707e609afdd6b17f (patch)
tree094899126558e846013a46379920af51a1a55313 /Makefile.am
parent94975c96d4f1f614e0877cac32ed5949cd0235f6 (diff)
downloadopenocd+libswd-0091e59d2a18c293fd952a9d707e609afdd6b17f.tar.gz
openocd+libswd-0091e59d2a18c293fd952a9d707e609afdd6b17f.tar.bz2
openocd+libswd-0091e59d2a18c293fd952a9d707e609afdd6b17f.tar.xz
openocd+libswd-0091e59d2a18c293fd952a9d707e609afdd6b17f.zip
allow documentation to be configured
Add --disable-doxygen-html and --enable-doxygen-pdf options to the configure script, allowing user to change the defaults. These update the proess of munging the Doxygen configuration file to use the settings thusly provided. Add options in README.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index be42c283..c0677120 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,7 +25,9 @@ Doxyfile: $(srcdir)/Doxyfile.in
@( \
echo "### @@@ -= DO NOT EDIT THIS FILE =- @@@ ###" && \
echo "### @@@ Make changes to Doxyfile.in @@@ ###" && \
- sed -e 's,@srcdir\@,$(srcdir),' $< \
+ sed -e 's,@srcdir\@,$(srcdir),' \
+ -e 's,@doxygen_as_html\@,$(doxygen_as_html),' \
+ -e 's,@doxygen_as_pdf\@,$(doxygen_as_pdf),' $< \
) > $@
THE_MANUAL = doxygen/latex/refman.pdf