summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorzwelch <zwelch@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-05-27 06:44:43 +0000
committerzwelch <zwelch@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-05-27 06:44:43 +0000
commit140d6c8e7948710a764965075bfaa700efd09802 (patch)
treeccb281820c12961eb036d2a00040164d114ad057 /Makefile.am
parent7c0e823d0a57df99adc5b1b7975406bfd9e0d9fb (diff)
downloadopenocd+libswd-140d6c8e7948710a764965075bfaa700efd09802.tar.gz
openocd+libswd-140d6c8e7948710a764965075bfaa700efd09802.tar.bz2
openocd+libswd-140d6c8e7948710a764965075bfaa700efd09802.tar.xz
openocd+libswd-140d6c8e7948710a764965075bfaa700efd09802.zip
Move TCL script files -- Step 1 of 2:
- Move src/target/{interface,target,board,test}/ into src/tcl/ - Remove existing rules in src/Makefile.am and src/target/Makefile.am. - Add Makefile.am handling of *.cfg and *.tcl files in top Makefile.am: - Add dist-hook to include such files under src/tcl in the distribution. - Add install-data-hook to install contents of '$(top_srcdir)/src/tcl/'. - Add uninstall-hook to remove the installed script files. - Change paths to (un)install script files in '$(pkgdatadir)/scripts'. git-svn-id: svn://svn.berlios.de/openocd/trunk@1918 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c14c81f6..431244b3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -29,6 +29,29 @@ doxygen::
$(MAKE) Doxyfile
doxygen Doxyfile 2>&1 | perl $(srcdir)/tools/logger.pl > doxygen.log
+TCL_PATH = src/tcl
+# command to find paths of script files, relative to TCL_PATH
+TCL_FILES := find $(srcdir)/$(TCL_PATH) -name '*.cfg' -o -name '*.tcl' | \
+ sed -e 's,^$(srcdir)/$(TCL_PATH),,'
+
+dist-hook:
+ for i in $$($(TCL_FILES)); do \
+ j="$(distdir)/$(TCL_PATH)/$$i" && \
+ mkdir -p "$$(dirname $$j)" && \
+ $(INSTALL_DATA) $(srcdir)/$(TCL_PATH)/$$i $$j; \
+ done
+
+install-data-hook:
+ for i in $$($(TCL_FILES)); do \
+ j="$(DESTDIR)$(pkgdatadir)/scripts/$$i" && \
+ mkdir -p "$$(dirname $$j)" && \
+ $(INSTALL_DATA) $(srcdir)/$(TCL_PATH)/$$i $$j; \
+ done
+
+uninstall-hook:
+ rm -rf $(DESTDIR)$(pkgdatadir)/scripts
+
+
distclean-local:
rm -rf Doxyfile doxygen