summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorZachary T Welch <zw@superlucidity.net>2009-11-17 06:04:03 -0800
committerZachary T Welch <zw@superlucidity.net>2009-11-17 11:42:48 -0800
commit94975c96d4f1f614e0877cac32ed5949cd0235f6 (patch)
tree476d304920c952e61322d4812dece57c4b4a5477 /Makefile.am
parent789d47c18097abb5ee6cc8544e0ba030000fd418 (diff)
downloadopenocd+libswd-94975c96d4f1f614e0877cac32ed5949cd0235f6.tar.gz
openocd+libswd-94975c96d4f1f614e0877cac32ed5949cd0235f6.tar.bz2
openocd+libswd-94975c96d4f1f614e0877cac32ed5949cd0235f6.tar.xz
openocd+libswd-94975c96d4f1f614e0877cac32ed5949cd0235f6.zip
update doxygen configuration to produce a PDF
A single PDF file for the developer manual allows accessing a single index, browsing, and searching. It takes significantly more time to build this way, but this patch allows others to look at the results. Migration Tip: If you have previously built the HTML Doxygen documentatation, rename your 'doxygen' directory to 'doxygen/html' to prevent needlessly rebuilding those files.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index dc4166d1..be42c283 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -28,9 +28,16 @@ Doxyfile: $(srcdir)/Doxyfile.in
sed -e 's,@srcdir\@,$(srcdir),' $< \
) > $@
+THE_MANUAL = doxygen/latex/refman.pdf
+
doxygen::
$(MAKE) Doxyfile
doxygen Doxyfile 2>&1 | perl $(srcdir)/tools/logger.pl > doxygen.log
+ $(MAKE) $(THE_MANUAL)
+
+%.pdf: %.tex
+ -cd $$(dirname $*) && pdflatex $$(basename $*)
+ -cd $$(dirname $*) && pdflatex $$(basename $*)
TCL_PATH = tcl
# command to find paths of script files, relative to TCL_PATH