summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorzwelch <zwelch@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-05-24 01:08:16 +0000
committerzwelch <zwelch@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-05-24 01:08:16 +0000
commita6f7ca1a3a6086a238207ff995de9767408b5c3f (patch)
treee7792e34a6c3700c675d56fd5eea1570de95efdc /Makefile.am
parent8717ed04aaa465dcd6ae722b120b2cd4fdc4c8b4 (diff)
downloadopenocd+libswd-a6f7ca1a3a6086a238207ff995de9767408b5c3f.tar.gz
openocd+libswd-a6f7ca1a3a6086a238207ff995de9767408b5c3f.tar.bz2
openocd+libswd-a6f7ca1a3a6086a238207ff995de9767408b5c3f.tar.xz
openocd+libswd-a6f7ca1a3a6086a238207ff995de9767408b5c3f.zip
Properly fix doxygen out-of-tree build process:
- move Doxyfile to Doxyfile.in: type 'make Doxyfile' to recreate it - create Doxyfile from Doxyfile.in with make rule: - use sed substitution of $(srcdir) to location directories - delete all doxygen created files with 'make distclean' - include all required files (including logger.pl) in distribution git-svn-id: svn://svn.berlios.de/openocd/trunk@1901 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 12 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index cb5277b7..10735f34 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,15 +11,23 @@ nobase_dist_pkgdata_DATA = \
SUBDIRS = src doc
-EXTRA_DIST = Doxyfile
+EXTRA_DIST = \
+ Doxyfile.in \
+ tools/logger.pl
docs: pdf html doxygen
+Doxyfile: $(srcdir)/Doxyfile.in
+ sed -e 's,@srcdir\@,$(srcdir),' $< > $@
+
doxygen::
- (cd $(srcdir) && doxygen Doxyfile 2>&1 | perl tools/logger.pl ) > doxygen.log
+ $(MAKE) Doxyfile
+ doxygen Doxyfile 2>&1 | perl $(srcdir)/tools/logger.pl > doxygen.log
+
+distclean-local:
+ rm -rf Doxyfile doxygen
-doxygen-clean:
- rm -f -r doxygen doxygen.log
+DISTCLEANFILES = doxygen.log
MAINTAINERCLEANFILES = \
configure \