summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoroharboe <oharboe@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-06-08 14:13:32 +0000
committeroharboe <oharboe@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-06-08 14:13:32 +0000
commit3245a0cd5fdfcf27cc08a173e5c29abfd66882ee (patch)
tree4a8c46751f77318b862a2e7c8945bb468173d108 /configure.in
parent76d9c3d5b8ef774b9ae60eb27a653c18691b8c0d (diff)
downloadopenocd+libswd-3245a0cd5fdfcf27cc08a173e5c29abfd66882ee.tar.gz
openocd+libswd-3245a0cd5fdfcf27cc08a173e5c29abfd66882ee.tar.bz2
openocd+libswd-3245a0cd5fdfcf27cc08a173e5c29abfd66882ee.tar.xz
openocd+libswd-3245a0cd5fdfcf27cc08a173e5c29abfd66882ee.zip
update zy1000 to latest minidriver work
git-svn-id: svn://svn.berlios.de/openocd/trunk@2132 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 5 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 7ab9db3d..56e431d9 100644
--- a/configure.in
+++ b/configure.in
@@ -400,13 +400,12 @@ AC_ARG_ENABLE(minidriver_dummy,
build_minidriver=no
AC_MSG_CHECKING([whether to enable ZY1000 minidriver])
if test $build_ecosboard = yes; then
- # check for that project's header file in the current header search path
- AC_CHECK_HEADERS(jtag_minidriver.h, [build_minidriver=yes],
- AC_MSG_WARN([The --enable-ecosboard option needs the out-of-tree 'jtag_minidriver.h'])
- AC_MSG_ERROR([The out-of-tree jtag_minidriver.h cannot be found.])
- )
+ if test $build_minidriver = yes; then
+ AC_MSG_ERROR([Multiple minidriver options have been enabled.])
+ fi
+ AC_DEFINE(HAVE_JTAG_MINIDRIVER_H, 1,
+ [Define to 1 if you have the <jtag_minidriver.h> header file.])
build_minidriver=yes
- AC_DEFINE(BUILD_MINIDRIVER_DUMMY, 1, [Use the dummy minidriver.])
fi
AC_MSG_RESULT($build_ecosboard)