summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorZachary T Welch <zw@superlucidity.net>2009-11-19 12:02:07 -0800
committerZachary T Welch <zw@superlucidity.net>2009-11-24 07:30:19 -0800
commit3a660e229301c905392a0b2826e5ebf08c4e01b9 (patch)
treed8d14d934592a41c75f3996c745846b066001b7e /configure.in
parent3efc99b34a934cb4d657ec27a164769c46c10f28 (diff)
downloadopenocd+libswd-3a660e229301c905392a0b2826e5ebf08c4e01b9.tar.gz
openocd+libswd-3a660e229301c905392a0b2826e5ebf08c4e01b9.tar.bz2
openocd+libswd-3a660e229301c905392a0b2826e5ebf08c4e01b9.tar.xz
openocd+libswd-3a660e229301c905392a0b2826e5ebf08c4e01b9.zip
add jtag/usb_common.[ch] files
Begins to consolidate code used by several USB JTAG interfaces. This first patch provides the required build system changes and a common jtag_usb_open routine, which will replace the guts for probing the busses and devices for possible VID/PID matches. The following patches convert each driver to use it.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8ba89512..81e43262 100644
--- a/configure.in
+++ b/configure.in
@@ -996,6 +996,7 @@ if test $build_jlink = yes -o $build_vsllink = yes -o $build_usbprog = yes -o \
then
AC_CHECK_HEADERS([usb.h],[],
[AC_MSG_ERROR([usb.h is required to build some OpenOCD driver(s)])])
+ build_usb=yes
fi
AM_CONDITIONAL(RELEASE, test $build_release = yes)
@@ -1021,6 +1022,7 @@ AM_CONDITIONAL(JLINK, test $build_jlink = yes)
AM_CONDITIONAL(VSLLINK, test $build_vsllink = yes)
AM_CONDITIONAL(RLINK, test $build_rlink = yes)
AM_CONDITIONAL(ARMJTAGEW, test $build_armjtagew = yes)
+AM_CONDITIONAL(USB, test $build_usb = yes)
AM_CONDITIONAL(IS_CYGWIN, test $is_cygwin = yes)
AM_CONDITIONAL(IS_MINGW, test $is_mingw = yes)
AM_CONDITIONAL(IS_WIN32, test $is_win32 = yes)