summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorzwelch <zwelch@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-05-02 22:35:02 +0000
committerzwelch <zwelch@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-05-02 22:35:02 +0000
commit66add57aa5bae147b7996840a2287f3547b4b8ea (patch)
treefc0159ec326143d12a8afe3d7d8be059c51ca023 /configure.in
parent6cacbd9575e03c37057719a97bf260217c4e275f (diff)
downloadopenocd+libswd-66add57aa5bae147b7996840a2287f3547b4b8ea.tar.gz
openocd+libswd-66add57aa5bae147b7996840a2287f3547b4b8ea.tar.bz2
openocd+libswd-66add57aa5bae147b7996840a2287f3547b4b8ea.tar.xz
openocd+libswd-66add57aa5bae147b7996840a2287f3547b4b8ea.zip
Update autotools scripts to require automake 1.6. The configure.in script
already required autoconf 2.59 (circa 2006), so there is no reason to support versions of automake older than 1.6 (circa 2002). The first part of this patch upgrades the configure.in script: 1. Use current calling conventions for the AC_INIT and AM_INIT_AUTOMAKE macros, bringing their usage up-to-date with the version of autoconf already specified by AC_PREREQ. 2. Add AC_CONFIG_SRCDIR macro, required by new version of AC_INIT. 3. Automatically enable all of automake's warnings except Makefile portability (which OpenOCD violates by using GNU make's $(wildcard)). [[ While automake has its own -Werror option, I did not enabled it due to existing warnings. ]] 4. Add the missing AM_PROG_C_O check, required by the build rules for openocd.o in src/Makefile.am. 5. Adjust version number to show progress toward the next release. 6. Include a bug reporting e-mail address to direct users to this list. This patch makes the following adjustments to the Makefile.am files: 1. Update AUTOMAKE_OPTIONS to require automake version 1.6 2. Rewrite all deprecated INCLUDES assignments as AM_CPPFLAGS 3. Clean-up all AM_CPPFLAGS declarations to be patch-friendly. 4. Remove vestigial references to $(all_includes) 5. Remove erroneous references to @CPPFLAGS@ (only use AM_CPPFLAGS) 6. Remove unused -I and -D directives in helper/, flash/, target/ git-svn-id: svn://svn.berlios.de/openocd/trunk@1591 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 9eaeb7e4..9855da09 100644
--- a/configure.in
+++ b/configure.in
@@ -1,5 +1,7 @@
AC_PREREQ(2.59)
-AC_INIT(configure.in)
+AC_INIT([openocd], [0.2.0-in-development],
+ [OpenOCD Mailing List <openocd-development@lists.berlios.de>])
+AC_CONFIG_SRCDIR([src/openocd.c])
AC_CANONICAL_HOST
@@ -738,7 +740,7 @@ CFLAGS=$CFLAGS_SAVE
fi
AM_CONFIG_HEADER(config.h)
-AM_INIT_AUTOMAKE(openocd, 1.0)
+AM_INIT_AUTOMAKE([-Wall -Wno-portability])
AM_MAINTAINER_MODE
AM_CONDITIONAL(RELEASE, test $build_release = yes)
@@ -771,6 +773,7 @@ AM_CONDITIONAL(BITQ, test $build_bitq = yes)
AC_LANG_C
AC_PROG_CC
+AM_PROG_CC_C_O
AC_PROG_RANLIB
# set default gcc warnings