summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSpencer Oliver <ntfreak@users.sourceforge.net>2010-11-19 09:07:43 +0000
committerSpencer Oliver <ntfreak@users.sourceforge.net>2010-11-19 09:07:43 +0000
commit8c0c259ed64a7a182c82edfca9809cfe33cb96ce (patch)
treec1fbcfd009c2f118621fd66ff9ff4b35175e4673 /configure.in
parentd80fca527a6618595a118381a2cd2a569f85889f (diff)
downloadopenocd+libswd-8c0c259ed64a7a182c82edfca9809cfe33cb96ce.tar.gz
openocd+libswd-8c0c259ed64a7a182c82edfca9809cfe33cb96ce.tar.bz2
openocd+libswd-8c0c259ed64a7a182c82edfca9809cfe33cb96ce.tar.xz
openocd+libswd-8c0c259ed64a7a182c82edfca9809cfe33cb96ce.zip
build: prepend --with-jim-ext=nvp to jimtcl configure
This allows us to add options to jimtcl configure. The default autoconf AC_CONFIG_SUBDIRS does not currently support this. Signed-off-by: Spencer Oliver <ntfreak@users.sourceforge.net>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index c5e81a28..b030d9f8 100644
--- a/configure.in
+++ b/configure.in
@@ -4,6 +4,8 @@ AC_INIT([openocd], [0.5.0-dev],
AC_CONFIG_SRCDIR([src/openocd.c])
AC_CONFIG_AUX_DIR([.])
+m4_include(config_subdir.m4)dnl
+
AM_INIT_AUTOMAKE([-Wall -Wno-portability dist-bzip2 dist-zip])
AM_MAINTAINER_MODE
@@ -763,7 +765,7 @@ fi
if test "$use_internal_jimtcl" = yes; then
if test -f "$srcdir/jimtcl/configure.ac"; then
- AC_CONFIG_SUBDIRS([jimtcl])
+ AX_CONFIG_SUBDIR_OPTION(jimtcl, --with-jim-ext=nvp)
else
AC_MSG_ERROR([jimtcl not found, run git submodule init and git submodule update.])
fi