summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorzwelch <zwelch@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-05-03 03:35:01 +0000
committerzwelch <zwelch@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-05-03 03:35:01 +0000
commitcaf14c53db57b48303a8f5f3f001faaf0e117f9d (patch)
tree71c3639a3f9e82e7198150f9a8b22efc69ba778d /configure.in
parent85ecae2875d091e1d9bf541b0e7939cde10eb8cd (diff)
downloadopenocd+libswd-caf14c53db57b48303a8f5f3f001faaf0e117f9d.tar.gz
openocd+libswd-caf14c53db57b48303a8f5f3f001faaf0e117f9d.tar.bz2
openocd+libswd-caf14c53db57b48303a8f5f3f001faaf0e117f9d.tar.xz
openocd+libswd-caf14c53db57b48303a8f5f3f001faaf0e117f9d.zip
Fix build when enabling presto+ftd2xx driver only.
git-svn-id: svn://svn.berlios.de/openocd/trunk@1593 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index dc797750..3b1d49e4 100644
--- a/configure.in
+++ b/configure.in
@@ -537,7 +537,7 @@ then
AC_MSG_ERROR([The option: with_ftd2xx_linux_tardir is for LINUX only.])
fi
-if test $build_ft2232_ftd2xx = yes ; then
+if test $build_ft2232_ftd2xx = yes -o $build_presto_ftd2xx = yes ; then
AC_MSG_CHECKING([for ftd2xx.lib exists (win32)])
# if we are given a zipdir...
@@ -586,7 +586,7 @@ then
AC_MSG_ERROR([The option: with_ftd2xx_linux_tardir is for LINUX only.])
fi
-if test $build_ft2232_ftd2xx = yes ; then
+if test $build_ft2232_ftd2xx = yes -o $build_presto_ftd2xx = yes ; then
AC_MSG_CHECKING([for libftd2xx.a (darwin)])
if test ! -f /usr/local/include/ftd2xx.h ; then
@@ -607,7 +607,7 @@ then
AC_MSG_ERROR([The option: --with-ftd2xx-win32-zipdir is for win32 only])
fi
-if test $build_ft2232_ftd2xx = yes ; then
+if test $build_ft2232_ftd2xx = yes -o $build_presto_ftd2xx = yes ; then
# Must be linux
if test $host_os != linux-gnu && test $host_os != linux ; then
AC_MSG_ERROR([The (linux) ftd2xx library from FTDICHIP.com is linux only. Try --enable-ft2232-libftdi instead])
@@ -661,7 +661,7 @@ if test $build_ft2232_ftd2xx = yes ; then
fi
fi
-if test $build_ft2232_ftd2xx = yes; then
+if test $build_ft2232_ftd2xx = yes -o $build_presto_ftd2xx = yes; then
# Before we go any further - make sure we can *BUILD* and *RUN*
# a simple app with the "ftd2xx.lib" file - in what ever form we where given