summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorzwelch <zwelch@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-05-11 11:20:45 +0000
committerzwelch <zwelch@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-05-11 11:20:45 +0000
commitce23eb7e3aebbf03e1f1cab436f417d034395439 (patch)
treecb80e5b633b46f9103404a321eba0ef8a23db26f /configure.in
parente170938ae802b4e61cd87544bf81faf144d84f07 (diff)
downloadopenocd+libswd-ce23eb7e3aebbf03e1f1cab436f417d034395439.tar.gz
openocd+libswd-ce23eb7e3aebbf03e1f1cab436f417d034395439.tar.bz2
openocd+libswd-ce23eb7e3aebbf03e1f1cab436f417d034395439.tar.xz
openocd+libswd-ce23eb7e3aebbf03e1f1cab436f417d034395439.zip
Update jim helper files to use proper configure script support:
- configure.in: Add AC_TYPE_LONG_LONG_INT to detect 'long long int' support. - configure.in: Add AC_C_CONST to provide equivalent support as jim.h. - jim*.c: include config.h when HAVE_CONFIG_H is defined. - jim*.{h,c}: use HAVE_LONG_LONG_INT definition from config.h. - jim.h: Remove hard-coded const and HAVE_LONG_LONG definitions. - jim.h: -DJIM_NO_CONST has been obsoleted; -Dconst is equivalent. git-svn-id: svn://svn.berlios.de/openocd/trunk@1744 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 9d6c90f6..4243e668 100644
--- a/configure.in
+++ b/configure.in
@@ -816,6 +816,10 @@ AM_PROG_CC_C_O
AC_PROG_RANLIB
AC_PROG_LIBTOOL
+dnl configure checks required for Jim files (these are obsolete w/ C99)
+AC_C_CONST
+AC_TYPE_LONG_LONG_INT
+
# Look for environ alternatives. Possibility #1: is environ in unistd.h or stdlib.h?
AC_MSG_CHECKING([for environ in unistd.h and stdlib.h])
AC_COMPILE_IFELSE([